You are Here:
Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.



[ SOLVED ] autohide the panel

Author (Read 3537 times)

0 Members and 1 Guest are viewing this topic.

autohide the panel
« on: February 14, 2016, 11:02:38 PM »
 

chicknfangz

  • New to Forums
  • *
  • 30
    Posts
  • Country: 00
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 2.8 64bit

  • CPU: i7 2600k 3.4ghz

  • MEMORY: 16Gb

  • VIDEO CARD: EVGA GTX 760
Hi guys here at linux lite

Is there a way to autohide the panel  just when firefox opens so it does not completey disappear

I like the penal there but it gets in the way when Firefox opens
Last Edit: February 17, 2016, 03:46:23 AM by chicknfangz
I love my chicken and my popcorn and movies like i like Linux
 


Re: autohide the panel
« Reply #1 on: February 14, 2016, 11:47:05 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7022
    Posts
  • Country: nz
  • Reputation: 653
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
I don't think you can set this for just one application. Right click on the panel, Panel > Panel Preferences > Automatically show and hide the panel.
 

Re: autohide the panel
« Reply #2 on: February 15, 2016, 12:14:05 AM »
 

chicknfangz

  • New to Forums
  • *
  • 30
    Posts
  • Country: 00
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 2.8 64bit

  • CPU: i7 2600k 3.4ghz

  • MEMORY: 16Gb

  • VIDEO CARD: EVGA GTX 760
I know regular xfce4 has it. either autohide. Like if you open up firefox the penal wont be there. or another window and you maximize it the panel goes away.

The one that is in the panel if you hit hide it will go away nomatter what even if your corsair above the penal. I like it to stay there if you know what i mean
I love my chicken and my popcorn and movies like i like Linux
 

Re: autohide the panel
« Reply #3 on: February 15, 2016, 02:52:34 AM »
 

chicknfangz

  • New to Forums
  • *
  • 30
    Posts
  • Country: 00
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 2.8 64bit

  • CPU: i7 2600k 3.4ghz

  • MEMORY: 16Gb

  • VIDEO CARD: EVGA GTX 760
If you look here jerry you will see the option i'
m talking about. timeline at 8:41
I love my chicken and my popcorn and movies like i like Linux
 

Re: autohide the panel
« Reply #4 on: February 15, 2016, 06:01:07 AM »
 

LL-user

  • I come here a lot
  • *****
  • 446
    Posts
  • Country: 00
  • Reputation: 213
  • Linux Lite Member

  • Linux Lite: 2.8 64bit
Hi chicknfangz,

The feature you're looking for/ referring to is available in Xfce 4.12. However Linux Lite is currently still using Xfce 4.10.

Maybe a workaround could be the following till Linux Lite upgrades to Xfce 4.12:

a) You right click on the Firefox window title bar and choose "Always on Top". Then you can maximize the window overlapping the panel by dragging the corner with the mouse.

b) In addition you can play with the "Margin" settings for "Workspaces". For example, you could set the margin to 0. Then by maximizing the window via the button in the window title bar it will automatically overlap the panel, so you wouldn't have to drag the corner over it - see a). However all other windows would also overlap the panel when maximized.

Hope that helps and gives you some ideas for an interim solution :)
 

Re: autohide the panel
« Reply #5 on: February 15, 2016, 01:22:45 PM »
 

chicknfangz

  • New to Forums
  • *
  • 30
    Posts
  • Country: 00
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 2.8 64bit

  • CPU: i7 2600k 3.4ghz

  • MEMORY: 16Gb

  • VIDEO CARD: EVGA GTX 760
 :D Thank you LL-user thats most helpful to me. I wasn't where it was on a older release of xfce thanks

This is awesome very helpful


So i guess my question is now to jerry. Are you going to be going with xfce 4.12?  And why did you choose to hold back version of xfce 4.10
I love my chicken and my popcorn and movies like i like Linux
 

Re: autohide the panel
« Reply #6 on: February 15, 2016, 01:38:17 PM »
 

chicknfangz

  • New to Forums
  • *
  • 30
    Posts
  • Country: 00
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 2.8 64bit

  • CPU: i7 2600k 3.4ghz

  • MEMORY: 16Gb

  • VIDEO CARD: EVGA GTX 760
Hi chicknfangz,

The feature you're looking for/ referring to is available in Xfce 4.12. However Linux Lite is currently still using Xfce 4.10.

Maybe a workaround could be the following till Linux Lite upgrades to Xfce 4.12:

a) You right click on the Firefox window title bar and choose "Always on Top". Then you can maximize the window overlapping the panel by dragging the corner with the mouse.

b) In addition you can play with the "Margin" settings for "Workspaces". For example, you could set the margin to 0. Then by maximizing the window via the button in the window title bar it will automatically overlap the panel, so you wouldn't have to drag the corner over it - see a). However all other windows would also overlap the panel when maximized.

Hope that helps and gives you some ideas for an interim solution :)

Ok i tried this way and seems this does not work. I hit always on top like you said. But it does not seem to do anything and this does not stay there
I love my chicken and my popcorn and movies like i like Linux
 

Re: autohide the panel
« Reply #7 on: February 15, 2016, 02:12:18 PM »
 

firenice03

  • Rockin' the FREE World
  • Platinum Level Poster
  • **********
  • 1127
    Posts
  • Country: us
  • Reputation: 222
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880
:D Thank you LL-user thats most helpful to me. I wasn't where it was on a older release of xfce thanks

This is awesome very helpful


So i guess my question is now to jerry. Are you going to be going with xfce 4.12?  And why did you choose to hold back version of xfce 4.10


I can not speak on Jerry's behalf - but searching the forums for XFCE; the following link may lend information to the DEV's decision to keep with xfce 4.10 throughout the 2.x series..
https://www.linuxliteos.com/forums/on-topic/xfce-4-12-to-be-released-next-week!/

LL 4.6 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 4.4 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 

Re: autohide the panel
« Reply #8 on: February 15, 2016, 04:13:52 PM »
 

LL-user

  • I come here a lot
  • *****
  • 446
    Posts
  • Country: 00
  • Reputation: 213
  • Linux Lite Member

  • Linux Lite: 2.8 64bit
Ok i tried this way and seems this does not work. I hit always on top like you said. But it does not seem to do anything and this does not stay there

So what exactly are you hitting on the top? And what do you mean by it does not stay there?

In my setup I can maximize a window either by double clicking on the window title bar or I can click the symbol on the right to maximize it.
 

Re: autohide the panel
« Reply #9 on: February 15, 2016, 04:38:24 PM »
 

chicknfangz

  • New to Forums
  • *
  • 30
    Posts
  • Country: 00
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 2.8 64bit

  • CPU: i7 2600k 3.4ghz

  • MEMORY: 16Gb

  • VIDEO CARD: EVGA GTX 760
Ok i tried this way and seems this does not work. I hit always on top like you said. But it does not seem to do anything and this does not stay there

So what exactly are you hitting on the top? And what do you mean by it does not stay there?

In my setup I can maximize a window either by double clicking on the window title bar or I can click the symbol on the right to maximize it.


What i mean is. i right click the Firefox and hit always on top. But it does not overlap the panel. And when i logout and back in the check mark is gone from always on top i have to click it again. But this is pointless because it doesn't work anyway.

So you say you have the windows and Firefox can overlap the penal Right?. If so then there must be something you have turned else on or something i have turned on that is not allowing me to do this

I got it working. I had to checkmark "don't reserve space on borders" it works But when i close Firefox i have to hit always on top again
Last Edit: February 15, 2016, 05:00:39 PM by chicknfangz
I love my chicken and my popcorn and movies like i like Linux
 

Re: autohide the panel
« Reply #10 on: February 15, 2016, 05:18:03 PM »
 

LL-user

  • I come here a lot
  • *****
  • 446
    Posts
  • Country: 00
  • Reputation: 213
  • Linux Lite Member

  • Linux Lite: 2.8 64bit
That's correct, as soon as you close the window the "Always on Top" setting is gone.

To actually get the maximized window overlap the panel you also need to activate "Don't reserve space on borders" in your panel setting.

It's all not elegant I know :(

Another way to get as much screen estate as possible with Firefox is running it in full screen mode. That might be a lot easier than tweaking all the panel, workspace and window settings. Just hit F11 to activate, and F11 again to deactivate :)
 

Re: autohide the panel
« Reply #11 on: February 15, 2016, 05:25:14 PM »
 

chicknfangz

  • New to Forums
  • *
  • 30
    Posts
  • Country: 00
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 2.8 64bit

  • CPU: i7 2600k 3.4ghz

  • MEMORY: 16Gb

  • VIDEO CARD: EVGA GTX 760
That's correct, as soon as you close the window the "Always on Top" setting is gone.

To actually get the maximized window overlap the panel you also need to activate "Don't reserve space on borders" in your panel setting.

It's all not elegant I know :(

Another way to get as much screen estate as possible with Firefox is running it in full screen mode. That might be a lot easier than tweaking all the panel, workspace and window settings. Just hit F11 to activate, and F11 again to deactivate :)


YES. You have to do all this for this feature. But my point is how can you have this set so i don't have to hit Always on top again and again. Just leave it and away we go. If tyhere is a command i can set or something so when i login and out i don't have to set it again and again
I love my chicken and my popcorn and movies like i like Linux
 

Re: autohide the panel
« Reply #12 on: February 15, 2016, 06:36:53 PM »
 

LL-user

  • I come here a lot
  • *****
  • 446
    Posts
  • Country: 00
  • Reputation: 213
  • Linux Lite Member

  • Linux Lite: 2.8 64bit
 

Re: autohide the panel
« Reply #13 on: February 16, 2016, 01:21:45 PM »
 

chicknfangz

  • New to Forums
  • *
  • 30
    Posts
  • Country: 00
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 2.8 64bit

  • CPU: i7 2600k 3.4ghz

  • MEMORY: 16Gb

  • VIDEO CARD: EVGA GTX 760
OK But then your forced to use compiz :( I have never tried the other one pie i thjink it was??


If anybody knows an easier way or can confirm this way works let me know
I love my chicken and my popcorn and movies like i like Linux
 


Tags:
 


Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.