You are Here:
Linux Lite 4.2 Final has been released. See the Release Announcements Section.



lm-sensors

Author (Read 668 times)

0 Members and 1 Guest are viewing this topic.

lm-sensors
« on: November 03, 2018, 08:39:13 AM »
 

freefreeno

  • New to Forums
  • *
  • 12
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: i5 7200u

  • MEMORY: 8Gb

  • VIDEO CARD: Intel graphics 620
I am having this small issue with fans running too much and I have noticed that sensors only shows me temp and not fan speed so I ran sudo senors-detect but have not finished because the little guide I am following says to not do it if my drivers are built into kernel.(Before you answer, look in your kernel configuration file to see if the drivers are built-in, or are loadable modules. If they are built-in then don't modify /etc/modules. If they are modules, then modify /etc/modules. So basically I am stuck not really knowing if I sould answer yes at the end of sudo sensors-detect or not so any advice would be great.
 


Re: lm-sensors
« Reply #1 on: November 15, 2018, 05:05:53 PM »
 

Moltke

  • I come here a lot
  • *****
  • 392
    Posts
  • Country: ve
  • Reputation: 60
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750
Hi @freefreeno

As I see it, you might try these two options and see whether one or the other does what you want since both claim to do it

https://openhardwaremonitor.org/

https://github.com/amanusk/s-tui
Without each others help there ain't no hope for us :)
 

Re: lm-sensors
« Reply #2 on: November 26, 2018, 02:41:20 PM »
 

freefreeno

  • New to Forums
  • *
  • 12
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: i5 7200u

  • MEMORY: 8Gb

  • VIDEO CARD: Intel graphics 620
I am still looking for a simple way to turn fans down in linux. My laptop runs very very cool so the fans shouldnt be running.
iwlwifi-virtual-0
Adapter: Virtual device
temp1:        +44.0C 

pch_skylake-virtual-0
Adapter: Virtual device
temp1:        +32.5C 

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +36.0C  (high = +100.0C, crit = +100.0C)
Core 0:        +36.0C  (high = +100.0C, crit = +100.0C)
Core 1:        +35.0C  (high = +100.0C, crit = +100.0C)

At those temps my fans should never kick on the way I see it.
 

Re: lm-sensors
« Reply #3 on: November 26, 2018, 03:07:10 PM »
 

trinidad

  • Gold Level Poster
  • *******
  • 860
    Posts
  • Country: us
  • Reputation: 158
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.2 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D
Think CPU performance not temperature. In the BIOS there are settings to choose optimizing CPU performance.Choosing the highest performance level defaults the fans to either run all the time, or at the least to run a lot more because the CPU is expected to work harder especially with video. It is common on Dells with skylake or older CPUs.Choose the in between setting for CPU performance,which is usually the one involving power saving. Linux ACPI support is not complete by any estimation for skylake CPUs and there is no real community interest as the issues are always minor. Generally BIOS binaries control the OEM fans on Intel stuff, an issue that is often not resolvable with software. It's basically a non issue on newer more expensive machines because there are Linux compatible add-on PCI fan controllers available for purchase for big gamer machines etc.   

TC
"You can't depend on your eyes when your imagination is out of focus."
 

Re: lm-sensors
« Reply #4 on: December 01, 2018, 12:15:53 PM »
 

freefreeno

  • New to Forums
  • *
  • 12
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: i5 7200u

  • MEMORY: 8Gb

  • VIDEO CARD: Intel graphics 620
Just answeing your post. Like I said laptops do not have settings like you are talking abut in the bios. You will never find a setting like that in a laptop bios.
I am on a Lenovo Yoga laptop and me and alot of people will find that the default thermald config is not working on our laptops. My fans are running even when I am at 36 c and I have done left ths distro once because of this and I don't want to leave again. I am using the uefi test addition and love it if I could reduce the wear and tear on fans. There needs to be a tutorial on adjusting thermald config xml file to your laptop.
Last Edit: December 01, 2018, 12:21:50 PM by freefreeno
 


Tags:
 


Linux Lite 4.2 Final has been released. See the Release Announcements Section.