Linux Lite Forums

Hardware - Support => Other => Topic started by: icedigger on May 07, 2019, 08:11:16 AM

Title: LL 4.4 on Alienware 13 R2 and some things not working correctly
Post by: icedigger on May 07, 2019, 08:11:16 AM
I have a Alienware 13 R2 w/OLED screen, i7 6500u, 16GB DDR3, Intel HD 520, NVidia GTX 965M, Killer E2400 NIC, Killer 1535 Wifi/BT, and 2x M.2 NVME drives

It is running LL 4.4

The issues I have are the screen brightness I can't turn down.

The touchpad gets really strange as it jumps and freezes.

The battery time lasts under 2hrs but while in windows lasts almost 6-7hrs.

Attached system report.

Title: Re: LL 4.4 on Alienware 13 R2 and some things not working correctly
Post by: Jerry on May 07, 2019, 08:29:27 AM
All fixable. There are a ton of Alienware linux hacks on the internet. Just Google search your make and model with the word Ubuntu and you're good to go. Also consider attaching a Lite System Report to your post.
Title: Re: LL 4.4 on Alienware 13 R2 and some things not working correctly
Post by: icedigger on May 09, 2019, 02:07:41 PM
Attached system report.

Everything now works except the brightness for the OLED screen.  None of the tutorials worked.
Title: Re: LL 4.4 on Alienware 13 R2 and some things not working correctly
Post by: Jerry on May 10, 2019, 01:24:12 AM

Everything now works except the brightness for the OLED screen.  None of the tutorials worked.

How does everything work suddently when it didn't before?

Brightness, try this - https://itsfoss.com/fix-brightness-ubuntu-1310/ (https://itsfoss.com/fix-brightness-ubuntu-1310/)

Also - https://www.reddit.com/r/Alienware/comments/5l57hu/aw13_r3_oled_ubuntu_everything_good_but_the/dc7wcvd/ (https://www.reddit.com/r/Alienware/comments/5l57hu/aw13_r3_oled_ubuntu_everything_good_but_the/dc7wcvd/)

Extra options:

https://github.com/LordAmit/Brightness (https://github.com/LordAmit/Brightness)

Try our 5.1 kernel.
Title: Re: LL 4.4 on Alienware 13 R2 and some things not working correctly
Post by: icedigger on May 20, 2019, 01:11:12 PM
Apparently a lot of revisions for the firmware on the thunderbolt port made a HUGE help for the dell TB16 docking station!