You are Here:
Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section



Keyboard Layout Problem.

Author (Read 14459 times)

0 Members and 4 Guests are viewing this topic.

Re: Keyboard Layout Problem.
« Reply #23 on: July 30, 2023, 09:07:48 AM »
 

karlheinz

  • New to Forums
  • *
  • 13
    Posts
  • Reputation: 2
  • Linux Lite Member
    • View Profile

  • CPU: AMD A10

  • MEMORY: 8Gb
Hallo! Ich habe LL6.4 mehrfach neu installiert. Bei der Installation ist Chrome als Browser dabei, den hatte ich auch in Windows. Der funktioniert, Firefox ist möglicherweise ein "Snap" der Probleme bereitet. Viel Erfolg ! K.H.
 

Re: Keyboard Layout Problem.
« Reply #22 on: July 30, 2023, 07:58:59 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
Many thanks for all the time you've spent on this. I've not got a System Restore as the problem started right from the beginning. I'll try a re-install, and see if the issues I'm having with Firefox will disappear as well.
 

Re: Keyboard Layout Problem.
« Reply #21 on: July 25, 2023, 05:43:01 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
I'm out of ideas as to why your system is fixed on using what is probably a us keyboard layout.
All the locations I can think of where the keyboard layout is noted point at a gb layout.  Clearly I am missing something.

The absence of the pictogram on the GUI settings screen is one possible avenue to explore, but beyond my scope.   

If you have snapshots made using 'System Restore  Utility' (aka timeshift) you could try rolling back, but it maybe time to re-install.
clueless
 

Re: Keyboard Layout Problem.
« Reply #20 on: July 25, 2023, 03:57:27 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="gb"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"
 

Re: Keyboard Layout Problem.
« Reply #19 on: July 24, 2023, 07:51:27 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
 The keyboard problem was there right from the start. I can't remember where I found the many keyboard options available.

I've just realised I'm on a Windows machine; I'll do the Terminal command tomorrow morning.

Just to let you know, I'll be going away tomorrow around midday for about a week and will have no Internet access.
 
 

Re: Keyboard Layout Problem.
« Reply #18 on: July 24, 2023, 06:17:45 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
I could only speculate why your Settings screen is locked and missing the on/off pictogram.  Do you remember if it ever looked correct and worked ?  For example, in your first post you mentioned looking at the many keyboard options available.  Was this using the Setting screen ?

No explicit response expected from the CLI to the set command, but if the 'before' query had shown the map to be 'us', then the set command should have set it to 'gb' which would have been shown in the 'after' query and hopefully corrected the keyboard mapping for the session.

One more place to check.  Please post back with the result of
Code: [Select]
cat /etc/default/keyboard
From what you've posted so far I'd expect this will show the layout to be 'gb' as well but worth a check.

clueless
 

Re: Keyboard Layout Problem.
« Reply #17 on: July 24, 2023, 04:13:18 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
The ON/OFF slider is not present. I've done this before, but a useful double check.

 setxkbmap -query
rules:      evdev
model:      pc105
layout:     gb

setxkbmap gb                    No response-goes back to the cursor.



 

Re: Keyboard Layout Problem.
« Reply #16 on: July 23, 2023, 06:30:51 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
Just to be 100% clear, the settings layout screen should look something like this.
The mouse pointer in the image is indicating the position of the 'Use Default Settings' on/off slider.
With the pictogram switch set to the left, it is possible to make changes.



If I've understood correctly, you don't see the on/off slider pictogram at all.
Your system operates as if 'Use System Defaults' is set to ON and enforcing the US keyboard layout.

Even with 'Use System Defaults' ON, it should be possible to set the keyboard layout to 'gb' temporarily (for duration of the session) to 'gb' from the CLI.  I think I asked you to check this but please can you run these commands and post back.

Code: [Select]
setxkbmap -query
Code: [Select]
setxkbmap gb
Code: [Select]
setxkbmap -query




clueless
 

Re: Keyboard Layout Problem.
« Reply #15 on: July 23, 2023, 05:14:55 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
 The property 'XkbDisable' (Type boolean). Value box is not ticked; has GB above it. The locked value box is also unticked.
 

Re: Keyboard Layout Problem.
« Reply #14 on: July 23, 2023, 05:05:15 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
That's odd. We're looking for a pictogram of an on/off type slider switch over on the right, level with the 'Use System Defaults' text.  As you don't have that pictogram, go back to 'Settings Manager' and under the 'other' section at the bottom click 'Settings Editor'

On the resulting screen, highlight the 'keyboard-layout' line

In the line 'Default' is there a tick in the locked box ?
If necessary, expand the 'Default' entry by clicking on the triangle.
Look for the property 'XkbDisable' (Type boolean).
Is the Value box is ticked or not.
clueless
 

Re: Keyboard Layout Problem.
« Reply #13 on: July 23, 2023, 04:32:39 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
There are the words "Use System Defaults" but no slider.
 

Re: Keyboard Layout Problem.
« Reply #12 on: July 23, 2023, 04:08:43 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
Quote
I've done Settings Manager> Keyboard Icon> Layout, and there is no slider or selectable options on this page. Clicking any of the headings does nothing.

Just below where you select the tabs when viewing the 'Layout' tab, there should be the words 'Use System Defaults' on the upper left side and level with that over on the right there should be an an on/off slider switch type selector.

Do you not have this at all ?
clueless
 

Re: Keyboard Layout Problem.
« Reply #11 on: July 23, 2023, 03:53:55 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
I've done Settings Manager> Keyboard Icon> Layout, and there is no slider or selectable options on this page. Clicking any of the headings does nothing.
 

Re: Keyboard Layout Problem.
« Reply #10 on: July 22, 2023, 06:51:41 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 749
    Posts
  • Reputation: 141
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
Quote
Would you recommend a re-install?
Not yet.

Let's go back to the GUI for a moment.
Quote
I can't turn "Use System Defaults" off

What exactly do you mean here ?

On my desktop, 'Use System Defaults' set to ON means the slider is to the right (with a blue background) and the options to change anything are greyed out.  To turn it off, I click the slider to the left, the blue goes to grey and the options are enabled.

Can you confirm your settings GUI is stuck with Use System Defaults being ON
« Last Edit: July 23, 2023, 01:41:07 AM by stevef »
clueless
 

Re: Keyboard Layout Problem.
« Reply #9 on: July 22, 2023, 05:55:32 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
Many thanks for your time on this. Would you recommend a re-install? If so, is there anything I have to watch for when reinstalling on top of the old LL6.4 with Mint installed on the same PC? (I want to keep Mint, for the time being).
 

 

-->
X Close Ad

Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section