You are Here:
Linux Lite 7.0 Final Released - See Release Announcement Section



Keyboard Layout Problem.

Author (Read 22537 times)

0 Members and 2 Guests are viewing this topic.

Re: Keyboard Layout Problem.
« Reply #8 on: July 22, 2023, 05:13:41 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 915
    Posts
  • Reputation: 162
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
Not sure what is going on then.  Just checked on a LL 6.4 system with a UK keyboard and UK mapping.
First showing the current mapping, then switching to to us mapping, repeat show the mapping and test with shift3.
Then revert to gb mapping and show and test again.

Code: [Select]
stevef>setxkbmap -query
rules:      evdev
model:      pc105
layout:     gb
stevef>
stevef>setxkbmap us
stevef> setxkbmap -query
rules:      evdev
model:      pc105
layout:     us
stevef>###
stevef>setxkbmap gb
stevef>
: command not found
stephen>setxkbmap -query
rules:      evdev
model:      pc105
layout:     gb
stevef>
clueless
 

Re: Keyboard Layout Problem.
« Reply #7 on: July 22, 2023, 03:59:29 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
Nothing happens when using the command.

In the meantime I installed Mint xfce alongside LL to see if there's anything odd in my PC or brain. There is no keyboard issue here (nor the Firefox issues I'm having as well with LL6.4-a separate topic).
 

Re: Keyboard Layout Problem.
« Reply #6 on: July 21, 2023, 06:46:27 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 915
    Posts
  • Reputation: 162
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
There are some quirks in xfce desktop.  It can get confused if you change using the GUI and end up out of step.
Having one layout set by the GUI usually works, but something is awry here.

Try using the command

Code: [Select]
setxkbmap gb
Then check again.
clueless
 

Re: Keyboard Layout Problem.
« Reply #5 on: July 21, 2023, 06:32:24 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
Hi Stevef,

The following comes back from     setxkbmap -query:

rules:      evdev
model:      pc105
layout:     us

LL settings tells me I have a UK keyboard (I've rechecked this), terminal (and the wrong key settings) indicate a US keyboard! It amazes me how people learn all these Terminal commands, etc. Expertise, I guess. I only use a few.

ean
 

Re: Keyboard Layout Problem.
« Reply #4 on: July 21, 2023, 05:51:33 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 915
    Posts
  • Reputation: 162
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
What is reported if you open a terminal and enter the following command ?

Code: [Select]
setxkbmap -query
clueless
 

Re: Keyboard Layout Problem.
« Reply #3 on: July 21, 2023, 05:12:57 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
Hi Stevef,

Many thanks for your fast reply. When shift 3 is pressed, I get a #. I can't turn "Use System Defaults" off; on clicking this nothing happens. English UK is the sole option shown under keyboard layout.

Ean.
 

Re: Keyboard Layout Problem.
« Reply #2 on: July 21, 2023, 04:41:54 AM »
 

stevef

  • Global Moderator
  • Gold Level Poster
  • *****
  • 915
    Posts
  • Reputation: 162
  • Linux Lite Member
    • View Profile

  • CPU: Intel Core i5-4460

  • MEMORY: 16Gb

  • Kernel: 5.x
Try this

Click Menu
Begin typing 'settings manager' into the search bar
When you see Settings Manager offered, click it
Under Hardware, click 'Keyboard'
Select the Layout tab
Ensure 'Use system defaults' is off
Under 'Keyboard model' the Generic option should be ok

Under 'Keyboard layout'
Check your keyboard marking for shift 3.
If it is a '' symbol, then
If English (UK) is not present, use 'Add' to put it in the list.
Once English (UK) is in the list, highlight and remove other layouts leaving just one.
Close
This may change dynamically, but reboot if it doesn't.
clueless
 

Keyboard Layout Problem.
« Reply #1 on: July 21, 2023, 04:20:09 AM »
 

Ean

  • New to Forums
  • *
  • 37
    Posts
  • Reputation: 1
  • Linux Lite Member
    • View Profile

  • CPU: 2.4GHz Dual core, 3.3GHz i3 dual core

  • MEMORY: 4Gb

  • VIDEO CARD: ON-BOARD
Hi, I've recently installed LL6.4 and have had a couple of problems which weren't present in 5.x. The PC is a dual core 3GHz CPU with 4Gb DDR3 RAM.

Here, the Keyboard characters @ and" are transposed, and I installed LL6.4 with a UK keyboard, Generic 105 Key, using the same keyboard and PC as with the earlier LL5.x installation. The problem persists after a reboot. There may be other wrong keys which I haven't discovered. I examined the many keyboard options available in LL, but the existing setting is by far the best apparent match. Please advise.

Many thanks, Ean.
 

 

-->
X Close Ad

Linux Lite 7.0 Final Released - See Release Announcement Section