You are Here:
Download Linux Lite 5.2 today - See Release Announcements



platform-tools flash-all returns command not found, Please Help

Author (Read 1571 times)

0 Members and 3 Guests are viewing this topic.

platform-tools flash-all returns command not found, Please Help
« on: September 07, 2020, 07:23:48 PM »
 

+Me

  • New to Forums
  • *
  • 4
    Posts
  • Country: nz
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: 2.0 GHz i5

  • MEMORY: 12Gb

  • VIDEO CARD: intel HD Graphics 4600
Hardware = HP EliteDesk 800 G1 DM, 2 GHz i5, 12 GB RAMemory, 1TB Sata, intel HD Graphics 4600

Fully Updated X64 bit Linux-Lite 5

I've Navigated 2 the Location of platform-tools ie. /home/linux-lite/platform-tools Checked that adb iz Running, Confirmed that it Detects the Pixel 2 Phone, I've Copied All the GrapheneOS image Files to inside the platform-tools Directory & Clicked on flash-all.bat it Opens MousePad & when I Click on flash-all.sh Nutthing happens.

From the Linux-Lite Terminal, I cd /home/linux-lite/platform-tools/flash-all it Returns command not found same w/ .bat & .sh eXtensions. Also in All cases I there's a Maroon Red Flag w/ 127 inside I don't know what this means.

Please Help!

;-)K


Last Edit: September 07, 2020, 09:35:49 PM by +Me
 


Re: platform-tools flash-all returns command not found, Please Help
« Reply #1 on: September 08, 2020, 12:58:20 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1464
    Posts
  • Country: us
  • Reputation: 258
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
I've Navigated 2 the Location of platform-tools ie. /home/linux-lite/platform-tools Checked that adb iz Running, Confirmed that it Detects the Pixel 2 Phone, I've Copied All the GrapheneOS image Files to inside the platform-tools Directory & Clicked on flash-all.bat it Opens MousePad & when I Click on flash-all.sh Nutthing happens.

From the Linux-Lite Terminal, I cd /home/linux-lite/platform-tools/flash-all it Returns command not found same w/ .bat & .sh eXtensions. Also in All cases I there's a Maroon Red Flag w/ 127 inside I don't know what this means.

@+Me

1st off the .bat will error as you have seen - .bat are Windows executable files.
The .sh - should work for but may not have the "x" permission (making it executable) - this can be seen if in the terminal ls -la 'the file' on the left you'll see wr-wr-wr- ... or similar (no X)

You can right click the file too - while having properties open - click the box for make executable.
OR in terminal (add path to file name as needed)
Code: [Select]
sudo chmod +x FILENAME
LL 4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 

Re: platform-tools flash-all returns command not found, Please Help
« Reply #2 on: September 08, 2020, 11:00:40 PM »
 

+Me

  • New to Forums
  • *
  • 4
    Posts
  • Country: nz
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: 2.0 GHz i5

  • MEMORY: 12Gb

  • VIDEO CARD: intel HD Graphics 4600
Thanx FireNice03 4 your Support, Sorry this izn't happening 4 me, Please Check the Attached ScreenShot & let me know wot I've done wRong!

;-)K
 

Re: platform-tools flash-all returns command not found, Please Help
« Reply #3 on: September 14, 2020, 05:45:59 PM »
 

+Me

  • New to Forums
  • *
  • 4
    Posts
  • Country: nz
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: 2.0 GHz i5

  • MEMORY: 12Gb

  • VIDEO CARD: intel HD Graphics 4600
Please Please Help!

Wot eLse Can I Do?

;-)K
 

Re: platform-tools flash-all returns command not found, Please Help
« Reply #4 on: September 14, 2020, 08:31:32 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1464
    Posts
  • Country: us
  • Reputation: 258
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
Thanx FireNice03 4 your Support, Sorry this izn't happening 4 me, Please Check the Attached ScreenShot & let me know wot I've done wRong!

;-)K


@+Me
1st read up on proper way of posting an image - You will get faster responses, kinda of suspicious of downloading zipped image files ;)

It doesn't know your command - well it thinks its a command -- its a script.
In that directory try with a leading ' ./ '  -- so
Code: [Select]
./flash-all.sh
LL 4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 

Re: platform-tools flash-all returns command not found, Please Help
« Reply #5 on: September 15, 2020, 02:00:17 AM »
 

+Me

  • New to Forums
  • *
  • 4
    Posts
  • Country: nz
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: 2.0 GHz i5

  • MEMORY: 12Gb

  • VIDEO CARD: intel HD Graphics 4600
Thanx again FireNice03, I've Advanced another step, w/ that ./

But Unfortunately the fastboot --version iz too Old... so I've Updated it, However Now I'm having Challenges w/ Setting the PATH Variable & I'm getting not a valid identifier Message.

Sorry I don't know about How 2 Post an image on this Forum???...

;-)K
 

Re: platform-tools flash-all returns command not found, Please Help
« Reply #6 on: September 15, 2020, 09:27:20 AM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1464
    Posts
  • Country: us
  • Reputation: 258
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
LL 4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 


Tags:
 


Download Linux Lite 5.2 today - See Release Announcements