You are Here:
Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.



Firefox 63.0 -unable to stop HTML5 videos from auto playing in this release

Author (Read 1014 times)

0 Members and 2 Guests are viewing this topic.

 

Ottawagrant

  • Forum Regular
  • ***
  • 182
    Posts
  • Country: ca
  • Reputation: 28
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • CPU: Intel Duo Core 2 E8400 @ 3.00GHz

  • MEMORY: 12Gb

  • VIDEO CARD: Mesa DRI Intel Q45/Q43
I don't really like these popup & auto playing videos so many sites like to use. In Firefox it could be stopped by going to about:config & toggling media.autoplay.enabled to false. In Mozillas latest release of Firefox (v.63.0) it's not working. Even with it toggled to false the popup's still appear & auto play in v.63.0. Anyone have a suggestion to fix this, without resorting to a 3rd party app? Thanks for any & all help.
 


 

trinidad

  • Gold Level Poster
  • *******
  • 970
    Posts
  • Country: us
  • Reputation: 174
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.4 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D
Disable the video extensions.

TC
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

 

Ottawagrant

  • Forum Regular
  • ***
  • 182
    Posts
  • Country: ca
  • Reputation: 28
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • CPU: Intel Duo Core 2 E8400 @ 3.00GHz

  • MEMORY: 12Gb

  • VIDEO CARD: Mesa DRI Intel Q45/Q43
A good suggestion. A problem is that HTML5 video can come in many forms. OGG, H264, etc. Depending on what codec the website used. I did find more information here:https://www.ghacks.net/2018/09/21/firefox-improved-autoplay-blocking/and it makes perfect sense. It seems that clicking media.autoplay.enabled in about:config no longer works as of Firefox 63. I did find a workaround by entering media.autoplay.default and changing the default value from '0' to '1' (autoplay blocked). The videos still appear, but they don't autoplay. So until Firefox 64 comes out, it's a good solution for now. Thanks for your suggestion as it would as well.
 


Tags:
 


Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.