You are Here:
Linux Lite 4.0 Final has been released. See the Release Announcements Section.




Wireless Connection

Author (Read 303 times)

0 Members and 1 Guest are viewing this topic.

Wireless Connection
« on: July 05, 2018, 10:25:43 AM »
 

hackneydave

  • New to Forums
  • *
  • 6
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: Pentium M 1.73 Ghz

  • MEMORY: 2Gb
I have a Dell Latitude D610 running Linux Lite 3.8. My primary network connection is through a USB NIC dongle. See output following:

Bus 001 Device 002: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

The performance on the RTL dongle is good but when the system starts BIOS also starts up a PCI card with the old Dell b/g wireless connection. At restart, both of the wireless connections start and internet access slows substantially.  I have to manually disconnect the Dell card so that the dongle works properly.

I tried to switch off the WIFI in BIOS but then it also disables the RTL adapter and there is no network connection. Short of removing the original Dell WIF card, is there a way to disable it at login so that I just use the USB RTL adapter?

Thanks for your help.
 


Re: Wireless Connection
« Reply #1 on: July 05, 2018, 12:17:56 PM »
 

DeepThought

  • New to Forums
  • *
  • 42
    Posts
  • Country: wales
  • Reputation: 8
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
Hi @hackneydave

An easy way is to prevent the pci card from auto connecting.


1) left click on your network icon in the panel and choose "Edit Connections" should be at the bottom
2) Under wifi you will see 2 possible connections, you'll have to decide which is your pci card and which is your dongle, but trial and error will do no harm, you can always undo the following if it is the wrong card
3) double click on one wifi card to edit it
4) click on the General tab and untick the box at the top that says to Automatically connect when available
5) close the dialog and reboot
6) only one card should now be connected, left click on your network icon again and you should be able to tell which wifi card is not connected. If it is the wrong one just repeat the above but tick the box this time, then untick the box for the other card.

Just tried this on my Dell Inspiron 1501 laptop with onboard and usb dongle and it works :)

DeepThought
 

Re: Wireless Connection
« Reply #2 on: July 06, 2018, 12:36:47 AM »
 

hackneydave

  • New to Forums
  • *
  • 6
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: Pentium M 1.73 Ghz

  • MEMORY: 2Gb
A big thank you, Deep Thought. Your suggestion worked, though it took a bit of time as I have multiple APs running. Your help, and that of the Linux Lite and Ubuntu communities have helped me turn a 13-year old clunker into a productive general office machine and a great learning tool.
 

Re: Wireless Connection
« Reply #3 on: July 06, 2018, 02:14:32 AM »
 

DeepThought

  • New to Forums
  • *
  • 42
    Posts
  • Country: wales
  • Reputation: 8
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
@hackneydave   That's great, glad to help :)
 


Tags:
 


Linux Lite 4.0 Final has been released. See the Release Announcements Section.