Hardware - Support > Network

Wifi unavailable

<< < (2/2)

Username Ace:
Thank you for the responses.

I tried loading the previous OS using a disc. And the driver that I needed to update was "rlt8187." I followed this link to help me install the driver: "https://github.com/Dekadencee/rtl8187-Linux-Driver#readme." However, I do not know why the wifi still does not connect.


This is also what followed after inputting these commands:

--- Code: ---Hardware Lister (lshw) - B.02.17
usage: lshw [-format] [-options ...]
       lshw -version

   -version        print program version (B.02.17)

format can be
   -html           output hardware tree as HTML
   -xml            output hardware tree as XML
   -short          output hardware paths
   -businfo        output bus information

options can be
   -class CLASS    only show a certain class of hardware
   -C CLASS        same as '-class CLASS'
   -c CLASS        same as '-class CLASS'
   -disable TEST   disable a test (like pci, isapnp, cpuid, etc. )
   -enable TEST    enable a test (like pci, isapnp, cpuid, etc. )
   -quiet          don't display status
   -sanitize       sanitize output (remove sensitive information like serial numbers, etc.)
   -numeric        output numeric IDs (for PCI, USB, etc.)

--- End code ---

--- Code: ---Command: inxi -n
Network:   Card-1: VIA VT6102/VT6103 [Rhine-II] driver: via-rhine
           IF: enp0s18 state: down mac: 00:90:f5:59:b0:d8
           Card-2: Realtek RTL8187 Wireless Adapter
           IF: N/A state: N/A mac: N/A

--- End code ---

--- Code: ---Command: sudo lsusb
Bus 001 Device 002: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
--- End code ---

--- Code: ---Command: rfkill list all
This does not show anything.
--- End code ---

@Username Ace -- is this an internal or USB wifi adapter?
May want to provide the output of the following commands for better assistance./

--- Code: ---sudo lshw -C network

inxi -n

sudo lsusb

sudo lspci

rfkill list all
--- End code ---

Some BIOS/UEFI screens list the WiFi adapter.
Laptop manual/documentation may have some FCC compliance data regarding the adapter which may give a clue

Some laptops have a switch/setting on the laptop that disables WiFi - could be accidentally active
Have a look through the dmesg log for anything suspicious
Search the internet for your laptop model spec
If you tried Linux Lite from a live source (before installing) and the WiFi worked give that another try and determine hardware.
Try using a live source of your previous OS or any other bootable USB/CD and determining your adapter type from there.

Username Ace:
I need assistance with connecting my laptop to the internet via Wifi.

I recently installed Linux Lite on my computor from it's Ubuntu operating system. The wifi would connect properly without problem on it's previous operating, however,  I cannot connect to the internet via wifi unless it's through the Ethernet cable.

I ran this command "nmcli d" in the terminal which showed that through the Ethernet, I can access the internet, whilst the wifi status remains unavailable.

I also ran this command "lshw -c network" so that I can figure out the hardware adapter, so that I can update the driver. But, it does not show the hardware name for the wifi adapter.

Any assistance will help me out a lot.


[0] Message Index

[*] Previous page

Go to full version