You are Here:
Install Updates Gimp Error - see Security & Bug Fixes Section Sticky



[ SOLVED ] Lite 4.4 install - no support for Intel AC3165 wifi

Author (Read 1210 times)

0 Members and 4 Guests are viewing this topic.

Lite 4.4 install - no support for Intel AC3165 wifi
« on: August 23, 2019, 04:51:05 AM »
 

frank4360

  • New to Forums
  • *
  • 7
    Posts
  • Country: fr
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.0 64bit

  • CPU: Intel Celeron N2930 (plus other computrrs)

  • MEMORY: 4Gb
Hello
I have just bought a Lenovo Ideapad, specifically to take abroad as it is so small and light. It has an Intel dual wifi/bluetooth chip, the AC3165, but there is no RJ45 Ethernet port, and so everything must be done by WiFi.
Unfortunately, LinuxLite 4.4 64bit install does not have a driver for the AC3165. Which is odd, because the 3165 has been around a long time (for example, it is recognised by the Puppy Linux install process).
After installing LinuxLite there is no way I can download the relevant driver, as there is no wifi or cable connection.
I am looking into downloading a driver on another system and loading this, but why not add support into the installation procedure, particularly as the OS is otherwise good for low spec computers?
Last Edit: August 24, 2019, 12:38:54 PM by frank4360
 


Re: Lite 4.4 install - no support for Intel AC3165 wifi
« Reply #1 on: August 23, 2019, 07:07:32 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7129
    Posts
  • Country: nz
  • Reputation: 669
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Puppy Linux use a newer kernel. Install a newer kernel. Get our 5.2 kernel from here - http://repo.linuxliteos.com/linuxlite/pool/main/l/lite-kernel/linux-headers-linuxlite-5.2.0_0010_amd64.deb & http://repo.linuxliteos.com/linuxlite/pool/main/l/lite-kernel/linux-image-linuxlite-5.2.0_0010_amd64.deb on another pc. Transfer the files onto a USB. Plug the USB into your AC3165 laptop, open a terminal in that USB folder and do: sudo dpkg -i *.deb. Reboot after install has finished.
 

Re: Lite 4.4 install - no support for Intel AC3165 wifi
« Reply #2 on: August 24, 2019, 12:38:19 PM »
 

frank4360

  • New to Forums
  • *
  • 7
    Posts
  • Country: fr
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.0 64bit

  • CPU: Intel Celeron N2930 (plus other computrrs)

  • MEMORY: 4Gb
Thanks Jerry, the new kernel has solved the problem!
However, during the running of dpkg a few error messages appeared - they were:-

Selecting previously unselected package linux-image-linuxlite-5.2.0.
Preparing to unpack linux-image-linuxlite-5.2.0_0010_amd64.deb ...
Unpacking linux-image-linuxlite-5.2.0 (0010) ...
Setting up linux-headers-linuxlite-5.2.0 (0010) ...
Setting up linux-image-linuxlite-5.2.0 (0010) ...
ERROR (dkms apport): kernel package linux-headers-5.2.0 is not supported
Error! Bad return status for module build on kernel: 5.2.0 (x86_64)
Consult /var/lib/dkms/virtualbox-guest/5.2.18/build/make.log for more information.

update-initramfs: Generating /boot/initrd.img-5.2.0
W: Possible missing firmware /lib/firmware/i915/icl_dmc_ver1_07.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_huc_ver01_8_2893.bin for module i915
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel modules.
VirtualBox Guest Additions: Look at /var/log/vboxadd-setup.log to find out what went wrong

Sourcing file `/etc/default/grub'
Generating grub configuration file ...
Found background: /boot/grub_linux_lite.png
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found background image: /boot/grub_linux_lite.png
Found linux image: /boot/vmlinuz-5.2.0
Found initrd image: /boot/initrd.img-5.2.0
Found linux image: /boot/vmlinuz-4.15.0-45-generic
Found initrd image: /boot/initrd.img-4.15.0-45-generic
Found linux image: /boot/vmlinuz-4.15.0-38-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Windows Recovery Environment on /dev/sda1
Found Ubuntu 14.04.5 LTS (14.04) on /dev/sda8
done


All is running well now - thanks again.
 

Re: Lite 4.4 install - no support for Intel AC3165 wifi
« Reply #3 on: August 24, 2019, 09:06:27 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7129
    Posts
  • Country: nz
  • Reputation: 669
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Errors are safe to ignore. Have fun :)

Sent from my Phone using Tapatalk

 


Tags:
 


Install Updates Gimp Error - see Security & Bug Fixes Section Sticky