You are Here:
Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.



[ SOLVED ] Wifi ok on DVD boot, fails when installed

Author (Read 458 times)

0 Members and 2 Guests are viewing this topic.

Wifi ok on DVD boot, fails when installed
« on: July 20, 2019, 07:06:30 PM »
 

Davide Barranca

  • New to Forums
  • *
  • 2
    Posts
  • Reputation: 0
Hello,
I have the strangest of problems.
I'm installing Linux Lite on my mother's old laptop: I've burned the 3.8 ISO on a DVD (for the machine doesn't accept USB boot, and it's 32bit) and runned the OS from the DVD: flawless WiFi out-of-the-box.

Partitioning, formatting and installing the OS on the HD brings me a grayed out "Wi-Fi Networks" and "Wi-Fi is disabled by hardware switch" flyout menu. Now, it is true that the HP Compaq Presario CQ60 has a physical button that switches on/off the WiFi, but:
  • Pushing the button has no effect it is always retro-illuminated, which should mean it's on
  • It was retro-illuminated by default when the Linux was running from the DVD anyway

I am a bit puzzled.
In case it helps, I've run inxi -Nn and the result is a Realtek RTL8101/2/6E for Ethernet, and Qualcomm Atheros AR242x / AR542x for the wifi; driver: ath5k; IF: wlp3s0; state: down.

The output of sudo rfkill list is:

0: phy0: Wireless LAN
              Soft blocked: no
              Hard blocked: yes
1: hp-wifi: Wireless LAN
              Soft blocked: no
              Hard blocked: yes

So, to my newbie eyes, the OS fails to understand that the Wifi is already switched on... maybe? And why hadn't had any problem when running from DVD?

Thanks in advance for any guidance you can provide please remember that I have zero experience with this stuff :)

Davide
Last Edit: July 21, 2019, 03:54:23 AM by Davide Barranca
 


Re: Wifi ok on DVD boot, fails when installed
« Reply #1 on: July 21, 2019, 03:01:09 AM »
 

minesheep

  • Occasional Poster
  • **
  • 60
    Posts
  • Country: fi
  • Reputation: 7
  • Linux Lite Member

  • Linux Lite: 4.4 64bit

  • MEMORY: 4Gb
  • Pushing the button has no effect it is always retro-illuminated, which should mean it's on
  • It was retro-illuminated by default when the Linux was running from the DVD anyway
How could it be always on, even after pushed? It should be a switch to turn wifi on and off.
Tried booting from dvd again for testing?
Tried installing directly from the boot options menu or from live session desktop?
Tried to install updates from the menu with wired connection?
 

Re: Wifi ok on DVD boot, fails when installed
« Reply #2 on: July 21, 2019, 04:02:10 AM »
 

Davide Barranca

  • New to Forums
  • *
  • 2
    Posts
  • Reputation: 0
Hi minesheep,
thanks for responding.

> How could it be always on, even after pushed? It should be a switch to turn wifi on and off.

It's not a switch, nor a toggle button (the kind of which stays pressed down): there's no feedback on the status of the Wifi other than the button backlight being either orange or turned off. And mine is always on, no matter what I do.

I've solved the problem in the most embarrassing way: I gave up yesterday night, and when I booted this morning the wifi decided to be kind with humanity and it worked. I've tried rebooting again and it persists being functional, so I'll call quit on that.
Thanks,

Davide
 


Tags: ar242x ar542x 
 


Linux Lite 4.6 RC1 has been released. See the Release Announcements section for more information.