Hardware - Support > Network

Shutdown Freeze after WPC54GX Ndiswrapper install


Well it looks like I found a solution.

It was on an old thread.
Basically all you have to do is add the following line of code to the /etc/init.d/halt script.

ifconfig wlan0 down
modprobe -r ndiswrapper

The old thread didn't specify where. I put it at the end and did not work. The I put it at the beginning and it worked like a charm.

I hope I am able to help some body.
Good Day!

Hello I added the word ndiswrapper to the end of the file and nothing happened.

Hi, SkylineR34

You might try adding the following to /etc/modules (this is from the Ubuntu wireless wiki, available at: https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper#autostart ):

If you are using the nm-applet to configure Wireless Network, ndiswrapper will not be started by the network manager alias setting. In order to ensure the ndiswrapper module is loaded at system startup. First, make a backup copy of the file:


before manually editing it. Then, edit the /etc/modules file to add an entry for ndiswrapper at the end of the file. In Ubuntu:

gksudo gedit /etc/modules

In Kubuntu:

kdesu kate /etc/modules

and add the word ndiswrapper to the end of this file and save it.

The basic problem is that ndiswrapper is linking to the driver file, and this link needs to be unloaded for "proper" shutdown, otherwise the process will hang as the kernel does not know how to proceed.

I don't know whether this will work but it is worth a try.

Hello All,
After hours of researching I was able to install or make my wireless card work using NDISWRAPPER. Its a Linksys WPC54GX ver. 2 model. I surfed the net like a pro and celebrated with a nice hot chocolate at 2am. When I went to turn the laptop off it just froze. If i pullout the wireless card from the machine it shuts down with no problem.
I am stumped. I am computer savvy but new to linux.
Please Help!


[0] Message Index

Go to full version