Hardware - Support > Network

Remmina Lost RDP Connection


If you can ping through but not completely connect it's probably the Windows firewall settings. You can open port 3389 to public in order to connect through the VPN, but you should change the port RDP uses to something higher above 49000 and allow only three connection attempts. In Windows RDP authentication is through user profiles, so it might work if you just use a different user with RDP permissions for each respective authentication and connection i/e one for through VPN, one for without VPN. Otherwise if you know how you can add a remote-rdp-host address directed through the default gateway (sudo ip route add) in your VPN configuration files to just allow RDP connections through the VPN, kinda like port forwarding, though I'm not sure how you would do that on phone hotspot. Don't use phones that way myself. Interesting topology though.       

winston malcolm:
Thanks for getting back to me.

Regarging the topology, I have  a dedicated Ubuntu machine which is acting as my DHCP server and on which I am running easy-openvpn.
On my palmtop I am running Lite Linux .

So to RDP into  my Windows 10 machine I connect my Lite Linux palmtop to my phone via hotspot ( as I am just testing remote access at the moment), VPN (Lite Linux has a VPN option in the network area) into my Ubuntu easy-open server, and then on my Lite Linux Palmtop use Remmina to RDP into My Win 10

The VPN works fine, stays up and I can ping my Windows machine from my palmtop when connected.
ThenI use Remmina to RDP, I get a black screen and after about 5 seconds the Lost Connection message.

Hope that clarifies a little.

The VPN (set up on Windows) will have a different IP address route than your LAN. Set up two saved connections in Remmina, one over your LAN and the other through the VPN, that way you have a choice to use either one. I can't comment without knowing your net topology, and it depends on the type and setup of your VPN. The issue is not with Remmina.


winston malcolm:
I can RDP from my Lite Linux machine  into a Windows 10 on my local network with no issues , but when I try using a VPN (which appears stable) and my mobile phone as a hotspot I get a 'Remmina lost connection to RDP ' error.

I would appreciate any help.



This window can help you find connection problems.
You can stop and start the logging at any moment using the On/Off switch.
The stats button (Ctrl+T), can be useful to gather system info you may share when reporting a bug.
There is more info about debugging Remmina on https://gitlab.com/Remmina/Remmina/-/wikis/Usage/Remmina-debugging
(DEBUG) - (rcw_map_event) - Mapping: RemminaConnectionWindow
(DEBUG) - (remmina_protocol_widget_map_event) - Calling plugin mapping function
(DEBUG) - (remmina_protocol_widget_open_connection_real) - Opening connection
(DEBUG) - (remmina_rdp_event_init) - Disable smooth scrolling is set to 0
(DEBUG) - (remmina_rdp_event_init) - Adding GDK_SMOOTH_SCROLL_MASK
(DEBUG) - (remmina_protocol_widget_open_connection_real) - Have SSH
(DEBUG) - (remmina_rdp_main) - RDP data path is /home/derith/.local/share/remmina/RDP
(DEBUG) - (remmina_rdp_main) - Not using system proxy settings
(DEBUG) - (remmina_rdp_tunnel_init) - Tunnel init
(DEBUG) - (remmina_protocol_widget_start_direct_tunnel) - SSH tunnel initialization…
(DEBUG) - (remmina_rdp_event_on_focus_in) - Top level name is: RemminaConnectionWindow
(DEBUG) - (remmina_protocol_widget_start_direct_tunnel) - Calling remmina_public_get_server_port
(DEBUG) - (remmina_protocol_widget_start_direct_tunnel) - Calling remmina_public_get_server_port (tunnel)
(DEBUG) - (remmina_protocol_widget_start_direct_tunnel) - server:, port: 3389
(DEBUG) - (remmina_rdp_tunnel_init) - protocol_plugin_start_direct_tunnel() returned []:3389
(DEBUG) - (remmina_rdp_tunnel_init) - Tunnel has been optionally initialized. Now connecting to
(DEBUG) - (remmina_rdp_main) - gfx_h264_available: 0
(DEBUG) - (remmina_rdp_main) - Resolution set by the user: 1240x708
(DEBUG) - (remmina_rdp_main) - Resolution set after workarounds: 1240x708
(DEBUG) - (remmina_rdp_main) - proxy_type: (null)
(DEBUG) - (remmina_rdp_main) - proxy_username: (null)
(DEBUG) - (remmina_rdp_main) - proxy_password: (null)
(DEBUG) - (remmina_rdp_main) - proxy_hostname: (null)
(DEBUG) - (remmina_rdp_main) - proxy_port: 80
(DEBUG) - (remmina_rdp_main) - Network settings not set
(DEBUG) - (remmina_rdp_main) - rdp_keyboard_remapping_list:
(DEBUG) - (remmina_rdp_main) - Log level set to to INFO
(DEBUG) - (rco_on_disconnect) - Disconnect signal received on RemminaProtocolWidget
(DEBUG) - (remmina_file_save) - Saving profile
(DEBUG) - (remmina_file_save) - We have a secret and disablepasswordstoring=0
(DEBUG) - (remmina_plugin_glibsecret_store_password) - Password “password” saved for file /home/derith/.local/share/remmina/group_rdp_de's-desktop_192-168-0-233.remmina

(DEBUG) - (remmina_file_save) - We have a secret and disablepasswordstoring=0
(DEBUG) - (remmina_plugin_glibsecret_delete_password) - password “ssh_tunnel_password” deleted for file /home/derith/.local/share/remmina/group_rdp_de's-desktop_192-168-0-233.remmina
(DEBUG) - (remmina_file_save) - We have a secret and disablepasswordstoring=0
(DEBUG) - (remmina_plugin_glibsecret_delete_password) - password “gateway_password” deleted for file /home/derith/.local/share/remmina/group_rdp_de's-desktop_192-168-0-233.remmina
(DEBUG) - (remmina_file_save) - We have a secret and disablepasswordstoring=0
(DEBUG) - (remmina_plugin_glibsecret_delete_password) - password “ssh_tunnel_passphrase” deleted for file /home/derith/.local/share/remmina/group_rdp_de's-desktop_192-168-0-233.remmina
(DEBUG) - (remmina_file_save) - Profile saved
(DEBUG) - (remmina_file_save) - Connection profile states saved
(DEBUG) - (remmina_network_monitor_status) - G_NETWORK_CONNECTIVITY_FULL
(DEBUG) - (rco_on_disconnect) - Could not disconnect


[0] Message Index

Go to full version