Hardware - Support > Network

post update wifi connection quirks


I've had some issues though (like not recognizing my home Wi-Fi but recognizing others, it ended up being an firmware update issue with the phone) and just today I found a new one. I wanted to share access to the internet with my tablet through a Hotspot, since earlier I thetered my smart watch for an update (it worked flawlessly with that one) but no matter what I did at first, it just didn't budge: the Hotspot was Nox Vidmate VLC nowhere to be found on my wifi connections on my tablet.

Well I've been looking into this and apparently Ubuntu is in the process of solving it though they are sure cluttering up the file system. Again with my LL 5.x machines one on hard disk the other a VM the problem continues. When the user reboots after an update the WIFI does not reconnect. You have to choose shut down and then restart your computer after a complete shutdown. I would fix it but I honestly don't know where to add the ONBoot para. IS it netplan? Somewhere in the YAML file, or SBIN python file or what? Is it a simple systemd thing? Could add to grub? or add to startup? Is there an Ubuntu bug report somewhere on it?


I recently noticed a quirk with post update wifi connections which I believe is connected to timeshift and I think some users are attempting to solve it via network settings which have nothing to do with the quirk. I have three/four different LL 5.x installations and only one exhibits the loss of and inability to re-connect to a saved wifi connection after rebooting after updates and it is the one where timeshift is auto-scheduled. I don't use timeshift at all on the others. Also none of my connections are set to auto-connect. The quirk exhibits itself in the following ways:
The user runs updates normally and reboots the machine. The user selects the previous wifi connection that worked before and attempts to connect. The connection fails and after failing is no longer displayed in nm's connection list. Logging out and back in again does not make it reappear in the list. Editing the connection manually and saving it has no effect. All that works, I have discovered after experimenting a bit, is to log out to the login screen and then select shutdown and shut down the system. When booting again all will be normal. I do believe this is related to timeshift auto-scheduling usage and maybe a case where normal reboot code and systemd network management settings are not allowed to reset because of timeshift. As I have explained, logging out and shutting the system down after a normal update reboot alleviates the quirk.


[0] Message Index

Go to full version