You are Here:
Linux Lite 5.2 RC1 is now available for download and testing

Accessing an SD Card on a Network Printer

Author (Read 1263 times)

0 Members and 1 Guest are viewing this topic.

Accessing an SD Card on a Network Printer
« on: September 15, 2019, 11:54:02 AM »

Sunny Lord

  • New to Forums
  • *
  • 5
  • Reputation: 0

My setup:

I installed Linux Lite 2.0 on a PC on which I previously had Windows XP installed (my son suggested I try migrating to Linux for this machine so I figured why not...I have never worked with Linux before and here is a good opportunity).  It is merely an extra computer in the house that I use since others in the house are so often on my better computer which has Windows 8.1 installed.  Anyway, there are some files that I use quite often that I need to be able to access using both computers.  To do this, I have an SD card installed on an Epson Work Force 610 that is installed as a network printer.  The SD card is formatted in FAT32.

Since installing Linux Lite 2.0, there are some problems I cannot resolve without causing other problems.

a)  I can get to the memorycard via the network on Linux Lite 2.0 and can copy from and paste to the card using the file explorer type software.  But, other programs, such as LibreOffice, the text editor (Leafpad?), and GIMP cannot open files on the card this way or save files to the card.  The programs just do not seem to recognize the card in this setup.0x800f0r1f

b) I have read that to overcome a) one needs to mount the memorycard.  To do this, I have been trying to modify my fstab file.  Using the following:

// /home/rob/memorycard cifs credentials=/home/rob/.smbcredentials,sec=ntlm,rw,user,noauto,uid=1000,gid=1000 0 0

I can get the memorycard mounted such that the programs can open files from the card and can save new files to the card.  The problem is that if I try to save a file having the same name as a file already there (overwriting or just hitting the save button), none of the programs will let me.  When I try in Leafpad, it says “Can't open file to write.”  When I try in LibreOffice, I get three errors: 1)  “Error saving the document Procedures3:General input/output error while accessing”, 2) “Error saving the document Procedures3:General input/output error while accessing”, and 3) “Error saving the document Procedures3:General Error. General input/output error.” (all very similar but all three come up).  Furthermore, the file that I am trying to overwrite gets corrupted and useless but if I try again to save the still open file as another name, it will do it.  GIMP gives similar results.

c)  Thinking that the problem might be the fact that I am mounting it using cifs as opposed to vfat, I have made attempts at trying to mount the memorycard using:

// /home/rob/memorycard vfat credentials=/home/rob/.smbcredentials,sec=ntlm,rw,user,noauto,uid=1000,gid=1000 0 0

I have also tried other iterations using various options.  The problem I have with the above is that it won't mount.  I keep getting the following:

mount: special device // does not exist

Now clearly it exists because I can get it to mount using cifs.

So my ultimate question is how can I get this SD card mounted so that the programs can properly overwrite existing files, so I can modify files and merely hit the save button when using the Linux programs?

My current workaround is to have XP loaded in VirtualBox and use that to access things.  But that kind of defeats the purpose of using Linux Lite 2.0 so I would really like a better solution.

Last Edit: October 16, 2019, 08:57:52 AM by Sunny Lord

Re: Accessing an SD Card on a Network Printer
« Reply #1 on: September 16, 2019, 03:04:56 AM »


  • Always Learning
  • PayPal Supporter
  • I come here a lot
  • *****
  • 437
  • Country: us
  • Reputation: 61
  • small but still awesome
    • Confessions of a Technophobe

  • Linux Lite: 3.8 64bit

  • CPU: Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz

  • MEMORY: 3Gb

  • VIDEO CARD: Mobile GM965/GL960 Integrated Graphics Controller

  • Kernel: 5.x
LL 2.0 is obsolete now.  Is there any particular reason you chose such an old release of Linux Lite?  We're up to 4.x now.


Linux Lite 5.2 RC1 is now available for download and testing