You are Here:
Linux Lite 5.0 RC1 is now available for download and installation



[ SOLVED ] No WiFi - LL 4.2 UEFI

Author (Read 1695 times)

0 Members and 4 Guests are viewing this topic.

No WiFi - LL 4.2 UEFI
« on: February 23, 2020, 07:45:24 PM »
 

ridenotwalk

  • New to Forums
  • *
  • 13
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • Kernel: 4.x
I have a bit of a problem with LL 4.2 UEFI not seeing my WiFi which means I can not get onto the www or any other network.
Info/outputs are at the very bottom of this post.

Using the very good info on this thread I have installed LL4.2UEFI on an external HDD that I recycled from an older laptop and so far it seams to be running spotty dog apart from the network issue I'm having. I guess you could say that I am dual booting Win10/LL4.2UEFI
I've tried LL4.8 in BIOS as this laptop can do legacy mode but still the same problem exists.
Problem also exists when using both versions of LL via live USB
I haven't tried an earlier version of LL yet but that is on the cards if I can't find a solution.

I do have an earlier version (3.X IIRC) of LL running on a 15 yo laptop and this doesn't have the problem so I copied all the network info over into this laptop with no joy.

To me it looks like LL on this laptop is not picking up the network card/adaptor so maybe drivers are missing however with no WiFi to search for what is needed I am not sure of the next step to take so I can resolve.

I'm currently search forums (mostly Ubuntu related forums so far) etc for info that may lead me in the right direction and wondered if anyone here might be able to help point me in the right direction.

Quote
djcall~  inxi -Fi
System:    Host: djcall-Lenovo-ideapad-S130-14IGM Kernel: 4.15.0-38-generic x86_64 bits: 64 Desktop: Xfce 4.12.3
           Distro: Linux Lite 4.2
Machine:   Device: laptop System: LENOVO product: 81J2 v: Lenovo ideapad S130-14IGM serial: N/A
           Mobo: LENOVO model: LNVNB161216 v: SDK0R32866WIN serial: N/A UEFI: LENOVO v: 9HCN26WW date: 07/09/2019
Battery    BAT1: charge: 29.7 Wh 96.1% condition: 30.8/32.2 Wh (96%)
           hidpp__0: charge: N/A condition: NA/NA Wh
CPU:       Quad core Intel Pentium Silver N5000 (-MCP-) cache: 4096 KB
           clock speeds: max: 2700 MHz 1: 932 MHz 2: 973 MHz 3: 903 MHz 4: 915 MHz
Graphics:  Card: Intel Device 3184
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.97hz
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 605 (Geminilake) version: 4.5 Mesa 18.0.5
Audio:     Card Intel Device 3198 driver: snd_hda_intel Sound: ALSA v: k4.15.0-38-generic
Network:   Card: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 448.1GB (1.7% used)
           ID-1: USB /dev/sda model: Tech size: 320.1GB
           ID-2: /dev/sdb model: HFS128G39TNF size: 128.0GB
Partition: ID-1: / size: 291G used: 5.1G (2%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 34.0C mobo: 10.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 173 Uptime: 17 min Memory: 464.2/3761.3MB Client: Shell (bash) inxi: 2.3.56


djcall~  sudo lshw -class network
  *-network UNCLAIMED       
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: ioport:1000(size=256) memory:a1100000-a110ffff
Last Edit: February 27, 2020, 04:08:14 AM by ridenotwalk
 


Re: No WiFi - LL 4.2 UEFI
« Reply #1 on: February 24, 2020, 01:41:40 AM »
 

ridenotwalk

  • New to Forums
  • *
  • 13
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • Kernel: 4.x
Found this thread while searching around for a possible solution and thought I'd give it a go.
Unfortunately no joy and had the same info/outputs as above once I rebooted, interestingly though the inbuilt touchpad stopped working so had to connect a mouse to be able to do 'mouse-y stuff'

Noting that the LL crew don't really support UEFI right now, one thing I'm thinking of is to reset/rebuild the laptop back to out of the box, format the ext HDD and start again with a fresh install of LL4.8, use legacy mode/BIOS instead of UEFI and see how I go. Thing is I'm a stubborn bugger and would really like to see if I can work out what is needed.

The search continues :-)
 

Re: No WiFi - LL 4.2 UEFI
« Reply #2 on: February 24, 2020, 02:39:39 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7532
    Posts
  • Country: nz
  • Reputation: 708
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960

  • Kernel: 4.x
It's not a UEFI issue. Hold tight, I'll get you a solution soon.

Sent from my Mobile phone using Tapatalk

 

Re: No WiFi - LL 4.2 UEFI
« Reply #3 on: February 24, 2020, 04:10:11 AM »
 

ridenotwalk

  • New to Forums
  • *
  • 13
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • Kernel: 4.x
Thanks Jerry, very appreciated.
 

Re: No WiFi - LL 4.2 UEFI
« Reply #4 on: February 24, 2020, 07:39:46 AM »
 

WytWun

  • PayPal Supporter
  • New to Forums
  • *****
  • 46
    Posts
  • Country: au
  • Reputation: 4
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: J3455
djcall~  inxi -Fi
...
Network:   Card: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
           IF: N/A state: N/A mac: N/A
...
As Jerry has spotted but didn't spell out while he tries to build one for you, the above output indicates that there is no device driver available for the Wireless adapter in your machine. According to this source, there's no current driver in the Linux kernel as of v5.5 but there are a couple of 3rd party drivers.

If you can source either a USB to ethernet adapter (I have a TP-Link UE300 which works with LL 4.x) or a USB WiFi adapter with a Linux kernel driver that would get you going until Jerry sorts a proper driver out - presuming your laptop has usable USB ports of course ;).
 

Re: No WiFi - LL 4.2 UEFI
« Reply #5 on: February 24, 2020, 10:55:47 AM »
 

az2020

  • New to Forums
  • *
  • 40
    Posts
  • Country: us
  • Reputation: 8

  • Linux Lite: 4.8 64bit

  • CPU: Ryzen 3 3200u

  • MEMORY: 32Gb

  • VIDEO CARD: Radeon Vega 3

  • Kernel: 5.x
If you can source either a USB to ethernet adapter (I have a TP-Link UE300 which works with LL 4.x) or a USB WiFi adapter with a Linux kernel driver ...

This probably won't apply, but it may possible to replace the laptop's internal wifi card (inexpensively). I just learned about this a couple weeks ago. My 5-6 year old Toshiba C55B has an older Atheros wifi that supports wireless-N in name only (it connects, but doesn't have the full speed). It's a m.2 card in the laptop, like the SSD cards in newer laptops (but, not as long, more square). I thought wifi was a chipset soldered onto the board. They probably were sometime in the past. But, in recent years they are socketed.

If you google about it, there are people replacing them. You could buy whatever's considered the most Linux friendly (Intel or Atheros?). But, it's more confusing than just connecting a wireless USB adapter. If your card has only one antenna (like mine), you have to get the right kind of card. I read about some people buying a second antenna and routing it around the motherboard -- which is better than no antenna at all, but maybe not as good as routing it up into the edge of the display (which would be a lot of work). Some laptop makers (HP, I think I was reading about) "whitelist" wireless cards. A new one might not work.

I just googled and saw this photo of the OP's motherboard:

https://www.notebookcheck.net/fileadmin/Notebooks/Lenovo/V130-14IGM/Lenovo_V130_14IGM_Innereien.jpg

The wifi card is in the top-left. It has two antennas too! (The specs say it's wireless AC, so you'd expect two.). I'd be replacing that in a heartbeat. There would still be a risk of the bios rejecting a different card.

I just wanted to mention this option in case the OP has an adventurous spirit. If so, the best way to proceed would be googling about people replacing that particular card (in other laptops, etc. Whether Lenovo whitelists cards, etc. It can be time consuming trying to sort it out. But, a replacement card isn't too expensive. $20-$30 USD.).

EDIT: I was googling and saw someone say HP & Lenovo are the only laptop makers who whitelist wifi cards. I also saw this thread on Lenovo which might help you find a whitelisted card. Sorry if I'm going too far into this topic than you're interested. Maybe it would help someone else who finds this in the future. Especially upgrading an older card.
Last Edit: February 24, 2020, 02:22:13 PM by az2020
 

Re: No WiFi - LL 4.2 UEFI
« Reply #6 on: February 24, 2020, 07:32:21 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7532
    Posts
  • Country: nz
  • Reputation: 708
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960

  • Kernel: 4.x
 

Re: No WiFi - LL 4.2 UEFI
« Reply #7 on: February 24, 2020, 08:12:39 PM »
 

ridenotwalk

  • New to Forums
  • *
  • 13
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • Kernel: 4.x
Thanks to all that posted info and ideas.
In my internet searching for a solution I found that linux is not the only one suffering from driver problems linked to the network card I have. At least we are not alone :-)

@WytWun  I'll chase this one up as this laptop doesn't have an wired network connector/socket. Hopefully it will work and can get me to where I need to be.

@az2020  A bit above my pay grade right now but interesting none the less. I'm always keen to 'tinker' so maybe a bit later down the track when I know and understand more about computers and how they do what they do and more importantly, how I can stuff them up so I can avoid doing it :-)

@Jerry  Thanks for the link. I'd been doing a whole bunch of searching this morning and found info re the network card and this was one that I'd found so I'm glad you posted it. Makes me feel that I'm on the right track.


 

Re: No WiFi - LL 4.2 UEFI
« Reply #8 on: February 27, 2020, 04:38:34 AM »
 

ridenotwalk

  • New to Forums
  • *
  • 13
    Posts
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.2 64bit

  • Kernel: 4.x
After a little too-ing and fro-ing I can now use Wifi.

The link Jerry included above did most of the work but as I'm using UEFI instead of BIOS there was a couple of more steps for me to complete that are not in the youtube vid.

So, from the start here is what I did.
  • Did a reset of my laptop to out of the box setup and made sure everything was ok on the WIn10 side as I intended to dual boot Win10/LL
  • Formatted the ext HDD to Fat32 so it was blank (it's going to be used for something else now)
  • Downloaded and created a fresh LL4.2UEFI live USB
  • Installed LL4.2UEFI onto a 128Gb USB stick (instead of the ext HDD) using the how to found here.
  • Used a Ehernet to USB adaptor so I could connect to the internet and get updates etc. There was no setup needed as I got one that worked with Linux.
  • Did a full upgrade to LL (600+ updates :-) ) As part of the upgrade, there were times I had to interact with the laptop and follow other instructions related to MOK (Machine Owner Key) changes. This was easy to do and I found the steps self explainitory
  • Followed the instructions in the youtube vid Jerry linked above. When I got to the point of doing
Code: [Select]
sudo modprobe 8821ce it returned an error something like
Code: [Select]
cannot modprobe, key not found
  • At this point I rebooted the laptop and during the startup a MOK screen came up at which time I followed the instructions to renew the MOK using the password I setup during the upgrade process. Once the laptop had finished logging on I continued following the instructions to fix WiFi and it all worked.
Last Edit: February 27, 2020, 04:48:31 AM by ridenotwalk
 


Tags:
 


Linux Lite 5.0 RC1 is now available for download and installation