Hardware - Support > Network

No Wifi after install of 6.2


Dear All,
Have now gone to Menu>Settings>Install drivers and removed the Broadcom driver.  Have rebooted and now the wifi is working. 
Sorry should have tried this yesterday but had to go back to work.
Thankyou for all your help.

I have included the output from the two sets of commands below
 sudo lshw -C network
[sudo] password for linuxlite:
  *-network UNCLAIMED       
       description: Network controller
       product: BCM4313 802.11bgn Wireless Network Adapter
       vendor: Broadcom Inc. and subsidiaries
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f0500000-f0503fff
       description: Ethernet interface
       product: AR8162 Fast Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 10
       serial: 3c:97:0e:5c:95:39
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx driverversion=5.15.0-52-generic latency=0 link=no multicast=yes port=twisted pair
       resources: irq:19 memory:f0400000-f043ffff ioport:2000(size=128)
 linuxlite  ~  sudo nmcli dev wifi list
 linuxlite  ~  
I did look at the other post with a similar question and it is using the Broadcom wifi driver but it is not working for me as there is no wifi list.  The wifi of the machine did work when we were trying out Linuxite from the booted USB but after the install it ceased to function.
Thankyou for getting back so quickly.

Also, did you see this post ?  Don't know if it is relevant to your install.


Can you run a couple of terminal commands and post back the results please ?
To see what network adaptors are on the system

--- Code: ---sudo lshw -C network
--- End code ---

and assuming the wifi adaptor is there, check what wifi networks it sees

--- Code: ---sudo nmcli dev wifi list
--- End code ---

Dear All,
I have just installed Linuxlite 6.2 on my pals aged laptop a Lenovo G580 with an i3 processor and 8G Ram.
The wifi is a Broadcom BCM4313 802.11bgn Wireless Network Adapter
No wifi network is showing up on the networking taskbar.  When I checked in the Software and Updates section to see if I could install a driver it appears that it is already using Broadcom 802.11 Linux STA wireless driver source from kernel bcmwl-kernel-source (proprietary).
The wifi worked fine when booting from the Linuxlite USB but after the installation I have to connect an ethernet cable to the router.  Any ideas on how to sort this out would be very welcome.
I am familiar with using terminal commands but this is my first go at using Linuxlite.


[0] Message Index

Go to full version