Hardware - Support > Network

"No network devices available" while showing WiFi dongle in the devices tab


Thank you for trying to help me stevef, but i managed to resolve the problem.
I used recovery mode to boot earlier version of the kernel, there the dongle worked. Having WiFi i was able to clone chipset drivers from the github and install it. I dont know what was the problem, now it works OK.

Does your PC have a wired ethernet connector and can you attach to a router using ethernet cable ?

Did you do any package upgrade/update between the hardware working and now not working ?
Was a reboot required after the upgrade ?
If there wasn't an upgrade/update, what else changed ?
If nothing changed, then you may have faulty hardware - do you have another dongle you can use or borrow?

It looks like the 'official' TP-Link drivers for TL-WN821N available (to me) to download are for linux kernel versions 2.6.18 to 3.10.10 so I wouldn't be trying them as a first choice.  There may be a PPA (Personal Package Archive) in which a developer has packaged network drivers for your hardware that works with more recent Linux kernels.

You will need to confirm the chipset in the hardware and the kernel version to check.

To start, answer the questions above and run the following command and post back the results please.

--- Code: ---inxi -NSxxx
--- End code ---

I am fresh to Linux, installed Linux lite 6.4. The PC connects to the internet over wifi dongle, TP-Link WN-821n v5. During system installation there were no problems. After installation dongle could not connect to WiFi, however it did connect if i unplugged & plugged it back. I had to do that after every reboot. Today after a reboot system claims that there are no network devices. I can see the wifi dongle at USB devices tab in system information. However it does not show up when i run lsusb command. I downloaded official TP-link drivers on other computer and transfer it with USB flash drive and ran make command. It gives me back a freaking syntax error "/bin/sh: 1: Syntax error: "(" unexpected" I download some other drivers for this chipset (rtl8188eu), tried to run make command. Told me off for downloading zip file instead of using git clone. How can I use git clone if i have no internet?!

Please help 😭


[0] Message Index

Go to full version