You are Here:
Download Linux Lite 5.6 Final today - See Release Announcements



X Close Ad
X Close Ad
nm-connection-editor fails when no icon present

Author (Read 3137 times)

0 Members and 1 Guest are viewing this topic.

nm-connection-editor fails when no icon present
« on: March 26, 2014, 07:03:50 AM »
 

sysdrum

  • Saying the wrong things at the right time.
  • Occasional Poster
  • **
  • 83
    Posts
  • Country: us
  • Reputation: 12
  • That's personal.

  • Linux Lite: 3.8 64bit

  • CPU: Intel Core i5-6400

  • MEMORY: 16Gb

  • VIDEO CARD: Nvidia 1050 Ti
** (nm-connection-editor:1997): WARNING **: Icon nm-device-wired missing: Error opening file: No such file or directory

** (nm-connection-editor:1997): WARNING **: Failed to initialize the UI, exiting

Not sure why a missing icon is causing the UI to crash but in the Gnome theme Icons it fails every time. 

After changing the icon theme the nm-connection-editor works.
If the icon pack does not have an icon for nm-connection-editor is there a way to set an Icon for the applet that is permanent.
If so do I need to assign it in pixmaps or themes. As I am not sure if this is a network issue or a theme issue. 
 


Re: nm-connection-editor fails when no icon present
« Reply #1 on: March 26, 2014, 11:14:40 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8138
    Posts
  • Country: nz
  • Reputation: 759
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
You would have to study the source code to find out exactly what icon is used. An easier way would be to set the icon theme back to Faenza, look in /usr/share/icons/Faenza for the icon, then symlink it to your icon theme.
 

Re: nm-connection-editor fails when no icon present
« Reply #2 on: March 29, 2014, 03:19:03 PM »
 

sysdrum

  • Saying the wrong things at the right time.
  • Occasional Poster
  • **
  • 83
    Posts
  • Country: us
  • Reputation: 12
  • That's personal.

  • Linux Lite: 3.8 64bit

  • CPU: Intel Core i5-6400

  • MEMORY: 16Gb

  • VIDEO CARD: Nvidia 1050 Ti
After much poking around I found that the issues is related to a symbolic link that looks for a unity reference theme that is not locale. So yes I could make changes but what about people who are not advanced user and then they change something and the  manager breaks with no error.  As I knew when the gnome network manager failed to load I set it to run in terminal to get an output for the failure. but you may have some new user that has no clue. So is there anyway we can fix the issue so that there is not a problem when themes are changed. as I found that the issue is more then just gnome themes, but that if the theme does not have the icon it defaults to the gnome theme icon that is not there because we have no unity themes.
 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.6 Final today - See Release Announcements