You are Here:
Linux Lite 7.0 Final Released - See Release Announcement Section



Network Manager applet weirdness - Lite 6.x

Author (Read 6616 times)

0 Members and 1 Guest are viewing this topic.

Network Manager applet weirdness - Lite 6.x
« Reply #1 on: November 22, 2023, 12:33:51 AM »
 

WytWun

  • PayPal Supporter
  • Forum Regular
  • *****
  • 102
    Posts
  • Reputation: 14
  • Linux Lite Member
    • View Profile

  • CPU: Atom z8300

  • MEMORY: 2Gb

  • VIDEO CARD: Intel integrated

  • Kernel: 5.x
I'm seeing two somewhat different weird behaviours with the Network Manager applet in Lite 6.x:
  • In a VirtualBox VM currently running 6.6: the NM applet reports no connection on login even though the network is connected and working.  The only way I've found to wake the NM applet up is to use
Code: [Select]
nmtui
    to activate the connection.  The VM was installed as 6.2 and then upgraded directly to 6.6 but the issue was visible in 6.2 before the upgrade.[/li]
  • On a Lenovo Ideapad 100S (-11IBY) currently running 6.6:  This laptop doesn't have a builtin ethernet interface so I normally connect via a USB ethernet or 4G dongle - if the USB dongle is present during boot the NM applet displays and correctly shows the connection state; if the dongle is plugged in after boot the NM applet won't display at all.  This one I think is at least related to me having disabled WiFi connections to save battery life.  It normally isn't much of a problem except if neither dongle is handy and I want to use WiFi as I haven't found a way to enable WiFi without plugging in a USB dongle  >:(.  The laptop was upgraded to 6.6 from 6.4; I don't recall when I disabled the WiFi.

I'm not seeing similar problems either in a Lite 5.x VM, a Lenovo Thinkpad X1 laptop (Yoga 2nd gen; has a builtin ethernet interface) or an Acer laptop with builtin ethernet interface running Lite 5.8.

Both issues are more cosmetic than anything, though the 2nd is disruptive on the rare occasions I want to use WiFi with that laptop.  I've tried to compare the configurations between the working and non-working instances and so far I've not found any difference that would lead to the first problem; as noted above I think the simple lack of any enabled interface leads to the 2nd but I think that it would be helpful if there was a way to configure the NM applet to stay up in the absence of same, unless Networking is actually disabled (and then it would be useful to have a convenient way to re-enable it and also to re-enable WiFi when that has been disabled and there's no builtin ethernet interface).

If the brains trust has any ideas that might alleviate these issues, I'm all ears...
 

 

-->
X Close Ad

Linux Lite 7.0 Final Released - See Release Announcement Section