Hardware - Support > Network

Linux Lite v5.2 connection to VPN server using SSTP blocks internet access



I have recently installed Linux Lite (LL) v5.2 as a dual boot with Windows 10 Home on two (out of 3) laptops and it is a pleasure using it. The installation was smooth and the available on LL website installation guide was very helpful.
Many thanks to the Linux Lite developers. My initial impression is that LL works faster than Windows 10 on my laptops and requires less RAM.

My third laptop (Acer 3023 with Sempron 3000+ and 1.25GB ram) was too old for LL, and its only OS is Debian 10 i386 with lxqt, chosen after a dozen of experiments.

Following the Linux Lite tutorials and tips from Ubuntu forums, I was able to connect all laptops and OS (Linux Lite, Windows 10 Home, Debian 10) in a small network and its work is satisfying, especially after the installation of Barrier, which allows me to use one keyboard and mouse for all laptops and OS.

I have though one problem that prevents me using LL on my ACER 5745G, 8GB, i5-460M laptop during my home office working hours.

I need to connect the laptop to my employerís VPN server, which uses SSTP, while been able to keep the access to Internet for other applications.

I was able to connect the laptop with LL to the VPN server, but then I lost the connection to Internet. Chrome and Firefox just say there is some DNS error and refuse to work.

I have been able to establish the connection with the same laptop with Windows 10 and mapped a network drive to the companyís server, without any problems. Thus, I believe that the hardware, internet connection and user login data are tested successfully.

What I have done by now is the following:

Windows 10 Home:
1.   Network Settings -> Add a VPN connection
2.   Filled the Connection name, Server name, VPN type (sstp), and sign in info.
3.   I entered the server IP in File Explorer address bar, selected the shared folder, and used my office network login data.
4.   Mapped the shared folder and successfully used it ever after.

Linux Lite v. 5.2, following various advices and tips found on the LL tutorials and Ubuntu forums:
1.   Installed CIFS-utils

--- Code: ---sudo apt update
sudo apt install cifs-utils
--- End code ---

2.   Installed libevent-2.1-7 with Synaptic PM, after an advice on Ubuntu forums that NM sstp plugin would need it.
3.   Installed Eivind Naess network-manager sstp plugin:

--- Code: ---sudo add-apt-repository ppa:eivnaes/network-manager-sstp
sudo apt-get update
sudo apt install network-manager-sstp sstp-client
--- End code ---

4.   Start Menu->Internet->Network Connection
        Clicked on Add connection, chosen VPN, SSTP and clicked the Create button.
5.   Filled the Connection name.
6.   Typed in Gateway field the Server name, i.e. vpn.XXX.com.
7.   Filled the VPN User name and Password
8.   Clicked the Advanced button
9.   Authentication methods -> clicked only MSCHAP and MSCHAPv2
10.   Unclicked everything else on the dialog window and pressed OK
11.   Saved the VPN connection settings
12.   Network Manager (NM) tray icon -> VPN connections -> ticked the VPN connection
13.   Edited the existing WiFi connection to automatically connect the VPN connection
14.   A message appeared saying that the VPN connection was successfully established
15.   The Ping to the VPN server seemed successful
16.   In the Network File Manager address bar, I typed the VPN server's IP address.
17.   Clicked on the shared folder and typed my officeís Network login data
18.   I mounted the VPN serverís shared folder with:

--- Code: ---sudo mount -t cifs -o username=<my office network username>,password=<my office network password>  //<Server IP>/<Shared folder>  /home/<Folder on my hdd>
--- End code ---

And I got access to the VPN server through the Devices section of the File Manager

19.   I created a credentials file:
--- Code: ---sudo mousepad /etc/XXXcred
--- End code ---
        and typed in
--- Quote ---username=<my office network username>
password=<my office network password>
domain=<VPN server domain name>
--- End quote ---
         then I saved it.
20.   Edited the /etc/fstab file:
--- Code: ---sudo mousepad /etc/fstab
--- End code ---

        adding at the end
--- Quote ---//<Server IP>/<Shared folder>  /home/<Folder on my hdd>  cifs credentials=/etc/XXXcred 0 0
--- End quote ---
21.   At this point I was able to mount the VPN serverís shared folder with:

--- Code: ---Sudo mount /home/<Folder on my hdd>
--- End code ---
And to unmount it with:

--- Code: ---Sudo umount Ėl /home/<Folder on my hdd>
--- End code ---

The SSTP connection to the VPN server works with one BIG BUT.
When the VPN connection is established, I donít have any other access to Internet. I mean Firefox, Chrome and Skype donít have any access to Internet, while the File Manager has access to the VPN server. Once I disable the VPN connection, the Internet access is restored, and I am able to browse Internet again.

While the VPN connection is established, Google Chrome refuses to load any web site with the message:

--- Quote ---<Web site> server IP address could not be found
--- End quote ---
And after some automatic troubleshooting:

--- End quote ---

My WiFi connection settings are as follow:

--- Quote ---Connection Name: <My WiFi name>
SSID: <My WiFi name>
Mode: Client
Band: Automatic
Channel: default
Device: wlp3s0
MTU: automatic

IPV4 Settings:
Method: Automatic (DHCP)
--- End quote ---
Everything else is blank and unchecked.

I would like to have connection to the VPN server and access to Internet at the same time, but I donít have the knowledge and experience to find out what is the problem.

Any help will be much appreciated!

A couple of things: can you mount without sudo? and/or have you tried firefox which has better integration with thunar? Chrome kinda messes up this kind of stuff on Linux, no file manager integration with permissions. 


Hello trinidad,

No, it seems that I can't mount/unmount without sudo.
Firefox behaves similarly to Chrome.

--- Quote ---Hmm. Weíre having trouble finding that site.

We canít connect to the server at www.linuxliteos.com.
If that address is correct, here are three other things you can try:
    Try again later.
    Check your network connection.
    If you are connected but behind a firewall, check that Firefox has permission to access the Web
--- End quote ---

Once the VPN connection is disabled, Firefox and Google have no problems accessing the websites.

It seems that the problem has been in the VPN connection's IPv4 settings.

Start Menu->Internet->Network Connection
Edit VPN connection->IPv4 Settings->Method
I'd changed the method field value from "Automatic (VPN)" to "Automatic (VPN) addresses only", and the problem was solved.


[0] Message Index

Go to full version