You are Here:
Linux Lite 5.0 Final is now available for download and installation



Internet working via Ethernet cable but WiFi not working

Author (Read 2550 times)

0 Members and 5 Guests are viewing this topic.

Internet working via Ethernet cable but WiFi not working
« on: May 19, 2020, 03:45:02 AM »
 

itsmerk

  • New to Forums
  • *
  • 2
    Posts
  • Country: in
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: Dual Core /intel Core Duo T2350

  • MEMORY: 1Gb

  • VIDEO CARD: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics C
Hello, I recently installed Linux Lite on my ancient Lenovo3000 Y500 laptop. I am very new to Linux and dont even know basic commands either :( However, I am liking the fact that this OS is super light. I have two issues currently:

1. I can only access the internet if I connect the laptop physically to my ADSL modem using an Ethernet cable. Wifi Option is there but does not work and the wifi Networks option appears to be dithered even after Enable Wifi option is enabled.

2. I have to use a mouse as the touch pad on the laptop does not work - I was able to resolve this issue by running this command: " sudo apt install xserver-xorg-input-synaptics ", after that run this command: " synclient TapButton1=1 TapButton2=3 TapButton3=2" . Rebooted my system and touchpad started working.

Here is an extract of my system information:

System:    Host: RAV Kernel: 5.6.0 i686 (32 bit) Desktop: Xfce 4.12.3
           Distro: Ubuntu 16.04 xenial
Machine:   System: Lenovo product: LENOVO3000 Y500 v: 00000000000000000000000000000000
           Mobo: Lenovo model: F50X Bios: Lenovo v: v2.04 date: 03/16/07
CPU:       Dual core Intel Core Duo T2350 (-MCP-) cache: 2048 KB
           clock speeds: max: 1867 MHz 1: 997 MHz 2: 1021 MHz
Graphics:  Card: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.19hz
           GLX Renderer: Mesa DRI Intel 945GM x86/MMX/SSE2
           GLX Version: 1.4 Mesa 18.0.5
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k5.6.0
Network:   Card-1: Intel PRO/Wireless 3945ABG [Golan] Network Connection
           driver: iwl3945
           IF: wlp3s0 state: down mac: *Masked*
           Card-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
           driver: 8139too
           IF: enp5s1 state: unknown speed: 100 Mbps duplex: full
           mac: *Masked*
           WAN IP: 122.171.156.228 IF: wlp3s0 ip-v4: N/A
           IF: enp5s1 ip-v4: 192.168.1.5
Drives:    HDD Total Size: 120.0GB (5.9% used)
           ID-1: /dev/sda model: Hitachi_HTS54161 size: 120.0GB
Partition: ID-1: / size: 109G used: 5.8G (6%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 1.06GB used: 0.01GB (1%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 161 Uptime: 7 min Memory: 373.2/923.4MB
           Client: Shell (bash) inxi: 2.2.35
Last Edit: May 19, 2020, 05:01:35 AM by itsmerk
 


Re: Internet working via Ethernet cable but WiFi not working
« Reply #1 on: May 19, 2020, 04:31:17 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7691
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Did it work before you added the 5.6 kernel? With hardware that old, I see no sensible reason to be running such a cutting edge kernel.

Sent from my Mobile phone using Tapatalk
 

Re: Internet working via Ethernet cable but WiFi not working
« Reply #2 on: May 19, 2020, 04:59:16 AM »
 

itsmerk

  • New to Forums
  • *
  • 2
    Posts
  • Country: in
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: Dual Core /intel Core Duo T2350

  • MEMORY: 1Gb

  • VIDEO CARD: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics C
Did it work before you added the 5.6 kernel? With hardware that old, I see no sensible reason to be running such a cutting edge kernel.

Sent from my Mobile phone using Tapatalk

Unfortunately No. It did not work before either. That was the reason I upgraded the Kernel :/ I am completely new to Linux. My ancient laptop has a Toggle switch for WiFi and Bluetooth. I even checked and ensured that it is On but that LED under the switch never comes on. But when I connect via ethernet cable, internet works just fine.

Also, I tried this :


rav@RAV:~$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
rav@RAV:~$ rfkill unblock all
Can't open RFKILL control device: Permission denied



 

Re: Internet working via Ethernet cable but WiFi not working
« Reply #3 on: May 19, 2020, 05:11:28 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7691
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Hardblocked means your WiFi toggle is switched off. Look for such a switch on your laptop. Usually on the side somewhere. Newer kernels support newer hardware. As kernels progress, older hardware support gets dropped, otherwise the kernel would grow to a ridiculous size.

Sent from my Mobile phone using Tapatalk

 

Re: Internet working via Ethernet cable but WiFi not working
« Reply #4 on: May 19, 2020, 05:17:26 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7691
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
It might also be a key combo eg. FN + somekey Then when rfkill reports hard blocked no, you can run: sudo rfkill unblock all

Sent from my Mobile phone using Tapatalk

 

Re: Internet working via Ethernet cable but WiFi not working
« Reply #5 on: June 10, 2020, 09:07:07 AM »
 

williamd

  • New to Forums
  • *
  • 1
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: Intel dual-core

  • MEMORY: 4Gb

  • VIDEO CARD: Intel
Just trying out Linux-Lite on a desktop 4G RAM, Intel dual-core processor. WIFI did not work out of the box even on the live CD (actually memory stick) - everything else seemed fine but no WIFI - rather I should say that the WIFI actually worked but there was no DNS. So, I could ping 8.8.8.8 for eg but not www.google.com Went ahead and installed to desktop hard drive (500G Seagate) but no change. Install seemed to proceed normally and completed normally but still no DNS. I am not able to test with a cable ethernet link so the WIFI operation is critical. After some googling I found a number of helpful suggestions, none of which worked.
/etc/resolv.conf as installed contained (apart from the warning not to edit it) just 1 line nameserver 127.0.0.53 - this I understand is correct but for some reason, does not work. In the end I edited /etx/resolv.conf and added nameserver 8.8.8.8 and nameserver 8.8.4.4 , saved the file after which DNS came alive and the internet was accessible. However, this did not survive a reboot and the file returned to default even when flagged read-only. Finally I switched on the "Immutable" attribute which stopped the update and I was able to reboot and DNS stayed active.
Hopefully, someone might explain why this problem exists and offer a more correct way of correcting it.
Note: this problem only happens on this machine with Linux-lite - Linux-Mint, MX, Ubuntu and Debian all installed and worked without any problem with DNS.
 

Re: Internet working via Ethernet cable but WiFi not working
« Reply #6 on: June 13, 2020, 05:12:36 PM »
 

Jesse R Bassett

  • New to Forums
  • *
  • 14
    Posts
  • Country: us
  • Reputation: 3

  • Linux Lite: 5.0 64bit

  • CPU: 1 x Intel Core i3 2120 / 3.3 GHz ( Dual-Core )

  • MEMORY: 4Gb

  • VIDEO CARD: Intel HD Graphics 2000 Dynamic Video Memory Technology

  • Kernel: 5.x
William,
I experienced this problem with my Linux Lite 5.0 pc. I just decided heck with trying to connect via wifi and have it plugged in via ethernet directly into my router. I know this might not be ideal, but ethernet is actually quicker and safer than wifi.
 


 


Linux Lite 5.0 Final is now available for download and installation