You are Here:
Download Linux Lite 5.4 Final today - See Release Announcements



X Close Ad
X Close Ad
[ SOLVED ] Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0

Author (Read 2351 times)

0 Members and 2 Guests are viewing this topic.

 

Dave Bruwer

  • New to Forums
  • *
  • 22
    Posts
  • Country: nz
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 5.2 64bit

  • MEMORY: 8Gb
I have just installed Linux Lite on an old desktop PC.
It uses a TP-LINK TL-WN722N V2.0 USB adapter for WIFI access.

The wifi seems to be working fine, and I was even able to access local shared files over the wifi.

BUT, the internet connection doesn't seem to be working.
I can't see anything obvious wrong.

I connected to the modem with an ethernet cable, and performed all the updates, but to no avail.

Any suggestions?
Last Edit: January 31, 2021, 06:56:44 PM by Jerry
 


Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #1 on: January 30, 2021, 11:15:04 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8050
    Posts
  • Country: nz
  • Reputation: 750
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.4 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
What DNS are you using?

What is the output of:

Code: [Select]
route -n
and

Code: [Select]
ifconfig
Last Edit: January 30, 2021, 11:20:36 PM by Jerry
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #2 on: January 31, 2021, 12:21:24 AM »
 

Dave Bruwer

  • New to Forums
  • *
  • 22
    Posts
  • Country: nz
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 5.2 64bit

  • MEMORY: 8Gb
with my ethernet cable connected

route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.254   0.0.0.0         UG    100    0        0 enp3s0
0.0.0.0         192.168.1.254   0.0.0.0         UG    600    0        0 wlxd46e0e1f45bb
192.168.1.0     0.0.0.0         255.255.255.0   U     100    0        0 enp3s0
192.168.1.0     0.0.0.0         255.255.255.0   U     600    0        0 wlxd46e0e1f45bb

ifconfig
enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.84  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::a99b:582e:2d35:ad69  prefixlen 64  scopeid 0x20<link>
        ether 44:8a:5b:26:2b:22  txqueuelen 1000  (Ethernet)
        RX packets 17876  bytes 8150271 (8.1 MB)
        RX errors 0  dropped 6  overruns 0  frame 0
        TX packets 34192  bytes 41935685 (41.9 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 794  bytes 65604 (65.6 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 794  bytes 65604 (65.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlxd46e0e1f45bb: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.78  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::3d4f:b860:d8b2:493d  prefixlen 64  scopeid 0x20<link>
        ether d4:6e:0e:1f:45:bb  txqueuelen 1000  (Ethernet)
        RX packets 6019  bytes 1005852 (1.0 MB)
        RX errors 0  dropped 3342  overruns 0  frame 0
        TX packets 422  bytes 71594 (71.5 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #3 on: January 31, 2021, 12:21:44 AM »
 

Dave Bruwer

  • New to Forums
  • *
  • 22
    Posts
  • Country: nz
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 5.2 64bit

  • MEMORY: 8Gb
without the ethernet cable:

route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.254   0.0.0.0         UG    600    0        0 wlxd46e0e1f45bb
192.168.1.0     0.0.0.0         255.255.255.0   U     600    0        0 wlxd46e0e1f45bb

ifconfig
enp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 44:8a:5b:26:2b:22  txqueuelen 1000  (Ethernet)
        RX packets 18112  bytes 8197332 (8.1 MB)
        RX errors 0  dropped 6  overruns 0  frame 0
        TX packets 34314  bytes 41949566 (41.9 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 884  bytes 72432 (72.4 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 884  bytes 72432 (72.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlxd46e0e1f45bb: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.78  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::3d4f:b860:d8b2:493d  prefixlen 64  scopeid 0x20<link>
        ether d4:6e:0e:1f:45:bb  txqueuelen 1000  (Ethernet)
        RX packets 6480  bytes 1078140 (1.0 MB)
        RX errors 0  dropped 3548  overruns 0  frame 0
        TX packets 450  bytes 75672 (75.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #4 on: January 31, 2021, 12:29:08 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8050
    Posts
  • Country: nz
  • Reputation: 750
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.4 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #5 on: January 31, 2021, 01:04:35 AM »
 

Dave Bruwer

  • New to Forums
  • *
  • 22
    Posts
  • Country: nz
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 5.2 64bit

  • MEMORY: 8Gb
nameserver 127.0.0.53
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #6 on: January 31, 2021, 04:02:57 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8050
    Posts
  • Country: nz
  • Reputation: 750
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.4 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Not sure what you're like installing drivers, but this looks very well suited and optimized - https://github.com/abhijeet2096/TL-WN722N-V2 only do 1 -7, nothing else! Hopefully it will work with the current kernel. Take note of the section 'Activating/Deactivating LED' before you do step 3.
Last Edit: January 31, 2021, 04:05:15 AM by Jerry
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #7 on: January 31, 2021, 01:58:27 PM »
 

Dave Bruwer

  • New to Forums
  • *
  • 22
    Posts
  • Country: nz
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 5.2 64bit

  • MEMORY: 8Gb
Thank you for finding that.
I might need a bit of help understanding what i am doing.

When I try to do step 4, I get this message:
(also, see attached make.log file)

Code: [Select]
sudo dkms build -m 8188eu -v 1.2

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
'make' all.........(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.4.0-65-generic (x86_64)
Consult /var/lib/dkms/8188eu/1.2/build/make.log for more information.
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #8 on: January 31, 2021, 04:48:31 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8050
    Posts
  • Country: nz
  • Reputation: 750
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.4 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Try this one - https://gitlab.com/kalilinux/packages/realtek-rtl8188eus-dkms click on the Download button next to 'Clone' and select 'build'. You should have a file called master.zip, extract the .deb file from that zip and double click on it to install the driver.
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #9 on: January 31, 2021, 05:13:08 PM »
 

Dave Bruwer

  • New to Forums
  • *
  • 22
    Posts
  • Country: nz
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 5.2 64bit

  • MEMORY: 8Gb
That one installed successfully, but unfortunately the problem persists.

It is quite interesting that the internet works fine over ethernet cable, and the WIFI seems to work fine for shared local files etc., but the internet just won't work over the WIFI.  :-\
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #10 on: January 31, 2021, 05:15:46 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8050
    Posts
  • Country: nz
  • Reputation: 750
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.4 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
That one installed successfully, but unfortunately the problem persists.

It is quite interesting that the internet works fine over ethernet cable, and the WIFI seems to work fine for shared local files etc., but the internet just won't work over the WIFI.  :-\

Did you read the entire page?
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #11 on: January 31, 2021, 05:21:46 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8050
    Posts
  • Country: nz
  • Reputation: 750
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.4 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
I'm curious about what's going on here. If you like, install Teamviewer from Lite Software, run Updates then send me the ID, pass via a PM here.
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #12 on: January 31, 2021, 05:40:13 PM »
 

Dave Bruwer

  • New to Forums
  • *
  • 22
    Posts
  • Country: nz
  • Reputation: 1
  • Linux Lite Member

  • Linux Lite: 5.2 64bit

  • MEMORY: 8Gb
PM Sent.  :)
 

Re: Internet not working on functioing WiFi adapter TP-LINK TL-WN722N V2.0
« Reply #13 on: January 31, 2021, 06:55:37 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8050
    Posts
  • Country: nz
  • Reputation: 750
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.4 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Solution for those with an already functioning WiFi, but no Internet. Disconnect Ethernet if connected.

Remove any existing WiFi connections from Edit Connections in Network Manager. In this case it got rid of duplicate IP's on the one adapter.

Set some reliable DNS:

Code: [Select]
sudo mousepad /etc/resolvconf/resolv.conf.d/head
Code: [Select]
nameserver 8.8.8.8
nameserver 8.8.4.4

Save.

Set IPV6 to 'Ignore' in Network Manager.

Reboot with Ethernet cable NOT plugged in.

Should be good to go :)
 


Tags:
 

X Close Ad
X Close Ad

Download Linux Lite 5.4 Final today - See Release Announcements