You are Here:
Linux Lite 4.8 Final is now available for download and installation



Ethernet Not Working, Intel e1000e 82578DC rev 06

Author (Read 7304 times)

0 Members and 122 Guests are viewing this topic.

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #15 on: November 12, 2019, 03:39:54 PM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Here's more:

Code: [Select]
sudo lshw -C network
gives, in relevant part:

Code: [Select]
  *-network                 
       description: Ethernet interface
       product: 82578DC Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: enp0s25
       version: 06
       serial: 60:eb:69:de:64:ec
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.12-5 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:27 memory:fbec0000-fbedffff memory:fbef8000-fbef8fff ioport:e880(size=32)

I notice the driver version is old, but it's part of the kernel. Not sure if changing it would matter, because the computer is old, too, and changing kernel drivers is a little over my head. If that's what it'll take, that's what I'll do, but i expect there's a simpler solution.

Thanks for reviewing this and thinking about it.
jerryc, not to be confused with the real Jerry who developed this distro.
 


Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #16 on: November 12, 2019, 03:52:08 PM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
I found this:

Code: [Select]
dracut -f /boot/initramfs-$(uname -r).img $(uname -r)
Somebody said it worked for him. I don't understand it, if I should try it as is, or if some of those things are variables I need to replace, like the username.

I've read updating the driver in the kernel didn't work for several people.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #17 on: November 12, 2019, 03:52:47 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7363
    Posts
  • Country: nz
  • Reputation: 691
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960

  • Kernel: 4.x
Also, output please of:

Code: [Select]
sudo lshw -C net
and

Code: [Select]
dmesg | grep -e eth -e e1000
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #18 on: November 12, 2019, 03:53:24 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7363
    Posts
  • Country: nz
  • Reputation: 691
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960

  • Kernel: 4.x
I found this:

Code: [Select]
dracut -f /boot/initramfs-$(uname -r).img $(uname -r)
Somebody said it worked for him. I don't understand it, if I should try it as is, or if some of those things are variables I need to replace, like the username.

I've read updating the driver in the kernel didn't work for several people.

I wouldn't do that at this stage.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #19 on: November 12, 2019, 08:41:56 PM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Thank you for your input.

The computer with the recent LL install is at my gf's, and I'm away from it until next weekend. I'll jump back into this thread when I'm in front of it again.

However, I can make one side comment right now. I've been a xubuntu user for 15+ years, with two short deviations, one to mint, and one to mx linux. I left the both in short order because I found their forums almost useless. This forum, however, has been off the chart phenomenal.

I already loved the OS. Now, I really love it. I'll be converting my own box from xubuntu to LL soon.

Thank you all for the help.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #20 on: November 12, 2019, 08:50:53 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7363
    Posts
  • Country: nz
  • Reputation: 691
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960

  • Kernel: 4.x
You're very welcome.

Sent from my Mobile phone using Tapatalk

 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #21 on: November 12, 2019, 08:57:34 PM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
I wouldn't do that at this stage.

Good. It looked like swatting flies with a sledge hammer to me. We'll save it as a last resort and, hopefully, find a simpler solution instead.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #22 on: November 12, 2019, 09:45:01 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1248
    Posts
  • Country: us
  • Reputation: 236
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
Neither of these worked, either:

Code: [Select]
sudo ip link set dev enp0s25 up
Code: [Select]
sudo /sbin/ifconfig enp0s25 up


I'm going to stick my head in for a sec... don't want to muddy the waters..


For kicks I was on my Ubuntu server...

I saw your code previously --- and thought I'd try..  (subbing my interface name - lol)
Code: [Select]
sudo ip link set dev enp0s25 upDidn't do anything for me after I downed my interface.. (Pings wouldn't find a host after attempting to "up")

Only once I upped it via the code below did I pull an IPv4 addy (I think yours pulled IPv6)
Code: [Select]
sudo ifup ETH_DeviceThen was it truly usable.


For your system...
Code: [Select]
sudo ifdown enp0s25 and sudo ifup enp0s25

Might be worth a try -- your not changing anything... 
LL 4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #23 on: November 12, 2019, 09:58:54 PM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
...
Might be worth a try -- your not changing anything...
For sure. Ever since I found out the kernel now already has the right driver built it, I've figured it would be something simple like this. If not this, I expect something similarly simple will do it.

Thanks for the input. I'll try it this weekend when I'm back at my sweetie's. Meanwhile, she'd doing fine on the wireless, and her computer is running much faster on LL than it did on Win7. She loves it.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #24 on: November 12, 2019, 10:03:57 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1248
    Posts
  • Country: us
  • Reputation: 236
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x

I've figured it would be something simple like this. If not this, I expect something similarly simple will do it.


More often than not... it usually something simple (atleast it seems to me)  ;D

Quote
Thanks for the input. I'll try it this weekend when I'm back at my sweetie's. Meanwhile, she'd doing fine on the wireless, and her computer is running much faster on LL than it did on Win7. She loves it.


LL is GREAT!! for me it has saved all kinds of hardware from scrap.. I run it on a lot  ;)
LL 4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #25 on: November 12, 2019, 11:23:10 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7363
    Posts
  • Country: nz
  • Reputation: 691
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960

  • Kernel: 4.x
Even easier, install the dkms deb package - https://github.com/koljah-de/e1000e-dkms-debian/releases
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #26 on: November 12, 2019, 11:41:59 PM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Even easier, install the dkms deb package - https://github.com/koljah-de/e1000e-dkms-debian/releases

Deb package? Now you're singing my song! Those, I know how to do.

And, it looks like there's a newer version than the one in my kernel. Looking forward to trying it this weekend.

Thank you.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #27 on: November 13, 2019, 07:54:31 AM »
 

TheDead

  • Gold Level Poster
  • *******
  • 666
    Posts
  • Country: ca
  • Reputation: 59
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 4.2 64bit

  • CPU: HAL9000

  • MEMORY: 2Gb

  • VIDEO CARD: Retinax Pro v.2

  • Kernel: 4.x
@jerryc
And... maybe a simple thing to try, you know just in case it's not already done.
Try changing the wire itselft and/or the port in the switch/router it's connected too.
You'd be surprise how many times I solved a network issue checking the physical wire because the little plastic clip was broken and the wire was not fully clipping "in" the plug ;))

Just last week, I solved a VoIP issue for 20 people by changing the main ethernet cable. Connectors looked flaky and seemed to have "pulled" wires and was not "molded". Was also an old CAT5 so I put a CAT6 in its place.
- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #28 on: November 13, 2019, 08:00:56 AM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Try changing the wire itself and/or the port in the switch/router it's connected too.

Thanks, but it works fine with Win7 and has for years. It has to be a config issue of some kind. It's a desktop, not a laptop. Hasn't moved.

I've tried probing for the router's url, but nothing has shown up.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #29 on: November 15, 2019, 11:44:55 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1084
    Posts
  • Country: us
  • Reputation: 184
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.8 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
Network Manager can be quirky with things that involve changing some drivers not in a repository kernel version. It can sometimes behave as if it was not installed as a GUI application prior to such a change.
To ease my mind concerning this run the following again: nmcli connection show

And then run: nmcli connection up 'Wired connection 1' (or whichever you wish to activate)

Then run: nmcli dev status
This will show if the correct logical name 'enp0s25' of your device is listed as up. If all this is correct and there is still no connection make sure your firewall is configured correctly. Perhaps you changed it at some point and forgot about it. If all is well there and you are still not connected you can try changing the ifupdown plugin configuration in your /etc/NetworkManager/NetworkManager.conf file from false to true. I'm not on LL right now so the file may have a different location.
TC
Last Edit: November 15, 2019, 12:04:36 PM by trinidad
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 


Tags: ethernet e1000 e1000e 
 


Linux Lite 4.8 Final is now available for download and installation