You are Here:
Linux Lite 4.8 Final is now available for download and installation



Ethernet Not Working, Intel e1000e 82578DC rev 06

Author (Read 13583 times)

0 Members and 7 Guests are viewing this topic.

Ethernet Not Working, Intel e1000e 82578DC rev 06
« on: November 11, 2019, 11:30:54 PM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Just did an LL install on a Win7 box and now we have no ethernet access. Fortunately, we have wifi working on it.

Here's what I got:

Code: [Select]
lspci | grep -i ethernet
00:19.0 Ethernet controller: Intel Corporation 82578DC Gigabit Network Connection (rev 06)

I tried googling it, but I couldn't find any simple instructions that work. Intel has a driver here:

https://downloadcenter.intel.com/download/15817/Intel-Network-Adapter-Driver-for-PCIe-Intel-Gigabit-Ethernet-Network-Connections-Under-Linux-?product=55351

but, even with some nix experience, I couldn't follow the instructions. They talk about building an .rpm, but I've been a .deb guy for way too many years.

I tried the instructions here:

https://www.intel.com/content/www/us/en/support/articles/000005480/network-and-i-o/ethernet-products.html

Here's what I got:

Code: [Select]
root > Downloads > e1000e-3.6.0 > src  make install
make[1]: Entering directory '/usr/src/linux-headers-4.15.0-66-generic'
  Building modules, stage 2.
  MODPOST 1 modules
make[1]: Leaving directory '/usr/src/linux-headers-4.15.0-66-generic'
Copying manpages...
Installing modules...
make[1]: Entering directory '/usr/src/linux-headers-4.15.0-66-generic'
  INSTALL /home/diane/Downloads/e1000e-3.6.0/src/e1000e.ko
At main.c:160:
- SSL error:02001002:system library:fopen:No such file or directory: ../crypto/bio/bss_file.c:72
- SSL error:2006D080:BIO routines:BIO_new_file:no such file: ../crypto/bio/bss_file.c:79
sign-file: certs/signing_key.pem: No such file or directory
  DEPMOD  4.15.0-66-generic
make[1]: Leaving directory '/usr/src/linux-headers-4.15.0-66-generic'
Running depmod...

Does anybody know a simple step by step guide to make this work on LL?

Thank you.
Last Edit: November 12, 2019, 04:08:39 PM by Jerry
jerryc, not to be confused with the real Jerry who developed this distro.
 


Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #1 on: November 12, 2019, 08:07:49 AM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
I've done some more digging. The driver needed is e1000e. It's supposed to be merged into the kernel already now.

I ran:
Code: [Select]
lsmod | grep e1000

and got:

Code: [Select]
e1000e                249856  0
ptp                    20480  1 e1000e

So, it appears as though I already have the proper driver. However, it's still not working.

Any ideas?

Thank you for your help on this.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #2 on: November 12, 2019, 08:15:27 AM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
More info. I ran:

Code: [Select]
lspci -nnk | grep 0200 -A3
and got:

Code: [Select]
00:19.0 Ethernet controller [0200]: Intel Corporation 82578DC Gigabit Network Connection [8086:10f0] (rev 06)
Subsystem: Acer Incorporated [ALI] 82578DC Gigabit Network Connection [1025:8000]
Kernel driver in use: e1000e
Kernel modules: e1000e

My guess it's probably a simple configuration issue.

Thank you again.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #3 on: November 12, 2019, 08:23:41 AM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Here's more:

Code: [Select]
route -n

yields:

Code: [Select]
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    600    0        0 wlp2s0
192.168.1.0     0.0.0.0         255.255.255.0   U     600    0        0 wlp2s0

No IP address shows for the ethernet router.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #4 on: November 12, 2019, 08:30:02 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1112
    Posts
  • Country: us
  • Reputation: 186
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.8 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
Run and post result: nmcli connection show
TC


All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #5 on: November 12, 2019, 08:39:13 AM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Per TC, I ran:

Code: [Select]
nmcli connection show
and got:

Code: [Select]
FiOS-QW2C2          43e439c1-0deb-4bef-bf29-865d0b1e435a  wifi      wlp2s0
Wired connection 1  281e9d38-5cd1-32b3-94eb-2a700fffc690  ethernet  --

I also ran:

Code: [Select]
sudo ip addr show
and got:

Code: [Select]
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp0s25: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 60:eb:69:de:64:ec brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 1c:65:9d:ee:8a:0a brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.195/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp2s0
       valid_lft 78792sec preferred_lft 78792sec
    inet6 fe80::1854:1802:d39f:9388/64 scope link noprefixroute
       valid_lft forever preferred_lft forever

I sure hope some of this is helping. Thank you.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #6 on: November 12, 2019, 08:50:26 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1112
    Posts
  • Country: us
  • Reputation: 186
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.8 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
Well network manager is not picking up the interface system name. Looks like the kernel is updated for the card but not network manager. Try manually creating a new wired connection in network manager to enp0s25.
https://developer.gnome.org/NetworkManager/stable/nmcli.html
I was intending to write on this subject myself, but I found this at tecmint.
https://www.tecmint.com/configure-network-connections-using-nmcli-tool-in-linux/

TC
Last Edit: November 13, 2019, 09:09:07 AM by trinidad
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #7 on: November 12, 2019, 08:54:57 AM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Even more. The relevant output of:

Code: [Select]
inxi -Fxz:
is:

Code: [Select]
Network:   Card-1: Intel 82578DC Gigabit Network Connection
           driver: e1000e v: 3.6.0-NAPI port: e880 bus-ID: 00:19.0
           IF: enp0s25 state: down mac: <filter>

Maybe "state: down" is something I can change, like maybe to "state:up."

Sign me up!
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #8 on: November 12, 2019, 09:05:16 AM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Try manually creating a new wired connection in network manager to enp0s25.

Tried it. It appears enp0s25 is already showing in the network manager for the wired connection as the same device:

Code: [Select]
enp0s25 (60:EB:69:DE:64:EC)
Now, I have two connections in network manager not working, wired connection 1 and ethernet collection 1.

Thanks for helping dig into this. I suspect it's something simple, just not easy to find, yet.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #9 on: November 12, 2019, 09:15:24 AM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Neither of these worked, either:

Code: [Select]
sudo ip link set dev enp0s25 up
Code: [Select]
sudo /sbin/ifconfig enp0s25 up
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #10 on: November 12, 2019, 09:58:18 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1112
    Posts
  • Country: us
  • Reputation: 186
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.8 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
Are you disconnected from WIFI while attempting to connect from wired? If not disconnect from WIFI and try, or try wired connecting to another computer to test the interface.

TC
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #11 on: November 12, 2019, 10:07:43 AM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Are you disconnected from WIFI while attempting to connect from wired? ... disconnect from WIFI and try

Didn't work.

Quote
or try wired connecting to another computer to test the interface.

Works fine on same computer with Win7 and has for years.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #12 on: November 12, 2019, 02:40:46 PM »
 

Moltke

  • Gold Level Poster
  • *******
  • 630
    Posts
  • Country: ve
  • Reputation: 77
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 4.x
Neither of these worked, either:

Code: [Select]
sudo ip link set dev enp0s25 up
Code: [Select]
sudo /sbin/ifconfig enp0s25 up

Did you get any error message or any message at all after running either one of these commands? What did the message say?
Without each others help there ain't no hope for us :)
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #13 on: November 12, 2019, 02:46:44 PM »
 

jerryc

  • New to Forums
  • *
  • 41
    Posts
  • Country: us
  • Reputation: 0
  • LL user - Old xubuntu user

  • Linux Lite: 4.6 64bit
Did you get any error message or any message at all after running either one of these commands? What did the message say?

Nope. Just new prompts.

Thanks for exploring this, moltke.
jerryc, not to be confused with the real Jerry who developed this distro.
 

Re: Ethernet Not Working, Intel e1000e 82578DC rev 06
« Reply #14 on: November 12, 2019, 03:37:23 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7439
    Posts
  • Country: nz
  • Reputation: 699
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960

  • Kernel: 4.x
There are a number of suggestions online for this chipset. Let's work through them one at a time. Some report a fix by having the latest BIOS installed.

Sent from my Mobile phone using Tapatalk

 


Tags: ethernet e1000 e1000e 
 


Linux Lite 4.8 Final is now available for download and installation