Hardware - Support > Network

Cannot get my bluetooth to work at all

(1/1)

finbarrus:
I have Linux Lite on a fairly old Lenovo S21e laptop.  Previously I ran Cinnamon Mint but changed to LL because of very limited memory. Generally it works fine, but unlike Mint, where the BT did work, I just cannot seem to get the BT up and running. I installed/uninstalled bluez, then blueman (on now) - no joy.

All I want is to be able to use a BT mouse without dongle and to connect my BT headphones.

Thanks in advance for any tips / tricks / fixes

TheDead:
Are you able to get into the blutooth configuration at all or the problem is that the device are not listed or that they are not able to connect?
Having the blutoooth card model name and that of the devices could also help ;)

finbarrus:
The devices don't list. Is the Network controller the BT card?

-PCI Devices-
Host bridge      : Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0e)
VGA compatible controller      : Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e) (prog-if 00 [VGA controller])
USB controller      : Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 0e) (prog-if 30 [XHCI])
Encryption controller      : Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0e)
Audio device      : Intel Corporation Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller (rev 0e)
PCI bridge      : Intel Corporation Atom Processor E3800 Series PCI Express Root Port 1 (rev 0e) (prog-if 00 [Normal decode])
PCI bridge      : Intel Corporation Atom Processor E3800 Series PCI Express Root Port 2 (rev 0e) (prog-if 00 [Normal decode])
ISA bridge      : Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0e)
SMBus      : Intel Corporation Atom Processor E3800 Series SMBus Controller (rev 0e)
Network controller      : Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n (rev 01)

TheDead:
Googlez sayz...
Other Lenovo laptops have a problem with the hardware block being enabled by default.
Open a terminal and do :
sudo rfkill

Then provide the results.
Also, update Linux first, just in case a fix is available.

Navigation

[0] Message Index

Go to full version