You are Here:
Linux Lite 4.2 Final has been released. See the Release Announcements Section.



UEFI Build Test

Author (Read 46175 times)

0 Members and 46 Guests are viewing this topic.

Re: UEFI Build Test
« Reply #150 on: November 10, 2018, 04:08:13 AM »
 

WytWun

  • PayPal Supporter
  • New to Forums
  • *****
  • 29
    Posts
  • Country: au
  • Reputation: 3
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: J3455
I've re-upped and tested a new ISO online. Original post updated.

I've been able to mod this revised ISO to add 32bit UEFI boot support and have succeeded in installing the result to a BayTrail Atom based Lenovo Ideapad 100s (11") notebook.  Everything is working fine in the final install except the keyboard and touchpad :(.  The Lite live boot didn't have the keyboard and touchpad working either so I used a USB keyboard and mouse to complete the install.  This is somewhat disappointing as the Xubuntu 18.04 ISO similarly modified comes up in the live boot (haven't tried installing) with both keyboard and touchpad working fine...  I've tried to compare the dmesg from both live boots but I can't see any real discrepancy regarding the keyboard and touchpad which are I2C HID devices on this machine.  The Lite Mouse and Touchpad settings dialog shows the touchpad detected and enabled under the name ENEE3730:0001.

For those with BayTrail and CherryTrail systems requiring 32bit UEFI bootloaders, this is how I modded the Xubuntu and Lite UEFI ISOs:
- I first used the Linuxium isorespin.sh script to add the 32bit bootloader support to the Xubuntu 18.04 ISO.  I just ran the script without options, selected the ISO and the advanced option to add Grub bootloader support (which covers the 32bit requirement) in a VirtualBox Lite VM on my Windows desktop then used dd to write the resulting ISO to a USB drive connected to the VM.  This process adds 2 copies of bootia32.efi to the ISO: one in /EFI/BOOT and the other in the vfat disk image /boot/grub/efi.img.  The respin script requires xoriso (sp?) to manipulate the ISOs and I estimate a minimum of 7GB usable free space in the working file system.

- I then used Rufus on the Windows desktop to write the Lite UEFI ISO to another USB drive using the default ISO Image (file copy) mode so that the unused space on the drive was accessible.

- I then copied /EFI/BOOT/bootia32.efi and /boot/grub/efi.img from the Xubuntu USB drive to the Lite UEFI USB drive (overwriting the existing /boot/grub/efi.img file on the Lite USB).

I booted the modded Xubuntu USB in the system first to confirm the 32bit loader was working, then went on with the Lite mod.  This machine had previously had the Windows 10 install wiped and replaced with a Linuxium modified Xubuntu 16.04 install which required a custom kernel to get the sound and WiFi working (if I recall correctly at least kernel 4.14 is required for full support) so its not a full test of Jerry's UEFI build, but that the install process coped with this and produced a bootable system without requiring any post-install surgery should increase confidence in this build.

The only limitation with the modded Lite install I can think of, other than the keyboard/touchpad not working on this machine, is that any necessary packages for the 32bit grub files aren't added to the apt database so if there are any updates they won't be applied.
Last Edit: November 10, 2018, 04:15:16 AM by WytWun
 


Re: UEFI Build Test
« Reply #151 on: November 25, 2018, 01:49:46 AM »
 

freefreeno

  • New to Forums
  • *
  • 12
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.0 64bit

  • CPU: i5 7200u

  • MEMORY: 8Gb

  • VIDEO CARD: Intel graphics 620
inxi -F
System:    Host: josh-Lenovo-YOGA-710-14IKB Kernel: 4.15.0-39-generic x86_64
           bits: 64
           Desktop: Xfce 4.12.3 Distro: Linux Lite 4.2
Machine:   Device: un-determined System: LENOVO product: 80V4 v: Lenovo YOGA 710-14IKB serial: N/A
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: N/A
           UEFI: LENOVO v: 2XCN38WW(V2.12) date: 07/10/2018
Battery    BAT1: charge: 47.5 Wh 98.2% condition: 48.4/53.0 Wh (91%)
CPU:       Dual core Intel Core i5-7200U (-MT-MCP-) cache: 3072 KB
           clock speeds: max: 3100 MHz 1: 706 MHz 2: 704 MHz 3: 700 MHz
           4: 705 MHz
Graphics:  Card: Intel HD Graphics 620
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.05hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
           version: 4.5 Mesa 18.2.4 - padoka PPA
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-39-generic
Network:   Card: Intel Wireless 8260 driver: iwlwifi
           IF: wlp1s0 state: up mac: 44:85:00:fe:90:a2
Drives:    HDD Total Size: 506.1GB (1.3% used)
           ID-1: USB /dev/sda model: Generic size: 256.1GB
           ID-2: /dev/sdb model: Samsung_SSD_860 size: 250.1GB
Partition: ID-1: / size: 80G used: 5.9G (8%) fs: ext4 dev: /dev/sdb2
           ID-2: /home size: 130G used: 289M (1%) fs: ext4 dev: /dev/sdb3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 32.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 197 Uptime: 2:09 Memory: 1655.1/7820.5MB
           Client: Shell (bash) inxi: 2.3.56
 josh  ~  
############################################
sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +39.0C  (high = +100.0C, crit = +100.0C)
Core 0:        +39.0C  (high = +100.0C, crit = +100.0C)
Core 1:        +38.0C  (high = +100.0C, crit = +100.0C)

pch_skylake-virtual-0
Adapter: Virtual device
temp1:        +35.5C 

iwlwifi-virtual-0
Adapter: Virtual device
temp1:        +32.0C 

I am running LL 4.2 in uefi with secure boot off and it installed fine first time around. What makes this interesting is that I am on a Yoga laptop and it is notorius for being a butthole about installing anything because it has a 32 bit uefi and it's a 64 bit PC and for some distro's that is just enough to make you spend a half of day figuring out that you would be better off to just to disable uefi all together and go with legacy but back to the point I was gonna install today anyway and I just went ahead and tried the uefi version and like I said it installed without any problems. I do got one question. Can I enable secure boot now or better to just leave secure off????I had already installed LL 4.0 and 4.2 but I was having a problem with fans running slowly all the time and never shutting down so I went on a distro hopping spree and came back today and thats when I decided to try the uefi. It really doesn't matter to me about the uefi but I do know that some people will not install without uefi support( I know weird right but anyways). Ya'll have a good and keep up the good work. One last thing do we not have a way to disable or change compistor on this distro???
 

Re: UEFI Build Test
« Reply #152 on: November 26, 2018, 12:52:10 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 6449
    Posts
  • Country: nz
  • Reputation: 586
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Should be ok to enable Secure Boot, you can leave it enabled during installation anyway.

Sent from my Mobile phone using Tapatalk
Download your free copy of Linux Lite today.

Jerry Bezencon
Linux Lite Creator

Learn to use your emotions to think, not think with your emotions.



 


 


Linux Lite 4.2 Final has been released. See the Release Announcements Section.