Development > Linux Lite Software Development

ALSA config switch for LibreOffice


Thanks @kpanic , but I am already aware of that, I believe this an XFCE specific DE configuration issue. There is no issue when starting Calc normally from the XFCE GUI. The system sounds all work. I am saying that for some reason starting Calc from the terminal causes it to attempt to use LOs old default ALSA queries, as if it seems to have no access (permission) to the existing XFCE system sound configurations in that environment, i/e it builds a GUI but not from a normal GUI startup for LO thus losing access to the system sound configurations. I'm sure it is the way the mod is starting/not starting that is the problem. If I am correct in that assumption the resolution could scripted for temporary exceptions, which is what I hope to do.

Perhaps something beginning: --unaccept={UNO string}  if indeed the sound connection is sent in such a fashion.


Try switching from ALSA (it is old and soon-to-be-deprecated, I think) to OSS or Pulseaudio.

--- Code: ---sudo lsmod | grep oss
--- End code ---

--- Code: ---snd_pcm_oss            49152  0
snd_seq_oss            45056  0
snd_mixer_oss          28672  1 snd_pcm_oss
snd_pcm                90112  5 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_hda_core
snd_seq_midi_event     16384  1 snd_seq_oss
snd_seq                65536  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device         16384  2 snd_seq,snd_seq_oss
snd                    81920  23 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_seq_oss,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm_oss,snd_pcm,snd_mixer_oss

--- End code ---

I'm script automating several items to use LibreOffice Calc from the terminal, successfully, but with one caveat. I get the ALSA library error when using the LL system sounds. I like the system sounds to be used, but I need a script for turning it off or on when Calc is started from the terminal. Either will work. A sample of the script is below. If I completely turn off system sounds it runs without errors. I want the syetm sounds to keep working. It would be nice to change the ALSA permissions for LibreOffice somehow.

wget -q -P /home/user/test/temp/ ""
libreoffice --calc /home/user/test/temp/* .csv

Update: I am getting a 3617 error for Alsa which essentially points to an incomplete installation. I'm guessing LO Calc is only partially installed.


[0] Message Index

Go to full version