You are Here:
Download Linux Lite 5.2 today - See Release Announcements

How can I install Linux Lite by the very beginning?

Author (Read 10364 times)

0 Members and 5 Guests are viewing this topic.

Re: How can I install Linux Lite by the very beginning?
« Reply #30 on: January 20, 2020, 02:23:30 PM »


  • Gold Level Poster
  • *******
  • 827
  • Country: ve
  • Reputation: 93
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
Wow, what a bad experience! I almost lost my pen drive!   By the way, using Balena Etcher I almost lost my pen drive too.

I had to use "Diskpart" from CMD. I used the commands "list disk", "select disk and "Clean". After that I ran Rufus again using the first option. And now at least my pendrive is back live.

However I still am not able to install LL, even excluding step 3.

I think maybe the problem is the failure on constructing a bootable device, although Rufus said the procedure was concluded successfully.

@Roken, Are you using the same "not so old pendrive" that has repeatedly failed to boot time after time or the "old one" you said did succesfully booted the "windows for example"? I think you might give that a try and see how that goes.
Without each others help there ain't no hope for us :)

Re: How can I install Linux Lite by the very beginning?
« Reply #31 on: January 20, 2020, 03:28:46 PM »


  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1481
  • Country: us
  • Reputation: 260
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x


I'm afraid your comment does not helped.

However I did research about UEFI since you said itīs like other kind of BIOS. And I find out I have BIOS not UEFI !!!

Thatīs why my BIOS donīt have the option to enable legacy bios as I told before, because it IS the legacy BIOS already.

About Etcher, are you assuming that is impossible to Balena Etcher fail ??

It's the same that saying all Linux O.S. is fully dependent on a third party software called Balena Etcher!  If Balena Etcher fails no one never could be able to use Linux ever.  Thatīs insane!

It does not help if you go this way and do not check others alternatives how to do that like I was trying to do.

I'm saying, saying it "It doesn't work"  - doesn't help anyone trying to help you.
I'm assuming something is wrong - I'm trying to help figure out what...

You may be overthinking it. Have you found one that does create a bootable usb? if so, use that - yes they are all the same (except multiboots)...
I typically dont use etcher.... BUT Don't assume cause its not readable its failed... Try it, it may work

Yep, I saw that Balena Etcher on the manual. This Balena Etcher just donīt work (by the way I almost lost my pendrive doing that!).

When I followed Balena Etcher procedure, it simply created an empty USB drive that Windows or the BIOS cannot read.

That is by design - Windows will not read it, its a boot disk now, as I mentioned in my previous post..

ARE you certain of your BIOS??
In a previous post you say... you disabled secureboot? - - That is available to UEFI.. not typically a bios...

Yes, I disabled secure boot.  It seems I don't have the option to enable legacy boot on my BIOS configuration. But the first boot is set to be my USB! It appears the fabrication name of my USB.

However, still Windows 10 is always started and no Linux Lite options is displayed.

If you haven't yet - Please try the UEFI version - it will install to either a BIOS or UEFI enabled systems --- a BIOS installer will only install to BIOS...

Don't give up @Roken

If the PC is UEFI - BIOS LL will not install (you are correct it doesn't see/read it)

You haven't mentioned you PC model - it might help us point you in the right direction...?

You can also look in System Information (msinfo32 from run) for BIOS

LL 4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2

Re: How can I install Linux Lite by the very beginning?
« Reply #32 on: December 28, 2020, 02:35:04 PM »


  • New to Forums
  • *
  • 1
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.2 64bit
I know that was a old post but maybe that could help someone.
I had the same problem and personaly that was just a corrupted iso.
So I downloaded it again and that's working for me.
Last Edit: December 28, 2020, 02:39:53 PM by Nasmad

Re: How can I install Linux Lite by the very beginning?
« Reply #33 on: January 04, 2021, 07:26:19 AM »


  • Gold Level Poster
  • *******
  • 840
  • Country: ca
  • Reputation: 71
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 4.8 64bit

  • CPU: HAL9000

  • MEMORY: 2Gb

  • VIDEO CARD: Quantum State VR v.3

  • Kernel: 4.x
LoL Nasmad... if that was the case here... the thread was a lot of wasted effort! ;)
If not, maybe 5.x works now...
- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.


Download Linux Lite 5.2 today - See Release Announcements