You are Here:
Linux Lite 5.0 Final is now available for download and installation



Wine 2.x has no icon in Whisker menu

Author (Read 3374 times)

0 Members and 1 Guest are viewing this topic.

Wine 2.x has no icon in Whisker menu
« on: August 25, 2017, 11:15:50 AM »
 

TheDead

  • Gold Level Poster
  • *******
  • 765
    Posts
  • Country: ca
  • Reputation: 70
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 4.8 64bit

  • CPU: HAL9000

  • MEMORY: 2Gb

  • VIDEO CARD: Quantum State VR v.3

  • Kernel: 4.x
Helloooo!


To have the latest version I installed Wine from here :
https://wiki.winehq.org/Ubuntu
using the version sudo apt-get install --install-recommends winehq-devel


But the Wine icons (WineCfg, Windows Program folder, etc.) do not show up up the Whisker menu.


Is there something else I'm suppose to do or it's maybe because of the Whisker menu itself?


Yeah, I try to spread Linux Lite but being able to run some Windows apps is a nice "selling" point. ;)


-TheDead



- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 


Re: Wine 2.x has no icon in Whisker menu
« Reply #1 on: August 25, 2017, 02:26:12 PM »
 

smhardesty

  • Forum Regular
  • ***
  • 165
    Posts
  • Country: us
  • Reputation: 23
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: AMD A8-6410 APU

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Radeon R5 Graphics 4
Just to clarify. Are you saying that there are entries on the Menu for launching "WineCfg, Windows Program folder, etc", but no icons? Or are you saying there are no entries at all?
Steve

If I was able to help, click my "Thank" link.
 

Re: Wine 2.x has no icon in Whisker menu
« Reply #2 on: September 03, 2017, 12:04:57 PM »
 

TheDead

  • Gold Level Poster
  • *******
  • 765
    Posts
  • Country: ca
  • Reputation: 70
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 4.8 64bit

  • CPU: HAL9000

  • MEMORY: 2Gb

  • VIDEO CARD: Quantum State VR v.3

  • Kernel: 4.x
There are no entries at all. :(
- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 

Re: Wine 2.x has no icon in Whisker menu
« Reply #3 on: September 03, 2017, 01:24:58 PM »
 

smhardesty

  • Forum Regular
  • ***
  • 165
    Posts
  • Country: us
  • Reputation: 23
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: AMD A8-6410 APU

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Radeon R5 Graphics 4
OK. I'll have to defer to one of the more experienced guys to help with that. I could have walked you through putting icons on a Menu entry. I don't use Wine so I don't know what the commands to launch it are. I can tell you that what you'll be doing is adding a new Menu item.

Anybody care to help him?
Steve

If I was able to help, click my "Thank" link.
 

Re: Wine 2.x has no icon in Whisker menu
« Reply #4 on: September 03, 2017, 05:57:46 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3180
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
There are no entries at all. :(

Hello TheDead,

you can add new Menu items by - Menu>All>Main Menu

On the GUI, right side click, "+ New Item" button.
Type in the name, then click browse to locate your folder for Wine, open folder how is the executable icon/launcher, click it, click okay.

You can find this if you unsure of location using the Menu>Accessories>File Search
When finding the launcher you can see its script for launch from viewing properties of this etc.

Wine is also available in Menu>System>Lite Software

You would need to remove and purge the installed one, and remove the PPA before using version in Lite Software, so it can make a clean installation.
Last Edit: September 03, 2017, 06:05:41 PM by bitsnpcs
 

Re: Wine 2.x has no icon in Whisker menu
« Reply #5 on: September 04, 2017, 10:37:17 AM »
 

TheDead

  • Gold Level Poster
  • *******
  • 765
    Posts
  • Country: ca
  • Reputation: 70
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 4.8 64bit

  • CPU: HAL9000

  • MEMORY: 2Gb

  • VIDEO CARD: Quantum State VR v.3

  • Kernel: 4.x
Thanks bitsnpcs! That wirked (with somr fildeling ;) ), and also gave me anm idea for the next install. I'll try and copy the Wine 1.x icons, uninstall it and pur them back after 2.x install.
(and sorry, for typos... I hate iPhones, stuck with one for work :( )
- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 

Re: Wine 2.x has no icon in Whisker menu
« Reply #6 on: September 04, 2017, 12:31:31 PM »
 

smhardesty

  • Forum Regular
  • ***
  • 165
    Posts
  • Country: us
  • Reputation: 23
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: AMD A8-6410 APU

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Radeon R5 Graphics 4
Thanks, bnp. I probably could have got him there, but not as quickly and neatly as you did.

TheDead, if the problem is resolved, could you mark the thread 'Solved". Thanks.
Steve

If I was able to help, click my "Thank" link.
 

Re: Wine 2.x has no icon in Whisker menu
« Reply #7 on: September 04, 2017, 03:04:49 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3180
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Thanks bitsnpcs! That wirked (with somr fildeling ;) ), and also gave me anm idea for the next install. I'll try and copy the Wine 1.x icons, uninstall it and pur them back after 2.x install.
(and sorry, for typos... I hate iPhones, stuck with one for work :( )
You are Welcome TheDead, happy to have helped :)
I hate iphones too.

@smhardesty I enjoy to try and join in with my peers in the community :)
 

Re: Wine 2.x has no icon in Whisker menu
« Reply #8 on: September 07, 2017, 05:07:08 PM »
 

TheDead

  • Gold Level Poster
  • *******
  • 765
    Posts
  • Country: ca
  • Reputation: 70
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 4.8 64bit

  • CPU: HAL9000

  • MEMORY: 2Gb

  • VIDEO CARD: Quantum State VR v.3

  • Kernel: 4.x
Ok, I was able to copy the shortcuts for the applications. But, the "Program Files' could not because its link to a folder.
But, since I'm a Linux No0b, I have to ask, is this common when installing apps that no icons are added to start menu?
Is it only for non-default synaptics packages (i.e. added repositories) or an installer issue?

TheDead (TheNo0b)
- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 

Re: Wine 2.x has no icon in Whisker menu
« Reply #9 on: September 07, 2017, 07:17:47 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3180
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Hello TheDead,

I had with Etcher only, it changes/doesn't hold icon, I just deleted icon from the menu, and it lives in a folder inside the Home folder.



 

Re: Wine 2.x has no icon in Whisker menu
« Reply #10 on: September 08, 2017, 04:07:54 PM »
 

TheDead

  • Gold Level Poster
  • *******
  • 765
    Posts
  • Country: ca
  • Reputation: 70
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 4.8 64bit

  • CPU: HAL9000

  • MEMORY: 2Gb

  • VIDEO CARD: Quantum State VR v.3

  • Kernel: 4.x
I'll try my luck in the Wine support forums. ;)
Also, I didn't know of Etcher, seems like a really nice tool to put ISOs on USB Keys.
I was asking myself just this week if something like that was on Linux. Super k0oL!

Thanks b&p, you da man!
- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 

Re: Wine 2.x has no icon in Whisker menu
« Reply #11 on: September 08, 2017, 04:34:23 PM »
 

TheDead

  • Gold Level Poster
  • *******
  • 765
    Posts
  • Country: ca
  • Reputation: 70
  • Linux Lite Worshipper
    • My OpenDesktop Projects

  • Linux Lite: 4.8 64bit

  • CPU: HAL9000

  • MEMORY: 2Gb

  • VIDEO CARD: Quantum State VR v.3

  • Kernel: 4.x
I think I found a solution for ALL missing icons to programs in the main menus that should be there.

I don't have a LL machine here to try but I found something really interesting here :
https://bugs.launchpad.net/ubuntu/+source/xfce4-panel/+bug/1332385

and a great explanation at comment number 8 (https://bugs.launchpad.net/ubuntu/+source/xfce4-panel/+bug/1332385/comments/8)

Gisin Bernard (bernard5) wrote on 2014-08-24:
The bug described by ToZ comes from a more general Bug.
In Xfce, if a menu contains only submenues, this menu is not visible.
Using the "menu principal" in french or "Main menu", from the "alacarte" package, you can add a "new item" to the menu, then the menu will be visible.

For example, if you add any "new item" to the "Programs" menu of "Wine", then the "Programs" menu of "Wine" will be visible.
Il you remove all "item" from the "Programs" menu, it will disapear.

The same is true for any other menu, having only "submenus" without any items.
You can try adding a submenu to "System", it will not appear until you add an item to this submenu.

Temporarly, a way to deal with this bug is to add any "new item" to a menu, to make it appear.

This was tested with XUbuntu 14.04, on different computers and different installations.

I tested also that this bug doesn't exist under KDE and GOME, but exist under XUbuntu and under Xfce.

+ other comments mentionned that sames goes for Xubuntu 16.04 and 17.04.
- TheDead (TheUxNo0b)

If my blabbering was helpful, please click my [Thank] link.
 


Tags:
 


Linux Lite 5.0 Final is now available for download and installation