You are Here:
Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.



Virtualbox updating

Author (Read 1043 times)

0 Members and 5 Guests are viewing this topic.

Virtualbox updating
« on: July 08, 2019, 04:52:50 PM »
 

BarryVG

  • Occasional Poster
  • **
  • 59
    Posts
  • Reputation: 8
  • Linux Lite Member

  • CPU: Intel (R) Pentium (R) 4 2.80GHz

  • MEMORY: 1Gb

  • VIDEO CARD: Intel Corp 82915G//910GL
Saw note that Kernel 5.2 was available and so went ahead and did this.  However, now the Virtualbox setup is not running.  Keep getting an error that says to reinstall the virtualbox-dkms package and then load the kernel module by executing 'modprobe vboxdrv'. 
Virtualbox is at version 5, which was installed using the Lite Software install procedure.  I've noted that even though Virtualbox version 6 is available, this is not being updated during regular weekly system updates.  I have previously put in the repositories, but after doing this, nothing seems to work.  Meaning having to unload all my data files, reformat and reload the OS all over again. 
What am I missing and any guidance to move forward would be helpful.  Been using LL since version 2.2 and I'm more than pleased with the OS.  But this issue is starting to become irritating.
Last Edit: July 08, 2019, 06:15:01 PM by BarryVG
 


Re: Virtualbox updating
« Reply #1 on: July 08, 2019, 05:10:37 PM »
 

BarryVG

  • Occasional Poster
  • **
  • 59
    Posts
  • Reputation: 8
  • Linux Lite Member

  • CPU: Intel (R) Pentium (R) 4 2.80GHz

  • MEMORY: 1Gb

  • VIDEO CARD: Intel Corp 82915G//910GL
System says to run the modprobe vboxdrv as root, but the logon account is already an admin account and there is no root account.  even tried to create one and not allowed.  Any help greatly appreciated.
 

Re: Virtualbox updating
« Reply #2 on: July 08, 2019, 05:32:15 PM »
 

DeepThought

  • Forum Regular
  • ***
  • 151
    Posts
  • Country: wales
  • Reputation: 30
  • Linux Lite Member
    • WKDfm Radio | WKDfm Chat

  • Linux Lite: 4.2 64bit

  • CPU: AMD Turion(tm) 64 x 2 Mobile Technology TL-60

  • MEMORY: 4Gb

  • VIDEO CARD: ATI RS480
when you use sudo you are running a command as root, so simply do:

Code: [Select]
sudo modprobe vboxdrv
and enter your user password when asked for.

Hope this helps :)
Owner and DJ at WKDfm Radio ( www.wkdfm.co.uk )
 

Re: Virtualbox updating
« Reply #3 on: July 08, 2019, 06:18:08 PM »
 

BarryVG

  • Occasional Poster
  • **
  • 59
    Posts
  • Reputation: 8
  • Linux Lite Member

  • CPU: Intel (R) Pentium (R) 4 2.80GHz

  • MEMORY: 1Gb

  • VIDEO CARD: Intel Corp 82915G//910GL
I did and it didn't accept the entry.Removed VB 5.2 using the Lite Software tool.  Loaded repositories, then installed VB 6.  Then updated again. Found a web page that helped alothttps://websiteforstudents.com/virtualbox-6-0-is-out-heres-how-to-install-upgrade-on-ubuntu-16-04-18-04-18-10/
Able to run the client OS's with that same error, but able to run.  Will keep trying.
 

Re: Virtualbox updating
« Reply #4 on: July 08, 2019, 06:34:29 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7032
    Posts
  • Country: nz
  • Reputation: 653
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
VB should only be installed via Lite Software and you shouldn't be running kernel 5.2 on that machine. Now it has caused all this extra work. VB6 is cutting edge and won't go in the repos until Ubuntu are satisfied that it is stable enough to run with the rest of the system. Your issue is 'irratating' because it is self inflicted. Please just install 4.4, and then other software the recommended way. You don't need the latest of everything, you just need stable, which of course you now don't have. Cheers.
 

Re: Virtualbox updating
« Reply #5 on: July 10, 2019, 06:38:52 PM »
 

BarryVG

  • Occasional Poster
  • **
  • 59
    Posts
  • Reputation: 8
  • Linux Lite Member

  • CPU: Intel (R) Pentium (R) 4 2.80GHz

  • MEMORY: 1Gb

  • VIDEO CARD: Intel Corp 82915G//910GL
Thanks Jerry, that is what I'm doing to get back to a working system.
 

Re: Virtualbox updating
« Reply #6 on: July 10, 2019, 06:52:31 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7032
    Posts
  • Country: nz
  • Reputation: 653
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960
Good stuff :)
 


Tags:
 


Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.