You are Here:
Linux Lite 5.0 Final is now available for download and installation



LuckyBackup not working in LL50

Author (Read 214 times)

waynebob, Şerban S., Moltke and 61 Guests are viewing this topic.

Re: LuckyBackup not working in LL50
« Reply #15 on: August 10, 2020, 11:15:10 PM »
 

arky217

  • New to Forums
  • *
  • 43
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Pentium Gold G5400

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 610

  • Kernel: 4.x
I think I've found a solution or at least a "better" workaround; open a terminal and type
Code: [Select]
pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY luckybackup a window should pop up for you to type in your password and LBSU  should launch/start and if it does, open a terminal and type
Code: [Select]
sudo nano /usr/bin/luckybackup-pkexec comment the lines in the file, copy/paste the pkexec command above, hit Ctrl + o to save changes and then Ctrl + x to close nano.



Now, click on menu, search for luckybackup and click on LBSU, a window should pop up for you to type in your password, hit enter and LBSU should start without a problem, at least It did here. :)



Moltke, the procedure I did in post #8 works fine for me, but I did start to do what you mentioned above.

But when I copied  pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY luckybackup
and pasted it in the terminal, I got a Warning- Unsafe Paste with the options to quit or paste.
Wasn't sure if I was about to mess something up, so I chose quit.

Did you get any warning when you entered that in the terminal ?

No, I didn't get any but I didn't use xfce4-terminal but konsole and I do know xfce4-terminal does that, so it's safe to paste the command, however, if it makes you feel a bit safer, copy/paste to a text editor first then copy from that one and paste it to the terminal, it  shouldn't trigger any warnings now. It does that cause you're copying/pasting something from a web page.

Ok, I did as you said above and put the original command (/usr/bin/luckybackup-pkexec) back in and
unchecked the 'Run in terminal' box and yes, it starts and runs ok now without having to use the terminal.
Thank you very much.
 


Re: LuckyBackup not working in LL50
« Reply #16 on: August 10, 2020, 11:31:07 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1414
    Posts
  • Country: us
  • Reputation: 255
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
Thank you firenice03 for that link.

I edited the command in Luckybackup (superuser) and put in  sudo -H luckybackup

Then I checked the box 'Run in terminal'.

Now when I click on the Luckybackup (superuser) icon, the terminal opens,
I enter my sudo password and LuckyBackup starts.
I created a task and backed up my Documents folder to the external drive, works fine.
Of course, I have to mount the external drive first or Luckybackup won't see it.


Quote
Ok, I did as you said above and put the original command (/usr/bin/luckybackup-pkexec) back in and
unchecked the 'Run in terminal' box and yes, it starts and runs ok now without having to use the terminal.
Thank you very much.


@arky217
Good to hear you have a couple workarounds and something suitable that works for you  :)


@Moltke
Thanks for some additional googling ;) .... gotta +1 ya  8)


I haven't used Lucky Backup, and didn't want to go too far down the rabbit hole this for that  :o



LL 4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 

Re: LuckyBackup not working in LL50
« Reply #17 on: Today at 06:17:17 AM »
 

Şerban S.

  • Şerban
  • PayPal Supporter
  • Forum Regular
  • *****
  • 134
    Posts
  • Country: ro
  • Reputation: 7
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: Intel® Core™ i7-4790

  • MEMORY: 16Gb

  • VIDEO CARD: Intel® HD Graphics 4600 + NVidia GK107 (GeForce GT630 OEM)

  • Kernel: 5.x
[...] It does that cause you're copying/pasting something from a web page.

Moltke, thanks for the tip!
I always use text files for this kind of tasks, but who knows, this might prove invaluable info at some point! :)
Some editors copy the code (HTML, XML) instead of the rendered output (I saw that many times) so it's important to be aware of that! :)

Regards! :)
"It's easy to die for an idea. It's way harder TO LIVE for your idea!"
Current Machine:
 Dell Precision T1700, 16 GB RAM, 240 GB SSD.
Laptop:
 Lenovo ThinkPad T400 + SSD Kingston A 400, 480 GB.
 


Tags:
 


Linux Lite 5.0 Final is now available for download and installation