You are Here:
Linux Lite 5.0 Final is now available for download and installation

L2TP VPN setup to a Cisco MX100 Meraki

Author (Read 1104 times)

0 Members and 1 Guest are viewing this topic.

L2TP VPN setup to a Cisco MX100 Meraki
« on: May 06, 2020, 03:05:23 AM »


  • New to Forums
  • *
  • 1
  • Country: au
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: i7 3520M

  • MEMORY: 12Gb

  • VIDEO CARD: onboard
Hello Everyone,

I am new here and also Linux is newish to me, I have used a few time back in the days but now I have pulled the trigger and have converted my full time laptop to run Linux.
So there is a lot for me to learn. I have tried to run a search from the search bar so if I have happened to missed it please don't roast me that badly.

Anyway enough of my boring stuff, I was wondering if anyone here have any issues on setting up L2TP VPN connection?
I am runing LL4.8 with:

So far this is have managed to setup an L2TP profile on the network VPN connection.

I have put in the usual settings:
Gateway (Tried both hostname and IP address),
add in the Username and Password,
I have confirmed the account is working as I have tested the same account under Windows and Via the Phone it seems to be connecting ok.

Under IPsec setting:
Enable IPsec tunnel to L2TP host
Enter in the Pre-Shared Key xxxxxx,

Under L2TP PPP Options:
Allow PAP Authentication (confirmed with Cisco support that this PAP is the one to use)
I did try a few different combination such as MSCHAP, MSCHAPv2 still didn't work.

With the above setting I am unable to get it connected and kept failing on me.

If there is one of you guru can point me in the right direction would be greatly appreciated.
Not sure if I am missing on some plugin? or perhaps I have missed out on some tick box?

Let me know if you wanted me to upload some pic

Kind regards
Newbie User

Tags: l2tp vpn 

Linux Lite 5.0 Final is now available for download and installation