You are Here:
Linux Lite 5.0 Final is now available for download and installation



[ SOLVED ] CPU without sse2 crashes Firefox update

Author (Read 4510 times)

0 Members and 2 Guests are viewing this topic.

CPU without sse2 crashes Firefox update
« on: June 05, 2017, 11:46:14 AM »
 

slivo59

  • New to Forums
  • *
  • 2
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 32bit

  • CPU: amd athlon (tm) xp 2500+

  • MEMORY: 2Gb

  • VIDEO CARD: nvdia geforce2 mx100/200
i happen to have a CPU without sse2 ie Athlon XP

i run duel boot, windows xp and now Linux lite 3.4 (have had 3.2 , 2.8 and 2.4)

Windows xp loads Firefox up to version 48.02 after that it refuses to install as it knows sse2 support is not available. i can also stop it updating in the preferences.

The Linux lite installation disk 3.4 loads Firefox version 52.0.1 everything works access to the Internet and manuals.

First install of updates loads Firefox version 53.0.1 Firefox crashes no access to the Internet or manuals
chromium browser if loaded also crashes.

Tor browser if you load it works but its a poor replacement as has no cached files.

Linux lite does not check for sse2 compatibility so loads latest version of Firefox, that also happened to Linux lite versions 3.2 , 2.8 and 2.4

Would be nice if i was given a option whether or not to update Firefox.

Will still use Linux lite and Firefox but will not update it when asked to,

Exert From https://en.wikipedia.org/wiki/SSE2

CPU support

SSE2 is an extension of the IA-32 architecture, based on the x86 instruction set. Therefore, only x86 processors can include SSE2. The AMD64 architecture supports the IA-32 as a compatibility mode and includes the SSE2 in its specification.[1][2] It also doubles the number of XMM registers allowing for better performance. SSE2 is also a requirement for installing Windows 8 (and later) or Microsoft Office 2013 (and later) "to enhance the reliability of third-party apps and drivers running in Windows 8".[3]

The following IA-32 CPUs support SSE2:

    Intel NetBurst-based CPUs (Pentium 4, Xeon, Celeron, Pentium D, Celeron D)
    Intel Pentium M and Celeron M
    Intel Atom
    Transmeta Efficeon
    VIA C7

The following IA-32 CPUs were released after SSE2 was developed, but did not implement it:

    AMD CPUs prior to Athlon 64, such as Athlon XP
    VIA C3
    Transmeta Crusoe
    Intel Quark
Last Edit: June 06, 2017, 08:39:28 AM by slivo59
 


Re: CPU without sse2 crashes Firefox update
« Reply #1 on: June 05, 2017, 02:38:32 PM »
 

supergamer

  • Forum Regular
  • ***
  • 163
    Posts
  • Country: us
  • Reputation: 27
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: AMD Phenom 565

  • MEMORY: 12Gb

  • VIDEO CARD: 550 ti
There is a way but you need to do this before updating the system. This is an example for chromium:


Code: [Select]
Disable a package to be updated:


sudo apt-mark hold chromium-browser


Enable the package to be updated:


sudo apt-mark unhold chromium-browser


Edit: Please fancy me for alittle bit. Try running the LinuxLite iso in live mode, just update Firefox or Chrome or whatever you use, I am trying to see if the kernel update (or any other update) might have affected this instead of actually the updated Firefox. It is time consuming but you can actually find out what package is the problem this way.
Last Edit: June 05, 2017, 03:50:50 PM by supergamer
 

Re: CPU without sse2 crashes Firefox update
« Reply #2 on: June 06, 2017, 08:36:59 AM »
 

slivo59

  • New to Forums
  • *
  • 2
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 32bit

  • CPU: amd athlon (tm) xp 2500+

  • MEMORY: 2Gb

  • VIDEO CARD: nvdia geforce2 mx100/200
The fix worked i am fully up to date
Thank you

here is what Firefox say for similar pc's like mine without sse2 processors
Your hardware is no longer supported, this would apply to linux Lite versions also
Firefox ESR version 52 was the last version that supported non sse2 processors.
https://support.mozilla.org/en-US/kb/your-hardware-no-longer-supported

Ps, at critical build points i do system backups,
which allow me to test software/updates and i also keep a diary of changes
Pps, i think i could use this fix to go between versions say to 3.6 when it comes.
 


Tags:
 


Linux Lite 5.0 Final is now available for download and installation