Software - Support > Installing Software

Sky Charts install

(1/6) > >>

Glad you got it installed.   I've marked the thread as Solved - you need to be modifying the initial post to choose a prefix for the thread.
For what it is worth, the install script from skychart should have worked.  I still don't understand the underlying issue of wget on your system not behaving as expected.

This command checks to see if you have a wget startup file in a non standard location.
Would you post back with the result of

--- Code: ---env | grep -i WGET
--- End code ---

I'm looking at the Modify Message screen and there is no Prefix to choose.  So, I don't know how to mark this as SOLVED.

Thanks to you, stevef, and others like who make Linux "simple".  Without you it would be impossible.  My SkyCharts software is nearly done installing.  Now I need to read up on how to close this out.   Thanks again.

Thank you.  That shows that wget on your system is saving the key as a compressed file.
The skychart install script doesn't run properly with the compressed data because the gpg commands it uses do not work with compressed data.

The best thing would be to understand how/why wget is doing this and correcting that to allow the script to run.
An alternative is to import the key and add the repository manually with a few extra commands to deal with the compressed download.  To emulate what the script does but without the errors, follow the commands below in sequence.  If you get any error messages or unexpected responses please post back.  Sorry if it looks a bit daunting, but it is just a case of pasting in the commands and reading the responses.

Rename and decompress the compressed file.

--- Code: ---mv 8B8B57C1AA716FC2.key 8B8B57C1AA716FC2.gz
--- End code ---

--- Code: ---gzip -dc 8B8B57C1AA716FC2.gz >8B8B57C1AA716FC2.key
--- End code ---

Check the result by running these commands.

--- Code: ---file 8B8B57C1AA716FC2.key
--- End code ---
Expected response
8B8B57C1AA716FC2.key: PGP public key block Secret-Key

--- Code: ---md5sum 8B8B57C1AA716FC2.key
--- End code ---
Expected response
807f6e1d41cf5406c080609cd42104a3  8B8B57C1AA716FC2.key

Run these commands to import the public key and export as a keyring file

--- Code: ---gpg --no-default-keyring --keyring ./skychart-temp-keyring.gpg --import 8B8B57C1AA716FC2.key
--- End code ---
Expected response
gpg: WARNING: unsafe permissions on homedir '/home/bill/.gnupg'
gpg: key 8B8B57C1AA716FC2: public key "Patrick Chevalley <[email protected]>" imported
gpg: Total number processed: 1
gpg:               imported: 1

--- Code: ---gpg --no-default-keyring --keyring ./skychart-temp-keyring.gpg --export --output skychart.gpg
--- End code ---
Expected response
gpg: WARNING: unsafe permissions on homedir '/home/bill/.gnupg'

Check the keyring with this

--- Code: ---file skychart.gpg
--- End code ---
Expected response
skychart.gpg: PGP/GPG key public ring (v4) created Sun Sep 18 20:13:08 2016 RSA (Encrypt or Sign) 2048 bits MPI=0xb0642ac63565db5c...

Delete the temporary files used to create the keyring

--- Code: ---rm skychart-temp-keyring.gpg
--- End code ---

--- Code: ---rm skychart-temp-keyring.gpg~
--- End code ---

--- Code: ---rm 8B8B57C1AA716FC2.key
--- End code ---

Make the folder for the keyring (if it already exists you'll see a message which can be ignored) and move the keyring to it

--- Code: ---sudo mkdir /usr/local/share/keyrings
--- End code ---

--- Code: ---sudo mv skychart.gpg /usr/local/share/keyrings/
--- End code ---

Add the skychart (stable) repository with the signing information with this command.
The choice of stable is based on your selections in previous posts.
If you want the more frequently updated beta version, replace the word 'stable' with 'unstable'

--- Code: ---sudo sh -c "echo deb [signed-by=/usr/local/share/keyrings/skychart.gpg] stable main > /etc/apt/sources.list.d/skychart.list"
--- End code ---

Confirm the key is correctly installed and the skychart repository is available.

--- Code: ---sudo apt update
--- End code ---
Expected response is a line like this somewhere in the list stable InRelease [3,615 B]

If that line appears you have done the equivalent of step 1 and step 2 of the skychart ubuntu installation.
Open this link in a browser

--- Code: ---
--- End code ---
and rejoin their guide at step 3

If they are still on your system, you can also delete a couple of files that we used earlier while testing the wget operation.

--- Code: ---rm skychartpublic.key
--- End code ---

--- Code: ---rm testskychart.key
--- End code ---

 bill  ~  rm 8B8B57C1AA716FC2.key
rm: cannot remove '8B8B57C1AA716FC2.key': No such file or directory
 bill  ~  1  wget -O 8B8B57C1AA716FC2.key ""
--2023-09-05 19:38:24--
Resolving (,, 2620:2d:4000:1007::d43, ...
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1357 (1.3K) [text/plain]
Saving to: ‘8B8B57C1AA716FC2.key’

8B8B57C1AA716FC2.key              100%[===========================================================>]   1.33K  --.-KB/s    in 0.05s   

2023-09-05 19:38:25 (29.3 KB/s) - ‘8B8B57C1AA716FC2.key’ saved [1357/1357]

 bill  ~  file 8B8B57C1AA716FC2.key
8B8B57C1AA716FC2.key: gzip compressed data, from Unix, original size modulo 2^32 1739
 bill  ~  

The 8B8B57C1AA716FC2.key file is in my home dir.

Should I try the install again?


[0] Message Index

[#] Next page

Go to full version