You are Here:
Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section



(How) can SageMath be installed on LL 6.2?

Author (Read 5584 times)

0 Members and 2 Guests are viewing this topic.

Re: (How) can SageMath be installed on LL 6.2?
« Reply #3 on: February 10, 2023, 11:14:39 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1459
    Posts
  • Reputation: 211
  • Linux Lite Member
    • View Profile
    • dbts-analytics.com

  • CPU: i7 4 cores 8 threads

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD graphics

  • Kernel: 5.x
https://packages.debian.org/bullseye/sagemath
https://packages.ubuntu.com/jammy/sagemath
or the 5.8 case:
https://packages.debian.org/buster/sagemath
https://packages.ubuntu.com/focal/math/sagemath
Ubuntu is in the Universe Repo.
Looking at the two packages diverse functionality may be better in Debian.
The focal package is no longer recommended but the jammy package is reported by some to work on focal and jammy once the dependencies resolve.
TC
« Last Edit: February 10, 2023, 11:32:20 AM by trinidad »
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: (How) can SageMath be installed on LL 6.2?
« Reply #2 on: February 09, 2023, 06:40:30 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1848
    Posts
  • Reputation: 284
  • Linux Lite Member
    • View Profile

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
@Chompo
Might be curious as to the error..

I looked on a 4.8 machine that is close - apt search sagemath showed it in the repo..
I ran the install command  apt install sagemath and a list of dependancies were displayed along with the ... do you want to install... which I cancelled

I did test on my LL6.2 VM and the install was the same. I would want to assume the same for LL5.x

Again maybe the error will help as to the why.
Maybe try running a Lite Update prior may help as well.
« Last Edit: February 09, 2023, 06:51:43 PM by firenice03 »
LL4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL5.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL4.8 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express  -- Shelved
BACK LL5.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA - Print Server
Running Linux Lite since LL2.2
 

(How) can SageMath be installed on LL 6.2?
« Reply #1 on: February 09, 2023, 06:00:17 PM »
 

Chompo

  • New to Forums
  • *
  • 7
    Posts
  • Reputation: 0
    • View Profile

  • CPU: Intel Core i3-370M

  • MEMORY: 2Gb

  • Kernel: 6.x
Hi. My Linux Lite version is 5.8 and I am trying to install a program called SageMath by entering "sudo apt install sagemath" on the Terminal, but I keep getting some sort of "uninstallable packages" error.
Before even attempting to troubleshoot the installation, I'd like to know whether it works on Linux Lite 6.2 without errors. If it does, I'll just upgrade the OS.

Thanks in advance.
 

 

-->
X Close Ad

Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section