You are Here:
Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section



samba-libs:i386 Dependency hell

Author (Read 5829 times)

0 Members and 1 Guest are viewing this topic.

samba-libs:i386 Dependency hell
« Reply #1 on: February 12, 2023, 07:20:46 AM »
 

Nicholas Markovich

  • New to Forums
  • *
  • 1
    Posts
  • Reputation: 0
    • View Profile
Trying to install the 32bit Samba libraries for a compile of Wine for some regression testing. Stuck in dependency hell:
Code: [Select]
kernel  ~  sudo apt install samba-libs:i386
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3 : Conflicts: python3:i386 but 3.10.6-1~22.04 is to be installed
 python3:i386 : Conflicts: python3 but 3.10.6-1~22.04 is to be installed
 python3-ldb : Conflicts: python3-ldb:i386 but 2:2.4.4-0ubuntu0.1 is to be installed
 python3-ldb:i386 : Conflicts: python3-ldb but 2:2.4.4-0ubuntu0.1 is to be installed
 python3-minimal : Conflicts: python3-minimal:i386 but 3.10.6-1~22.04 is to be installed
 python3-minimal:i386 : Conflicts: python3-minimal but 3.10.6-1~22.04 is to be installed
 python3.10 : Conflicts: python3.10:i386 but 3.10.6-1~22.04.2 is to be installed
 python3.10:i386 : Conflicts: python3.10 but 3.10.6-1~22.04.2 is to be installed
 python3.10-minimal : Conflicts: python3.10-minimal:i386 but 3.10.6-1~22.04.2 is to be installed
 python3.10-minimal:i386 : Conflicts: python3.10-minimal but 3.10.6-1~22.04.2 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
 kernel  ~  100 
Lots of stuff depends on python, removing it would be a headache:
Code: [Select]
 kernel  ~  100  sudo apt remove python3
[sudo] password for kernel:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apt-clone : Depends: python3:any
             Depends: lsb-release but it is not going to be installed
             Depends: python3 but it is not going to be installed
 apt-xapian-index : Depends: python3 but it is not going to be installed
                    Depends: python3-debian (>= 0.1.14) but it is not going to be installed
                    Depends: python3:any
 aptdaemon : Depends: python3:any (>= 3.2~)
 blueman : Depends: python3 (< 3.11) but it is not going to be installed
           Depends: python3 (>= 3.10~) but it is not going to be installed
           Depends: python3:any
 catfish : Depends: python3-pexpect but it is not going to be installed
           Depends: python3:any
 cifs-utils : Depends: python3 but it is not going to be installed
 deluge : Depends: python3:any
 deluge-common : Depends: python3-chardet but it is not going to be installed
                 Depends: python3-pyasn1 but it is not going to be installed
                 Depends: python3-six but it is not going to be installed
                 Depends: python3-xdg but it is not going to be installed
                 Depends: python3:any
                 Depends: python3-pkg-resources but it is not going to be installed
 deluge-gtk : Depends: python3:any
 duplicity : Depends: python3 (< 3.11) but it is not going to be installed
             Depends: python3 (>= 3.10~) but it is not going to be installed
             Depends: python3-fasteners but it is not going to be installed
             Depends: python3-future but it is not going to be installed
             Depends: python3:any (>= 3.7~)
             Depends: python3-lockfile but it is not going to be installed
             Recommends: python3-paramiko but it is not going to be installed
             Recommends: python3-pexpect but it is not going to be installed
             Recommends: python3-urllib3 but it is not going to be installed
 firewall-config : Depends: python3:any
 firewalld : Depends: python3:any
 gdebi : Depends: python3:any (>= 3.3~)
         Recommends: libgtk2-perl but it is not installable
 gdebi-core : Depends: python3:any (>= 3.3~)
              Depends: python3-debian but it is not going to be installed
 gir1.2-xapp-1.0 : Depends: python3:any
 gobject-introspection : Depends: python3 (< 3.11) but it is not going to be installed
                         Depends: python3 (>= 3.10~) but it is not going to be installed
                         Depends: python3:any
                         Depends: python3-distutils but it is not going to be installed
                         Depends: python3-markdown but it is not going to be installed
 hplip : Depends: hplip-data (= 3.21.12+dfsg0-1) but it is not going to be installed
         Depends: python3-pexpect but it is not going to be installed
         Depends: python3:any
         Depends: python3 (< 3.11) but it is not going to be installed
         Depends: python3 (>= 3.10~) but it is not going to be installed
         Recommends: printer-driver-postscript-hp but it is not going to be installed
 ibus : Depends: python3:any
        Recommends: ibus-gtk4 but it is not going to be installed
 language-selector-common : Depends: python3:any
 language-selector-gnome : Depends: python3:any
                           Recommends: yelp but it is not going to be installed
 libgirepository1.0-dev : Depends: libglib2.0-dev (>= 2.70.0) but it is not going to be installed
 lightdm-gtk-greeter-settings : Depends: python3:any
 lite-usermanager : Depends: python3-pexpect but it is not going to be installed
 lite-welcome : Depends: python3 but it is not going to be installed
                Depends: libcairo2-dev but it is not going to be installed
 menulibre : Depends: gnome-menus (>= 3.5.3) but it is not going to be installed
             Depends: python3:any
 mintstick : Depends: python3 but it is not going to be installed
 mugshot : Depends: python3-pexpect but it is not going to be installed
           Depends: python3:any
           Recommends: gir1.2-cheese-3.0 but it is not going to be installed
           Recommends: gir1.2-gtkclutter-1.0 but it is not going to be installed
           Recommends: gstreamer1.0-tools but it is not going to be installed
 netplan.io : Depends: python3 but it is not going to be installed
 networkd-dispatcher : Depends: python3:any
 onboard : Depends: python3 (< 3.11) but it is not going to be installed
           Depends: python3 (>= 3.10~) but it is not going to be installed
           Depends: python3:any
 onboard-common : Depends: python3 but it is not going to be installed
 orca : Depends: python3:any
        Depends: python3-louis (>= 1.6.2) but it is not going to be installed
        Depends: python3-speechd (>= 0.8) but it is not going to be installed
 powerline : Depends: python3:any
 python-is-python3 : Depends: python3 but it is not going to be installed
 python3-apport : Depends: python3:any (>= 3.0~)
                  Depends: python3-httplib2 but it is not going to be installed
                  Depends: python3-problem-report (>= 0.94) but it is not going to be installed
                  Depends: lsb-release but it is not going to be installed
                  Recommends: apport but it is not going to be installed
 python3-apt : Depends: python3 (< 3.11) but it is not going to be installed
               Depends: python3 (>= 3.10~) but it is not going to be installed
               Depends: python3:any
               Recommends: lsb-release but it is not going to be installed
 python3-aptdaemon : Depends: python3:any (>= 3.2~)
                     Depends: python3-defer (>= 1.0.6) but it is not going to be installed
                     Depends: python3-pkg-resources but it is not going to be installed
 python3-aptdaemon.gtk3widgets : Depends: python3:any (>= 3.2~)
 python3-bcrypt : Depends: python3 (>= 3~) but it is not going to be installed
                  Depends: python3-six (>= 1.4.1) but it is not going to be installed
                  Depends: python3:any
 python3-brlapi : Depends: python3 (< 3.11) but it is not going to be installed
                  Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-brotli : Depends: python3 (< 3.11) but it is not going to be installed
                  Depends: python3 (>= 3.10~) but it is not going to be installed
                  Depends: python3:any
 python3-cairo : Depends: python3 (< 3.11) but it is not going to be installed
                 Depends: python3 (>= 3.10~) but it is not going to be installed
                 Depends: python3:any
 python3-cap-ng : Depends: python3 (< 3.11) but it is not going to be installed
                  Depends: python3 (>= 3.10~) but it is not going to be installed
                  Depends: python3:any
 python3-cffi-backend : Depends: python3 (< 3.11) but it is not going to be installed
                        Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-commandnotfound : Depends: lsb-release but it is not going to be installed
                           Depends: python3:any
 python3-cryptography : Depends: python3 (>= 3~) but it is not going to be installed
                        Depends: python3:any
 python3-cups : Depends: python3 (< 3.11) but it is not going to be installed
                Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-cupshelpers : Depends: python3:any
 python3-dbus : Depends: python3 (< 3.11) but it is not going to be installed
                Depends: python3 (>= 3.10~) but it is not going to be installed
                Depends: python3:any
 python3-dev : Depends: python3 (= 3.10.6-1~22.04) but it is not going to be installed
               Depends: python3-distutils (>= 3.10.6-1~) but it is not going to be installed
 python3-distupgrade : Depends: python3:any
                       Depends: python3-distro-info but it is not going to be installed
                       Depends: lsb-release but it is not going to be installed
 python3-firewall : Depends: python3:any
 python3-gdbm : Depends: python3 (>= 3.10.5-0~) but it is not going to be installed
                Depends: python3 (< 3.12) but it is not going to be installed
 python3-geoip : Depends: python3 (< 3.11) but it is not going to be installed
                 Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-gi : Depends: python3 (< 3.11) but it is not going to be installed
              Depends: python3 (>= 3.10~) but it is not going to be installed
              Depends: python3:any
 python3-gi-cairo : Depends: python3 (< 3.11) but it is not going to be installed
                    Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-ibus-1.0 : Depends: python3:any
 python3-icu : Depends: python3 (< 3.11) but it is not going to be installed
               Depends: python3 (>= 3.10~) but it is not going to be installed
               Depends: python3:any
 python3-jsonschema : Depends: python3-attr but it is not going to be installed
                      Depends: python3-pkg-resources but it is not going to be installed
                      Depends: python3-setuptools but it is not going to be installed
                      Depends: python3-six (>= 1.11.0) but it is not going to be installed
                      Depends: python3-importlib-metadata but it is not going to be installed
                      Depends: python3:any
 python3-keyring : Depends: python3-importlib-metadata (>= 3.6) but it is not going to be installed
                   Depends: python3-jeepney (>= 0.4.2) but it is not going to be installed
                   Depends: python3:any
 python3-launchpadlib : Depends: python3-httplib2 but it is not going to be installed
                        Depends: python3-lazr.uri but it is not going to be installed
                        Depends: python3:any
 python3-lazr.restfulclient : Depends: python3-httplib2 (>= 0.7.7) but it is not going to be installed
                              Depends: python3-lazr.uri but it is not going to be installed
                              Depends: python3-wadllib (>= 1.1.4) but it is not going to be installed
                              Depends: python3-distro but it is not going to be installed
                              Depends: python3-pkg-resources but it is not going to be installed
                              Depends: python3-six but it is not going to be installed
                              Depends: python3:any
 python3-ldb : Depends: python3 (< 3.11) but it is not going to be installed
               Depends: python3 (>= 3.10~) but it is not going to be installed
               Depends: python3:any
 python3-libtorrent : Depends: python3 (< 3.11) but it is not going to be installed
                      Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-mako : Depends: python3:any
 python3-markupsafe : Depends: python3 (< 3.11) but it is not going to be installed
                      Depends: python3 (>= 3.10~) but it is not going to be installed
                      Depends: python3:any
 python3-nacl : Depends: python3 (>= 3~) but it is not going to be installed
                Depends: python3:any
 python3-netifaces : Depends: python3 (< 3.11) but it is not going to be installed
                     Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-nftables : Depends: python3:any
 python3-numpy : Depends: python3-pkg-resources but it is not going to be installed
                 Depends: python3 (< 3.11) but it is not going to be installed
                 Depends: python3 (>= 3.10~) but it is not going to be installed
                 Depends: python3:any
 python3-oauthlib : Depends: python3:any
                    Depends: python3-blinker but it is not going to be installed
                    Depends: python3-jwt (>= 1.0.0) but it is not going to be installed
 python3-openssl : Depends: python3-six (>= 1.5.2) but it is not going to be installed
                   Depends: python3:any
 python3-pam : Depends: python3 (< 3.11) but it is not going to be installed
               Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-parted : Depends: python3 (< 3.11) but it is not going to be installed
                  Depends: python3 (>= 3.10~) but it is not going to be installed
                  Depends: python3:any
 python3-pil : Depends: python3 (< 3.11) but it is not going to be installed
               Depends: python3 (>= 3.10~) but it is not going to be installed
               Depends: python3:any
               Recommends: python3-olefile but it is not going to be installed
 python3-powerline : Depends: python3:any
 python3-psutil : Depends: python3 (< 3.11) but it is not going to be installed
                  Depends: python3 (>= 3.10~) but it is not going to be installed
                  Depends: python3:any
 python3-pyatspi : Depends: python3:any
 python3-pycryptodome : Depends: python3 (>= 3~) but it is not going to be installed
                        Depends: python3:any
 python3-pygame : Depends: python3 (< 3.11) but it is not going to be installed
                  Depends: python3 (>= 3.10~) but it is not going to be installed
                  Depends: python3:any
 python3-pymacaroons : Depends: python3-six (>= 1.8.0) but it is not going to be installed
                       Depends: python3:any
 python3-pyrsistent : Depends: python3 (< 3.11) but it is not going to be installed
                      Depends: python3 (>= 3.10~) but it is not going to be installed
                      Depends: python3:any
 python3-pyxattr : Depends: python3 (< 3.11) but it is not going to be installed
                   Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-rencode : Depends: python3 (< 3.11) but it is not going to be installed
                   Depends: python3 (>= 3.10~) but it is not going to be installed
                   Depends: python3:any
 python3-reportlab : Depends: python3:any
                     Recommends: python3-renderpm but it is not going to be installed
 python3-reportlab-accel : Depends: python3 (< 3.11) but it is not going to be installed
                           Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-samba : Depends: python3 (< 3.11) but it is not going to be installed
                 Depends: python3 (>= 3.10~) but it is not going to be installed
                 Depends: python3:any
                 Recommends: python3-gpg but it is not going to be installed
 python3-secretstorage : Depends: python3-jeepney (>= 0.6) but it is not going to be installed
                         Depends: python3:any
 python3-service-identity : Depends: python3-attr but it is not going to be installed
                            Depends: python3-pyasn1 but it is not going to be installed
                            Depends: python3-pyasn1-modules but it is not going to be installed
                            Depends: python3:any
                            Recommends: python3-idna but it is not going to be installed
 python3-setproctitle : Depends: python3 (< 3.11) but it is not going to be installed
                        Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-simplejson : Depends: python3 (< 3.11) but it is not going to be installed
                      Depends: python3 (>= 3.10~) but it is not going to be installed
                      Depends: python3:any
 python3-software-properties : Depends: lsb-release but it is not going to be installed
                               Depends: python3 but it is not going to be installed
                               Depends: python3:any
                               Recommends: unattended-upgrades but it is not going to be installed
 python3-talloc : Depends: python3 (< 3.11) but it is not going to be installed
                  Depends: python3 (>= 3.10~) but it is not going to be installed
 python3-tdb : Depends: python3 (< 3.11) but it is not going to be installed
               Depends: python3 (>= 3.10~) but it is not going to be installed
               Depends: python3:any
 python3-twisted : Depends: python3-hamcrest but it is not going to be installed
                   Depends: python3-idna but it is not going to be installed
                   Depends: python3-attr (>= 19.2.0) but it is not going to be installed
                   Depends: python3-automat (>= 0.8.0) but it is not going to be installed
                   Depends: python3-constantly but it is not going to be installed
                   Depends: python3-hyperlink but it is not going to be installed
                   Depends: python3-incremental (>= 21.3.0) but it is not going to be installed
                   Depends: python3:any
 python3-update-manager : Depends: python3:any (>= 3.2~)
                          Depends: python3-distro-info but it is not going to be installed
                          Depends: lsb-release but it is not going to be installed
 python3-xapian : Depends: python3 (< 3.11) but it is not going to be installed
                  Depends: python3 (>= 3.10~) but it is not going to be installed
                  Depends: python3:any
 python3-yaml : Depends: python3 (< 3.11) but it is not going to be installed
                Depends: python3 (>= 3.10~) but it is not going to be installed
                Depends: python3:any
 python3-zope.interface : Depends: python3 (< 3.11) but it is not going to be installed
                          Depends: python3 (>= 3.10~) but it is not going to be installed
                          Depends: python3-pkg-resources but it is not going to be installed
                          Depends: python3:any
 redshift-gtk : Depends: python3-xdg but it is not going to be installed
                Depends: python3:any
 samba : Depends: python3 (< 3.11) but it is not going to be installed
         Depends: python3-dnspython but it is not going to be installed
         Depends: python3 (>= 3.10~) but it is not going to be installed
         Depends: python3:any
         Recommends: python3-markdown but it is not going to be installed
 samba-common-bin : Depends: python3 but it is not going to be installed
                    Depends: python3:any
 software-properties-common : Depends: python3 but it is not going to be installed
                              Depends: python3:any
 software-properties-gtk : Depends: python3 but it is not going to be installed
                           Depends: python3-dateutil but it is not going to be installed
                           Depends: python3-distro-info but it is not going to be installed
                           Depends: python3:any
 system-config-printer : Depends: python3:any
 system-config-printer-common : Depends: python3:any
                                Recommends: cups-pk-helper but it is not going to be installed
                                Recommends: gir1.2-secret-1 but it is not going to be installed
 system-config-printer-udev : Depends: python3:any (>= 3.3.2-2~)
 system-monitoring-center : Depends: python3:any
                            Depends: python3 (>= 3.6) but it is not going to be installed
 ubiquity : Depends: lsb-release but it is not going to be installed
            Depends: python3-debconf but it is not going to be installed
            Depends: python3:any (>= 3.1~)
 ubiquity-frontend-gtk : Depends: python3:any (>= 3.1~)
 ubuntu-advantage-tools : Depends: python3:any
                          Depends: python3-pkg-resources but it is not going to be installed
 ubuntu-drivers-common : Depends: python3:any (>= 3.2~)
                         Depends: python3-xkit but it is not going to be installed
                         Depends: python3-click but it is not going to be installed
 ubuntu-minimal : Depends: lsb-release but it is not going to be installed
                  Depends: python3 but it is not going to be installed
 ubuntu-release-upgrader-core : Depends: python3:any
 update-manager-core : Depends: python3:any (>= 3.2~)
                       Depends: python3-distro-info but it is not going to be installed
                       Depends: lsb-release but it is not going to be installed
 update-notifier-common : Depends: python3:any
                          Depends: python3-debian but it is not going to be installed
                          Depends: python3-debconf but it is not going to be installed or
                                   debconf (< 1.5.64~) but 1.5.79ubuntu1 is to be installed
                          Depends: python3-distro-info but it is not going to be installed
                          Depends: lsb-release but it is not going to be installed
 wolflandbuilder : Depends: python3:any (>= 3.3~)
 xapps-common : Depends: python3 but it is not going to be installed
                Depends: python3:any
 xfce4-helpers : Depends: python3 but it is not going to be installed
                 Depends: python3-urllib3 but it is not going to be installed
 yt-dlp : Depends: python3-certifi but it is not going to be installed
          Depends: python3-mutagen but it is not going to be installed
          Depends: python3-websockets but it is not going to be installed
          Depends: python3:any
          Depends: python3-pkg-resources but it is not going to be installed
 zfsutils-linux : Depends: python3 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
 kernel  ~  100  
What to try? Appreciate any assistance!
« Last Edit: February 12, 2023, 07:24:14 AM by Nicholas Markovich »
 

 

-->
X Close Ad

Linux Lite 6.6 FINAL Released - Support for 22 Languages Added - See Release Announcement Section