You are Here:
Linux Lite 5.2 RC1 is now available for download and testing



get-iplayer 2.92

Author (Read 3649 times)

0 Members and 1 Guest are viewing this topic.

get-iplayer 2.92
« on: June 02, 2015, 03:26:25 PM »
 

newtusmaximus

  • Gold Level Poster
  • *******
  • 666
    Posts
  • Country: gb
  • Reputation: 67
  • Paypal Supporter.

  • Linux Lite: 3.8 64bit

  • CPU: Intel Core duo 6300 1.86GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 82Q963/Q965

  • Kernel: 5.x
Jerry,
is there a way that we can get the updated version 2.92 via synaptic so that we get all the dependencies as well etc.?  Thanks.
2006 - HP DC7700p ultraslim Desktop Intel 6300 cpu  4GB Ram LL3.8 64bit.
2007 - Fujitsu Siemens V3405 Laptop  2 GB Ram LL3.6 32bit. Now 32bit Debian 9 + nonfree.
2006 - Fujitsu Siemens Si1520 Laptop Intel T720 cpu 3GB Ram LL4.8 64bit  LL5.0 64 Bit
2003 - RETIRED Toshiba Satellite Pro A10 1 GB RAM LL2.8 32bit
 


Re: get-iplayer 2.92
« Reply #1 on: June 02, 2015, 04:26:10 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7742
    Posts
  • Country: nz
  • Reputation: 732
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
I'm sorry, but I don't even know what 'get-iplayer' is. If it's in Synaptic, thats from the Ubuntu repos and the person that maintains that program is responsible for updating it. Perhaps try - https://github.com/get-iplayer/get_iplayer/wiki/ubuntu Cheers.
Last Edit: June 02, 2015, 04:28:37 PM by Jerry
 

Re: get-iplayer 2.92
« Reply #2 on: June 02, 2015, 09:40:53 PM »
 

N4RPS

  • Donator
  • Platinum Level Poster
  • **********
  • 1149
    Posts
  • Country: us
  • Reputation: 154
  • Knows JUST ENOUGH Linux to be DANGEROUS
    • Orphans for Christ, Self Advocates of Mecklenburg

  • Linux Lite: 2.6 64bit

  • CPU: Several Different 32-bit & 64-bit CPUs, 2-8 GB RAM

  • MEMORY: 8Gb

  • VIDEO CARD: Several Different AMD and Intel GPUs
Hello!

IIRC, iPlayer is used to access BBC and other UK-based radio/TV content. You are fortunate that a Linux version exists.

If you go to the github link posted by Jerry, it will tell you that the versions in the Ubuntu repositories are outdated or broken, and to get the latest version through the PPA. The github page gives you instructions on how to do that.

At least they have it in .deb format for you already. On SOME github pages, you have to install stuff from a tarball, or (!) compile it from source...

73 DE N4RPS
Rob


A gun in your hand is worth more than a whole police force on the phone.
 

Re: get-iplayer 2.94
« Reply #3 on: June 25, 2015, 03:05:37 PM »
 

newtusmaximus

  • Gold Level Poster
  • *******
  • 666
    Posts
  • Country: gb
  • Reputation: 67
  • Paypal Supporter.

  • Linux Lite: 3.8 64bit

  • CPU: Intel Core duo 6300 1.86GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 82Q963/Q965

  • Kernel: 5.x
get-iplayer  version 2.94 and its GUI now working fine on LL2.4 32 bit after some teething problems with earlier 2.9 versions.
2006 - HP DC7700p ultraslim Desktop Intel 6300 cpu  4GB Ram LL3.8 64bit.
2007 - Fujitsu Siemens V3405 Laptop  2 GB Ram LL3.6 32bit. Now 32bit Debian 9 + nonfree.
2006 - Fujitsu Siemens Si1520 Laptop Intel T720 cpu 3GB Ram LL4.8 64bit  LL5.0 64 Bit
2003 - RETIRED Toshiba Satellite Pro A10 1 GB RAM LL2.8 32bit
 

Re: get-iplayer 2.92
« Reply #4 on: June 25, 2015, 11:39:20 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7742
    Posts
  • Country: nz
  • Reputation: 732
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Cool, I know nothing about this program so it's difficult to support it. Does the developer offer support?
 

Re: get-iplayer 2.92
« Reply #5 on: June 26, 2015, 06:20:53 PM »
 

newtusmaximus

  • Gold Level Poster
  • *******
  • 666
    Posts
  • Country: gb
  • Reputation: 67
  • Paypal Supporter.

  • Linux Lite: 3.8 64bit

  • CPU: Intel Core duo 6300 1.86GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel 82Q963/Q965

  • Kernel: 5.x
https://launchpad.net/~jon-hedgerows/+archive/ubuntu/get-iplayer
It seems to be live - Not sure what type of support you are looking for Jerry.  However have to go via the ppa  not on the standard  sysnaptic list - as yet - Could you Jerry approach the developer and see what can be done?  I am too much of a novice to know the protocol etc.
Last Edit: June 26, 2015, 06:23:31 PM by newtusmaximus
2006 - HP DC7700p ultraslim Desktop Intel 6300 cpu  4GB Ram LL3.8 64bit.
2007 - Fujitsu Siemens V3405 Laptop  2 GB Ram LL3.6 32bit. Now 32bit Debian 9 + nonfree.
2006 - Fujitsu Siemens Si1520 Laptop Intel T720 cpu 3GB Ram LL4.8 64bit  LL5.0 64 Bit
2003 - RETIRED Toshiba Satellite Pro A10 1 GB RAM LL2.8 32bit
 

Re: get-iplayer 2.92
« Reply #6 on: June 27, 2015, 12:22:00 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7742
    Posts
  • Country: nz
  • Reputation: 732
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
To be honest newtusmaximus, I don't have enough spare time to be dealing with third party software developers. The protocol is actually for the user who is having the issue to contact the developer directly. Cheers.
 

Re: get-iplayer 2.92
« Reply #7 on: July 25, 2015, 07:15:20 AM »
 

justme2

  • PayPal Supporter
  • Forum Regular
  • *****
  • 201
    Posts
  • Country: gb
  • Reputation: 25
  • Linux Lite Member

  • Linux Lite: 3.8 64bit

  • CPU: Intel i5 vPro

  • MEMORY: 8Gb

  • VIDEO CARD: Intel
get-iplayer  version 2.94 and its GUI now working fine on LL2.4 32 bit after some teething problems with earlier 2.9 versions.

This might save someone lots of frustration!

Having just installed get-iplayer 2.94 on LL2.4, I can confirm that it does work but a quirk seems to exist, which is also apparent on the windows version too.
Sometimes using the pid to download a program fails (unable to find metadata etc) if the pid is manually typed into the terminal command. Copy/paste the pid from browser iplayer window into terminal then it works ok. I've double checked the typed pid is correct but only copy/paste works. Beats me why that is, but that is the case.  (Browser character set perhaps?)

Maybe somebody has the answer.
1) Lenovo T520 i5 LL3.8 8GB ram, fast & stable
2) Medion P4 32bit LL3.8 1GB ram, quite fast & stable
3) eeePC 901 32bit LL3.8 1GB ram, fast & stable
4) eeePC 701 32bit LL3.8 1GB ram, slower & stable but small and light enough to travel with me to New Zealand when visiting family in Blenheim.
 


Tags:
 


Linux Lite 5.2 RC1 is now available for download and testing