You are Here:
Download Linux Lite 5.2 today - See Release Announcements



LuckyBackup not working in LL50

Author (Read 1680 times)

0 Members and 1 Guest are viewing this topic.

LuckyBackup not working in LL50
« on: August 10, 2020, 02:36:41 PM »
 

arky217

  • New to Forums
  • *
  • 45
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Pentium Gold G5400

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 610

  • Kernel: 4.x
When you install LuckyBackup, it puts two options in the menu.
Normal LuckyBackup and LuckyBackup as superuser.
With LuckyBackup, the command is /usr/bin/luckybackup.
With LuckyBackup as superuser, the command is /usr/bin/luckybackup-pkexec.

I save to an external hard drive and with the regular LuckyBackup, it always failed because
of not having the correct permission, so I always used the superuser LuckyBackup.
(This was with LL48)

Well, the superuser LuckyBackup always worked just fine in LL48, but in LL50, it gives the following error
when you use the terminal to start it:

 /usr/bin/luckybackup-pkexec
qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

Aborted

Anyone know what the problem could be ?

 


Re: LuckyBackup not working in LL50
« Reply #1 on: August 10, 2020, 04:03:30 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1462
    Posts
  • Country: us
  • Reputation: 258
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x

@arky217 I would say it maybe something with LuckyBackup and Ubuntu 20.04 (LL5.0 Base)...


I did a quick google search and there does appear to be a bug - https://bugs.launchpad.net/ubuntu/+source/luckybackup/+bug/1887279


You would want to follow up with those devs...
LL 4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 

Re: LuckyBackup not working in LL50
« Reply #2 on: August 10, 2020, 04:09:48 PM »
 

Şerban S.

  • Şerban
  • PayPal Supporter
  • Forum Regular
  • *****
  • 146
    Posts
  • Country: ro
  • Reputation: 7
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: Intel® Core™ i7-4790

  • MEMORY: 16Gb

  • VIDEO CARD: Intel® HD Graphics 4600 + NVidia GK107 (GeForce GT630 OEM)

  • Kernel: 5.x
[...] Anyone know what the problem could be ?

Hello! :)

I use LuckyBackup for years!
I used it on Linux Lite 4.2, 4.4, 4.6, 4.8 and now, i use it on 5.0. Never had any trouble.
I use it as Root, only in exceptional situations.
You probably messed up with the rights.
Now, the settings are all saved in /home so reinstalling, is unlikely to solve the problem.
The only way to solve it is uninstall everything and then delete manually any remainders from /home and wherever you find any traces of LuckyBackup. You'll have to enable viewing the hiddeen files. There are many LuckyBackup profiles spread here and there.
After cleaning everything, use Synaptic Package Manager to install.
It should work.
I never had any problem, except for the first run. Take care at the paths. It supoports only one directory depth (the root directory) as target.

Good luck! :)
"It's easy to die for an idea. It's way harder TO LIVE for your idea!"
Current Machine:
 Dell Precision T1700, 16 GB RAM, 240 GB SSD.
Laptop:
 Lenovo ThinkPad T400 + SSD Kingston A 400, 480 GB.
 

Re: LuckyBackup not working in LL50
« Reply #3 on: August 10, 2020, 04:20:06 PM »
 

Moltke

  • Gold Level Poster
  • *******
  • 810
    Posts
  • Country: ve
  • Reputation: 92
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
Quote
Well, the superuser LuckyBackup always worked just fine

I'm also facing this and the only work aorund I found is run it with sudo
Code: [Select]
sudo luckybackup so as @firenice03 posted it is a bug, its not supossed to behave like that.

Quote
I use it as Root, only in exceptional situations.

Like your regular user for backing up your /home folder it woks fine but if you want to backup the whole system you need to run it as root/superuser as it's not working. It's a bug.
Without each others help there ain't no hope for us :)
 

Re: LuckyBackup not working in LL50
« Reply #4 on: August 10, 2020, 04:23:55 PM »
 

Şerban S.

  • Şerban
  • PayPal Supporter
  • Forum Regular
  • *****
  • 146
    Posts
  • Country: ro
  • Reputation: 7
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: Intel® Core™ i7-4790

  • MEMORY: 16Gb

  • VIDEO CARD: Intel® HD Graphics 4600 + NVidia GK107 (GeForce GT630 OEM)

  • Kernel: 5.x
I tested it for the sake of convenience:

Below, there is a screenshot:



https://imgur.com/a/IRGsEEB
"It's easy to die for an idea. It's way harder TO LIVE for your idea!"
Current Machine:
 Dell Precision T1700, 16 GB RAM, 240 GB SSD.
Laptop:
 Lenovo ThinkPad T400 + SSD Kingston A 400, 480 GB.
 

Re: LuckyBackup not working in LL50
« Reply #5 on: August 10, 2020, 04:34:42 PM »
 

Şerban S.

  • Şerban
  • PayPal Supporter
  • Forum Regular
  • *****
  • 146
    Posts
  • Country: ro
  • Reputation: 7
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: Intel® Core™ i7-4790

  • MEMORY: 16Gb

  • VIDEO CARD: Intel® HD Graphics 4600 + NVidia GK107 (GeForce GT630 OEM)

  • Kernel: 5.x
[...] Like your regular user for backing up your /home folder it woks fine but if you want to backup the whole system you need to run it as root/superuser as it's not working. It's a bug.

I never use it to backup /home or / (Root). It's a waste of time and space. I use CloneZilla. I only backup with LuckyBackup my personal data, nothing else.
So, I never use the "As Root" version. I only used it once, to backup Home (it's a partition) and I was sorry. It took ages (some 15 minutes or more) and sucked me 7 GB of HDD space. Bad business! :o
A common CloneZilla backup, takes below 3 GB. Some 2,5 GB / 7GB data.
LuckyBackup is very handy for 1:1 backup tasks, since you can access files directly. And is fast enough for this kind of job. :)
(Actually, the Oscar goes to rsync, but...)

PS:
A bug? What bug?

rsync works in real time so NEVER backup the whole system, since it leads to many errors, due to system locked files. I thought you knew this. That's the second reason I never tried to backup the system with LuckyBackup. Too many files are changing too fast and this prevents rsync to do its job, whatever superuser you might be.
These are basic backup rules: never backup a running OS. Do it from a bootable backup tool. If you ever used TimeShift, I bet you noticed it works after shutting down the system and re-loading from RAM. ;)
There is a difference between being a root user and trying to copy a common file and copying a system locked file. You need to issue a special command to unlock the file, which will then conflict with systemd, for one.
You may do as you please, it's your choice, but this is how it works. It has nothing to do with me, or you or anyone else. It is just the way the OS operates.

Best regards! :)
Last Edit: August 10, 2020, 04:46:47 PM by Şerban S.
"It's easy to die for an idea. It's way harder TO LIVE for your idea!"
Current Machine:
 Dell Precision T1700, 16 GB RAM, 240 GB SSD.
Laptop:
 Lenovo ThinkPad T400 + SSD Kingston A 400, 480 GB.
 

Re: LuckyBackup not working in LL50
« Reply #6 on: August 10, 2020, 04:45:30 PM »
 

Moltke

  • Gold Level Poster
  • *******
  • 810
    Posts
  • Country: ve
  • Reputation: 92
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
I tested it for the sake of convenience:

Below, there is a screenshot:



https://imgur.com/a/IRGsEEB

As your regular user it works fine, the problem it's not working as expected when superuser mode; if you click on menu and look for  luckybackup you'll find 2 versions/modes to choose from; a regular one and  the superuser one, if you choose the luckybackup (superuser) it won't launch/start, did you try that? did it work for you? It doesn't for me, OP and a bunch of other people apparently.
Without each others help there ain't no hope for us :)
 

Re: LuckyBackup not working in LL50
« Reply #7 on: August 10, 2020, 04:50:51 PM »
 

Şerban S.

  • Şerban
  • PayPal Supporter
  • Forum Regular
  • *****
  • 146
    Posts
  • Country: ro
  • Reputation: 7
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: Intel® Core™ i7-4790

  • MEMORY: 16Gb

  • VIDEO CARD: Intel® HD Graphics 4600 + NVidia GK107 (GeForce GT630 OEM)

  • Kernel: 5.x

[...] the problem it's not working as expected when superuser mode;
See all previous posts. I explained there what happens.
As a matter of fact, if you read all the docs of rsync, you'll understand.
LuckyBackup is only a GUI for rsync. ;)

Good luck! :)
"It's easy to die for an idea. It's way harder TO LIVE for your idea!"
Current Machine:
 Dell Precision T1700, 16 GB RAM, 240 GB SSD.
Laptop:
 Lenovo ThinkPad T400 + SSD Kingston A 400, 480 GB.
 

Re: LuckyBackup not working in LL50
« Reply #8 on: August 10, 2020, 05:00:05 PM »
 

arky217

  • New to Forums
  • *
  • 45
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Pentium Gold G5400

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 610

  • Kernel: 4.x

@arky217 I would say it maybe something with LuckyBackup and Ubuntu 20.04 (LL5.0 Base)...


I did a quick google search and there does appear to be a bug - https://bugs.launchpad.net/ubuntu/+source/luckybackup/+bug/1887279


You would want to follow up with those devs...

Thank you firenice03 for that link.

I edited the command in Luckybackup (superuser) and put in  sudo -H luckybackup

Then I checked the box 'Run in terminal'.

Now when I click on the Luckybackup (superuser) icon, the terminal opens,
I enter my sudo password and LuckyBackup starts.
I created a task and backed up my Documents folder to the external drive, works fine.
Of course, I have to mount the external drive first or Luckybackup won't see it.
 

Re: LuckyBackup not working in LL50
« Reply #9 on: August 10, 2020, 05:16:04 PM »
 

Moltke

  • Gold Level Poster
  • *******
  • 810
    Posts
  • Country: ve
  • Reputation: 92
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
I think I've found a solution or at least a "better" workaround; open a terminal and type
Code: [Select]
pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY luckybackup a window should pop up for you to type in your password and LBSU  should launch/start and if it does, open a terminal and type
Code: [Select]
sudo nano /usr/bin/luckybackup-pkexec comment the lines in the file, copy/paste the pkexec command above, hit Ctrl + o to save changes and then Ctrl + x to close nano.



Now, click on menu, search for luckybackup and click on LBSU, a window should pop up for you to type in your password, hit enter and LBSU should start without a problem, at least It did here. :)

Last Edit: August 10, 2020, 05:18:48 PM by Moltke
Without each others help there ain't no hope for us :)
 

Re: LuckyBackup not working in LL50
« Reply #10 on: August 10, 2020, 05:27:21 PM »
 

Moltke

  • Gold Level Poster
  • *******
  • 810
    Posts
  • Country: ve
  • Reputation: 92
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x

[...] the problem it's not working as expected when superuser mode;
See all previous posts. I explained there what happens.
As a matter of fact, if you read all the docs of rsync, you'll understand.
LuckyBackup is only a GUI for rsync. ;)

Good luck! :)

I saw your posts and they have nothing to do with the issue at hand, it's a known bug see here https://bugs.launchpad.net/ubuntu/+source/luckybackup/+bug/1887279 and here https://github.com/linuxmint/linuxmint/issues/277 
Yeah, I know what luckybackup is and also know what rsync is. You too. :) 
Without each others help there ain't no hope for us :)
 

Re: LuckyBackup not working in LL50
« Reply #11 on: August 10, 2020, 05:34:59 PM »
 

Moltke

  • Gold Level Poster
  • *******
  • 810
    Posts
  • Country: ve
  • Reputation: 92
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
Quote
There is a difference between being a root user and trying to copy a common file and copying a system locked file. You need to issue a special command to unlock the file, which will then conflict with systemd, for one.

That's not what we're talking about here, that could be another topic for a different thread. Thing is, Luckybackup(supersuser) should lauch/start whenever you click on it on the menu but it doesn't, regardless of whether or not it is a good idea to backup the entire system while it's running, which it does just fine by the way, it's been designed with that purpose in mind.
Without each others help there ain't no hope for us :)
 

Re: LuckyBackup not working in LL50
« Reply #12 on: August 10, 2020, 05:38:22 PM »
 

Moltke

  • Gold Level Poster
  • *******
  • 810
    Posts
  • Country: ve
  • Reputation: 92
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
@arky217 have you seen this? https://sourceforge.net/p/luckybackup/discussion/873563/thread/8463b76b07/?limit=25#6c31 Haven't tried it yet but LB developer OKes it.
Without each others help there ain't no hope for us :)
 

Re: LuckyBackup not working in LL50
« Reply #13 on: August 10, 2020, 05:47:55 PM »
 

arky217

  • New to Forums
  • *
  • 45
    Posts
  • Country: us
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 4.6 64bit

  • CPU: Pentium Gold G5400

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 610

  • Kernel: 4.x
I think I've found a solution or at least a "better" workaround; open a terminal and type
Code: [Select]
pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY luckybackup a window should pop up for you to type in your password and LBSU  should launch/start and if it does, open a terminal and type
Code: [Select]
sudo nano /usr/bin/luckybackup-pkexec comment the lines in the file, copy/paste the pkexec command above, hit Ctrl + o to save changes and then Ctrl + x to close nano.



Now, click on menu, search for luckybackup and click on LBSU, a window should pop up for you to type in your password, hit enter and LBSU should start without a problem, at least It did here. :)



Moltke, the procedure I did in post #8 works fine for me, but I did start to do what you mentioned above.

But when I copied  pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY luckybackup
and pasted it in the terminal, I got a Warning- Unsafe Paste with the options to quit or paste.
Wasn't sure if I was about to mess something up, so I chose quit.

Did you get any warning when you entered that in the terminal ?
 

Re: LuckyBackup not working in LL50
« Reply #14 on: August 10, 2020, 05:53:29 PM »
 

Moltke

  • Gold Level Poster
  • *******
  • 810
    Posts
  • Country: ve
  • Reputation: 92
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: amd athlon 64 x2

  • MEMORY: 4Gb

  • VIDEO CARD: amd radeon hd 6750

  • Kernel: 5.x
I think I've found a solution or at least a "better" workaround; open a terminal and type
Code: [Select]
pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY luckybackup a window should pop up for you to type in your password and LBSU  should launch/start and if it does, open a terminal and type
Code: [Select]
sudo nano /usr/bin/luckybackup-pkexec comment the lines in the file, copy/paste the pkexec command above, hit Ctrl + o to save changes and then Ctrl + x to close nano.



Now, click on menu, search for luckybackup and click on LBSU, a window should pop up for you to type in your password, hit enter and LBSU should start without a problem, at least It did here. :)



Moltke, the procedure I did in post #8 works fine for me, but I did start to do what you mentioned above.

But when I copied  pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY luckybackup
and pasted it in the terminal, I got a Warning- Unsafe Paste with the options to quit or paste.
Wasn't sure if I was about to mess something up, so I chose quit.

Did you get any warning when you entered that in the terminal ?

No, I didn't get any but I didn't use xfce4-terminal but konsole and I do know xfce4-terminal does that, so it's safe to paste the command, however, if it makes you feel a bit safer, copy/paste to a text editor first then copy from that one and paste it to the terminal, it  shouldn't trigger any warnings now. It does that cause you're copying/pasting something from a web page. 
Without each others help there ain't no hope for us :)
 


Tags:
 


Download Linux Lite 5.2 today - See Release Announcements