You are Here:
Linux Lite 5.0 Final is now available for download and installation



[ SOLVED ] Lite Control Center - wrong date for software updates

Author (Read 3489 times)

0 Members and 1 Guest are viewing this topic.

Lite Control Center - wrong date for software updates
« on: February 15, 2016, 06:30:20 AM »
 

LL-user

  • I come here a lot
  • *****
  • 448
    Posts
  • Country: 00
  • Reputation: 214
  • Linux Lite Member

  • Linux Lite: 2.8 64bit
Hi,

Just successfully upgraded one of my computers to LL2.8 :)
I usually don't use neither the Lite Control Center, nor the Install pdates GUI.

When starting the Lite Control Center to check the version, I realized that a date from last year was shown when the computer has been updated last. I only run an update minutes before that via CLI. Assuming it might be linked to the fact that I'm not using the GUI I followed the link of the date "Install Updates".
Still it shows the date from last year.
Last Edit: February 15, 2016, 11:25:34 PM by LL-user
 


Re: Lite Control Center - wrong date for software updates
« Reply #1 on: February 15, 2016, 07:08:10 AM »
 

Wirezfree

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1484
    Posts
  • Country: gb
  • Reputation: 404
  • Linux Lite "Advocate"

  • Linux Lite: 2.8 64bit

  • CPU: i7-4790S

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD4600 (Integrated)
Recently done 3 upgrades to 2.8
Just re-checked, and updated all 3, about 10 items to update
Checked the LLC date, looks fine, Date: 2015-02-15
((Not UK Format, dd/mm/yyyy but that's not an issue))
Upgrades WIP 2.6 to 2.8 - (6 X 2.6 to 2.8 completed on: 20/02/16 All O.K )
Linux Lite 3.0 Humming on a ASRock N3070 Mobo ~ btrfs RAID 10 Install on 4 Disks :)

Computers Early days:
ZX Spectrum(1982) , HP-150 MS-DOS(1983) , Amstrad CPC464(1984) ,  BBC Micro B+64(1985) , My First PC HP-Vectra(1987)
 

Re: Lite Control Center - wrong date for software updates
« Reply #2 on: February 15, 2016, 03:59:34 PM »
 

LL-user

  • I come here a lot
  • *****
  • 448
    Posts
  • Country: 00
  • Reputation: 214
  • Linux Lite Member

  • Linux Lite: 2.8 64bit
Hi Dave,

Thanks for checking.

Did there just creep in a typo (2015 instead of 2016) or am I missing something here?
Mine shows 2015-11-01 and tells me it's time to update. Although I run an update almost every day.


 

Re: Lite Control Center - wrong date for software updates
« Reply #3 on: February 15, 2016, 04:30:02 PM »
 

Wirezfree

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1484
    Posts
  • Country: gb
  • Reputation: 404
  • Linux Lite "Advocate"

  • Linux Lite: 2.8 64bit

  • CPU: i7-4790S

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD4600 (Integrated)
Oooops  :-[  a Typo:

Upgrades WIP 2.6 to 2.8 - (6 X 2.6 to 2.8 completed on: 20/02/16 All O.K )
Linux Lite 3.0 Humming on a ASRock N3070 Mobo ~ btrfs RAID 10 Install on 4 Disks :)

Computers Early days:
ZX Spectrum(1982) , HP-150 MS-DOS(1983) , Amstrad CPC464(1984) ,  BBC Micro B+64(1985) , My First PC HP-Vectra(1987)
 

Re: Lite Control Center - wrong date for software updates
« Reply #4 on: February 15, 2016, 05:24:53 PM »
 

shaggytwodope

  • Forum Regular
  • ***
  • 222
    Posts
  • Reputation: 44
  • Linux Lite Member
    • Shaggy's Blog

  • CPU: Intel i5 4440

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 4600
Hi,

Just successfully upgraded one of my computers to LL2.8 :)
I usually don't use neither the Lite Control Center, nor the Install pdates GUI.

When starting the Lite Control Center to check the version, I realized that a date from last year was shown when the computer has been updated last. I only run an update minutes before that via CLI. Assuming it might be linked to the fact that I'm not using the GUI I followed the link of the date "Install Updates".
Still it shows the date from last year.

Not enough info at all, updating via cli can mean any number of front ends to apt.

How are you updating? Using what tool by name exactly, if possible share full commands used.

Have you ran updates by clicking on the text in control center?

Can you run the command
Code: [Select]
apt-config dump > apt-get_config.txtAnd post the output.
The Truth is out there.
Be sure to check the Manual out and always report Bugs or feature requests.
 

Re: Lite Control Center - wrong date for software updates
« Reply #5 on: February 15, 2016, 06:00:02 PM »
 

shaggytwodope

  • Forum Regular
  • ***
  • 222
    Posts
  • Reputation: 44
  • Linux Lite Member
    • Shaggy's Blog

  • CPU: Intel i5 4440

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 4600
PR been sent to control center repo. This issue should be solved from now on. Post triggers in apt are not updating the file as it should for alot of people.

https://github.com/linuxlite/litecontrolcenter/pull/32
The Truth is out there.
Be sure to check the Manual out and always report Bugs or feature requests.
 

Re: Lite Control Center - wrong date for software updates
« Reply #6 on: February 15, 2016, 06:31:13 PM »
 

LL-user

  • I come here a lot
  • *****
  • 448
    Posts
  • Country: 00
  • Reputation: 214
  • Linux Lite Member

  • Linux Lite: 2.8 64bit
Thanks, shaggytwodope, for chirping in.

I was just writing my response to your first message when I saw your last one.
Do you still need/want the output of apt-config dump?

Usually I update via
Code: [Select]
apt-get update && apt-get upgradein a root shell.

Beside that I work with aptitude and recently apt.
Only in rare occasions/ just for testing I ever use a GUI for package management.
 

Re: Lite Control Center - wrong date for software updates
« Reply #7 on: February 15, 2016, 10:46:58 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7695
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
PR been sent to control center repo. This issue should be solved from now on. Post triggers in apt are not updating the file as it should for alot of people.

https://github.com/linuxlite/litecontrolcenter/pull/32

Thanks shaggy, updated code merged.
 

Re: Lite Control Center - wrong date for software updates
« Reply #8 on: February 15, 2016, 11:08:27 PM »
 

LL-user

  • I come here a lot
  • *****
  • 448
    Posts
  • Country: 00
  • Reputation: 214
  • Linux Lite Member

  • Linux Lite: 2.8 64bit
Just installed the update and can confirm to get shown the correct date now.

Thanks! :)
 

Re: Lite Control Center - wrong date for software updates
« Reply #9 on: February 15, 2016, 11:13:27 PM »
 

shaggytwodope

  • Forum Regular
  • ***
  • 222
    Posts
  • Reputation: 44
  • Linux Lite Member
    • Shaggy's Blog

  • CPU: Intel i5 4440

  • MEMORY: 8Gb

  • VIDEO CARD: Intel HD Graphics 4600
Thanks, shaggytwodope, for chirping in.

I was just writing my response to your first message when I saw your last one.
Do you still need/want the output of apt-config dump?

Usually I update via
Code: [Select]
apt-get update && apt-get upgradein a root shell.

Beside that I work with aptitude and recently apt.
Only in rare occasions/ just for testing I ever use a GUI for package management.


I'd very much like the output of that command, for future reference.
The Truth is out there.
Be sure to check the Manual out and always report Bugs or feature requests.
 

Re: Lite Control Center - wrong date for software updates
« Reply #10 on: February 15, 2016, 11:18:15 PM »
 

LL-user

  • I come here a lot
  • *****
  • 448
    Posts
  • Country: 00
  • Reputation: 214
  • Linux Lite Member

  • Linux Lite: 2.8 64bit
Here you go:
Code: [Select]
APT "";
APT::Architecture "amd64";
APT::Build-Essential "";
APT::Build-Essential:: "build-essential";
APT::Install-Recommends "true";
APT::Install-Suggests "0";
APT::Authentication "";
APT::Authentication::TrustCDROM "true";
APT::NeverAutoRemove "";
APT::NeverAutoRemove:: "^firmware-linux.*";
APT::NeverAutoRemove:: "^linux-firmware$";
APT::NeverAutoRemove:: "^linux-image-3\.13\.0-76-generic$";
APT::NeverAutoRemove:: "^linux-image-3\.13\.0-77-generic$";
APT::NeverAutoRemove:: "^linux-headers-3\.13\.0-76-generic$";
APT::NeverAutoRemove:: "^linux-headers-3\.13\.0-77-generic$";
APT::NeverAutoRemove:: "^linux-image-extra-3\.13\.0-76-generic$";
APT::NeverAutoRemove:: "^linux-image-extra-3\.13\.0-77-generic$";
APT::NeverAutoRemove:: "^linux-signed-image-3\.13\.0-76-generic$";
APT::NeverAutoRemove:: "^linux-signed-image-3\.13\.0-77-generic$";
APT::NeverAutoRemove:: "^kfreebsd-image-3\.13\.0-76-generic$";
APT::NeverAutoRemove:: "^kfreebsd-image-3\.13\.0-77-generic$";
APT::NeverAutoRemove:: "^kfreebsd-headers-3\.13\.0-76-generic$";
APT::NeverAutoRemove:: "^kfreebsd-headers-3\.13\.0-77-generic$";
APT::NeverAutoRemove:: "^gnumach-image-3\.13\.0-76-generic$";
APT::NeverAutoRemove:: "^gnumach-image-3\.13\.0-77-generic$";
APT::NeverAutoRemove:: "^.*-modules-3\.13\.0-76-generic$";
APT::NeverAutoRemove:: "^.*-modules-3\.13\.0-77-generic$";
APT::NeverAutoRemove:: "^.*-kernel-3\.13\.0-76-generic$";
APT::NeverAutoRemove:: "^.*-kernel-3\.13\.0-77-generic$";
APT::NeverAutoRemove:: "^linux-backports-modules-.*-3\.13\.0-76-generic$";
APT::NeverAutoRemove:: "^linux-backports-modules-.*-3\.13\.0-77-generic$";
APT::NeverAutoRemove:: "^linux-tools-3\.13\.0-76-generic$";
APT::NeverAutoRemove:: "^linux-tools-3\.13\.0-77-generic$";
APT::VersionedKernelPackages "";
APT::VersionedKernelPackages:: "linux-image";
APT::VersionedKernelPackages:: "linux-headers";
APT::VersionedKernelPackages:: "linux-image-extra";
APT::VersionedKernelPackages:: "linux-signed-image";
APT::VersionedKernelPackages:: "kfreebsd-image";
APT::VersionedKernelPackages:: "kfreebsd-headers";
APT::VersionedKernelPackages:: "gnumach-image";
APT::VersionedKernelPackages:: ".*-modules";
APT::VersionedKernelPackages:: ".*-kernel";
APT::VersionedKernelPackages:: "linux-backports-modules-.*";
APT::VersionedKernelPackages:: "linux-tools";
APT::Never-MarkAuto-Sections "";
APT::Never-MarkAuto-Sections:: "metapackages";
APT::Never-MarkAuto-Sections:: "restricted/metapackages";
APT::Never-MarkAuto-Sections:: "universe/metapackages";
APT::Never-MarkAuto-Sections:: "multiverse/metapackages";
APT::Never-MarkAuto-Sections:: "oldlibs";
APT::Never-MarkAuto-Sections:: "restricted/oldlibs";
APT::Never-MarkAuto-Sections:: "universe/oldlibs";
APT::Never-MarkAuto-Sections:: "multiverse/oldlibs";
APT::Periodic "";
APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";
APT::Update "";
APT::Update::Post-Invoke-Success "";
APT::Update::Post-Invoke-Success:: "touch /var/lib/apt/periodic/update-success-stamp 2>/dev/null || true";
APT::Update::Post-Invoke-Success:: "[ ! -f /var/run/dbus/system_bus_socket ] || /usr/bin/dbus-send --system --dest=org.debian.apt --type=signal /org/debian/apt org.debian.apt.CacheChanged || true";
APT::Archives "";
APT::Archives::MaxAge "30";
APT::Archives::MinAge "2";
APT::Archives::MaxSize "500";
APT::Changelogs "";
APT::Changelogs::Server "http://changelogs.ubuntu.com/changelogs";
APT::Architectures "";
APT::Architectures:: "amd64";
APT::Architectures:: "i386";
APT::Compressor "";
APT::Compressor::. "";
APT::Compressor::.::Name ".";
APT::Compressor::.::Extension "";
APT::Compressor::.::Binary "";
APT::Compressor::.::Cost "1";
APT::Compressor::gzip "";
APT::Compressor::gzip::Name "gzip";
APT::Compressor::gzip::Extension ".gz";
APT::Compressor::gzip::Binary "gzip";
APT::Compressor::gzip::Cost "2";
APT::Compressor::gzip::CompressArg "";
APT::Compressor::gzip::CompressArg:: "-9n";
APT::Compressor::gzip::UncompressArg "";
APT::Compressor::gzip::UncompressArg:: "-d";
APT::Compressor::bzip2 "";
APT::Compressor::bzip2::Name "bzip2";
APT::Compressor::bzip2::Extension ".bz2";
APT::Compressor::bzip2::Binary "bzip2";
APT::Compressor::bzip2::Cost "3";
APT::Compressor::bzip2::CompressArg "";
APT::Compressor::bzip2::CompressArg:: "-9";
APT::Compressor::bzip2::UncompressArg "";
APT::Compressor::bzip2::UncompressArg:: "-d";
APT::Compressor::xz "";
APT::Compressor::xz::Name "xz";
APT::Compressor::xz::Extension ".xz";
APT::Compressor::xz::Binary "xz";
APT::Compressor::xz::Cost "4";
APT::Compressor::xz::CompressArg "";
APT::Compressor::xz::CompressArg:: "-6";
APT::Compressor::xz::UncompressArg "";
APT::Compressor::xz::UncompressArg:: "-d";
APT::Compressor::lzma "";
APT::Compressor::lzma::Name "lzma";
APT::Compressor::lzma::Extension ".lzma";
APT::Compressor::lzma::Binary "xz";
APT::Compressor::lzma::Cost "5";
APT::Compressor::lzma::CompressArg "";
APT::Compressor::lzma::CompressArg:: "--format=lzma";
APT::Compressor::lzma::CompressArg:: "-9";
APT::Compressor::lzma::UncompressArg "";
APT::Compressor::lzma::UncompressArg:: "--format=lzma";
APT::Compressor::lzma::UncompressArg:: "-d";
APT::Compressor::::Name "";
APT::Compressor::::Extension ".";
APT::Compressor::::Binary "";
APT::Compressor::::Cost "100";
APT::Compressor::::CompressArg "";
APT::Compressor::::CompressArg:: "-9";
APT::Compressor::::UncompressArg "";
APT::Compressor::::UncompressArg:: "-d";
Dir "/";
Dir::State "var/lib/apt/";
Dir::State::lists "lists/";
Dir::State::cdroms "cdroms.list";
Dir::State::mirrors "mirrors/";
Dir::State::extended_states "extended_states";
Dir::State::status "/var/lib/dpkg/status";
Dir::Cache "var/cache/apt/";
Dir::Cache::archives "archives/";
Dir::Cache::srcpkgcache "srcpkgcache.bin";
Dir::Cache::pkgcache "pkgcache.bin";
Dir::Etc "etc/apt/";
Dir::Etc::sourcelist "sources.list";
Dir::Etc::sourceparts "sources.list.d";
Dir::Etc::vendorlist "vendors.list";
Dir::Etc::vendorparts "vendors.list.d";
Dir::Etc::main "apt.conf";
Dir::Etc::netrc "auth.conf";
Dir::Etc::parts "apt.conf.d";
Dir::Etc::preferences "preferences";
Dir::Etc::preferencesparts "preferences.d";
Dir::Etc::trusted "trusted.gpg";
Dir::Etc::trustedparts "trusted.gpg.d";
Dir::Bin "";
Dir::Bin::methods "/usr/lib/apt/methods";
Dir::Bin::solvers "";
Dir::Bin::solvers:: "/usr/lib/apt/solvers";
Dir::Bin::dpkg "/usr/bin/dpkg";
Dir::Bin::bzip2 "/bin/bzip2";
Dir::Bin::xz "/usr/bin/xz";
Dir::Bin::lzma "/usr/bin/xz";
Dir::Media "";
Dir::Media::MountPath "/media/apt";
Dir::Log "var/log/apt";
Dir::Log::Terminal "term.log";
Dir::Log::History "history.log";
Dir::Ignore-Files-Silently "";
Dir::Ignore-Files-Silently:: "~$";
Dir::Ignore-Files-Silently:: "\.disabled$";
Dir::Ignore-Files-Silently:: "\.bak$";
Dir::Ignore-Files-Silently:: "\.dpkg-[a-z]+$";
Dir::Ignore-Files-Silently:: "\.save$";
Dir::Ignore-Files-Silently:: "\.orig$";
Dir::Ignore-Files-Silently:: "\.distUpgrade$";
Acquire "";
Acquire::cdrom "";
Acquire::cdrom::mount "/media/cdrom/";
Acquire::Languages "";
Acquire::Languages:: "en_US";
Acquire::Languages:: "en";
Acquire::Languages:: "none";
Aptitude "";
Aptitude::Get-Root-Command "sudo:/usr/bin/sudo";
Unattended-Upgrade "";
Unattended-Upgrade::Allowed-Origins "";
Unattended-Upgrade::Allowed-Origins:: "${distro_id}:${distro_codename}-security";
DPkg "";
DPkg::Pre-Install-Pkgs "";
DPkg::Pre-Install-Pkgs:: "/usr/sbin/dpkg-preconfigure --apt || true";
DPkg::Post-Invoke "";
DPkg::Post-Invoke:: "if [ -d /var/lib/update-notifier ]; then touch /var/lib/update-notifier/dpkg-run-stamp; fi; if [ -e /var/lib/update-notifier/updates-available ]; then echo > /var/lib/update-notifier/updates-available; fi ";
DPkg::Options "";
DPkg::Options:: "--force-confdef";
DPkg::Options:: "--force-confold";
CommandLine "";
CommandLine::AsString "apt-config dump";

PS: trying to mark that post as solved but it's not offered under PREFIX... will post in the appropriate thread
 

Re: Lite Control Center - wrong date for software updates
« Reply #11 on: February 15, 2016, 11:21:12 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7695
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
You can't mark this as Solved because you've posted in the Suggestions and Feedback section. Moved to Software section.
 

Re: Lite Control Center - wrong date for software updates
« Reply #12 on: February 15, 2016, 11:25:08 PM »
 

LL-user

  • I come here a lot
  • *****
  • 448
    Posts
  • Country: 00
  • Reputation: 214
  • Linux Lite Member

  • Linux Lite: 2.8 64bit
Thanks, Jerry!
Looks like we're all writing posts at the same time...
 

Re: Lite Control Center - wrong date for software updates
« Reply #13 on: February 15, 2016, 11:28:02 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7695
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
No problem, FYI, you can only mark threads as Solved that are in the Support sections :)
 


Tags:
 


Linux Lite 5.0 Final is now available for download and installation