You are Here:
Install Updates Gimp Error - see Security & Bug Fixes Section Sticky



Lite 4.0 and Python

Author (Read 604 times)

0 Members and 1 Guest are viewing this topic.

Lite 4.0 and Python
« on: October 16, 2018, 03:50:58 AM »
 

barnaby

  • New to Forums
  • *
  • 19
    Posts
  • Country: gb
  • Reputation: 2
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel

  • MEMORY: 16Gb

  • VIDEO CARD: Intel
I have a desk top and a laptop. I keep them in sync using pCloud. A few days ago I decided to install LL 4.0 on to the laptop. No problem. I do a lot of work with Python, so I expected to see that I now had v 3.6.6, and yes, that was all fine. I use a program called mu-editor to work with it. This needs v 3.6.6 so it worked fine.

Since I was pleased with LL 4.0 I decided to install it on my desk top computer. I used the same memory stick for this. Once it was done I checked for the Python version. It was 3.5.2 which was a surprise. I also tried the mu-editor which brought up an error. After a lot of searching around I have finally managed to install Python 3.6.6 on the desk top, so I now have three versions, 2.7, 3.5.2, 3.6.6. I made 3.6.6. the default version, then tried mu-editor. Error message, it will not run. I have also found that the Python module gi will import happily on the laptop, but is "not found" on the desk top.

So, now I will have to use the laptop whenever I want to work with Python, but go back to the desk top for everything else. What puzzles me is that I used the same memory stick for both installations, so expected them to be the same. Weird.
 


Tags:
 


Install Updates Gimp Error - see Security & Bug Fixes Section Sticky