You are Here:
Linux Lite 5.2 RC1 is now available for download and testing



[ SOLVED ] dependency not satisfiable libssl

Author (Read 1132 times)

0 Members and 4 Guests are viewing this topic.

dependency not satisfiable libssl
« on: June 22, 2020, 09:57:27 AM »
 

nashtrik

  • New to Forums
  • *
  • 3
    Posts
  • Reputation: 0
While installing a .deb package with Gdebi, i get the following message..[dependency is not satisfiable libssl1.0.0(>=1.0.0)]. How can this be resolved?I am running latest 5.0 version and libssl version is 1.1.1.Kindly consider the fact  that I am a non-techie and not so command line savvy...though I am not entirely new to linux. I am running this from a 64GB USB 2 Flash drive..full installation. Thanks
Last Edit: June 27, 2020, 07:47:23 AM by nashtrik
 


Re: dependency not satisfiable libssl
« Reply #1 on: June 26, 2020, 05:01:15 AM »
 

Şerban S.

  • Şerban
  • PayPal Supporter
  • Forum Regular
  • *****
  • 138
    Posts
  • Country: ro
  • Reputation: 7
  • Linux Lite Member

  • Linux Lite: 5.0 64bit

  • CPU: Intel® Core™ i7-4790

  • MEMORY: 16Gb

  • VIDEO CARD: Intel® HD Graphics 4600 + NVidia GK107 (GeForce GT630 OEM)

  • Kernel: 5.x
While installing a .deb package with Gdebi, i get the following message..[dependency is not satisfiable libssl1.0.0(>=1.0.0)]. How can this be resolved?I am running latest 5.0 version and libssl version is 1.1.1.Kindly consider the fact  that I am a non-techie and not so command line savvy...though I am not entirely new to linux. I am running this from a 64GB USB 2 Flash drive..full installation. Thanks
As far as I know, this kind of message is generated by GDebi if you want to install an old App that lacks the proper version of a library, due to deprecation.
In your case, the App requires an older library and GDebi never overwrites older libs over the new ones and that is why you got this message.
Ask Jerry for help on installing two different versions of the same lib(s): Is it possible without breaking the system?, or try to find a replacement for the App, that has an Ubuntu 20.04 version on the download page.
Another approach is to use an AppImage version, if available. This might work.
"It's easy to die for an idea. It's way harder TO LIVE for your idea!"
Current Machine:
 Dell Precision T1700, 16 GB RAM, 240 GB SSD.
Laptop:
 Lenovo ThinkPad T400 + SSD Kingston A 400, 480 GB.
 

Re: dependency not satisfiable libssl
« Reply #2 on: June 27, 2020, 07:42:41 AM »
 

nashtrik

  • New to Forums
  • *
  • 3
    Posts
  • Reputation: 0
Thanks for the reply. I found a new version of the software which required libssl 1.0.2. I googled it out,found it in packages.debian.org..downloaded and installed from the ftp: site with same Gdebi. running smoothly.
Last Edit: June 27, 2020, 07:47:06 AM by nashtrik
 


Tags:
 


Linux Lite 5.2 RC1 is now available for download and testing