Linux Lite Forums

Software - Support => Installing Software => Topic started by: markmayhew on June 21, 2014, 05:12:42 PM

Title: Linux Lite won't let me install *any* software
Post by: markmayhew on June 21, 2014, 05:12:42 PM
Am I the only person who can't download any software to my installation of Linux lite? I just want to install Google Chrome but it won't let me, nor can I install any other programs.
Title: Re: Linux Lite won't let me install *any* software
Post by: gold_finger on June 21, 2014, 06:51:53 PM
Menu -> System -> Install Additional Software, then choose it (#2) from the list shown and it will be installed for you.

The Install Additional Software section contains some commonly desired programs for easy installation.  It is NOT a list of all software available, which numbers in the thousands of programs.

The system has a program called Synaptic Package Manager on it that will allow you to install any of the thousands of programs available in the repositories (Menu -> System -> Install/Remove Software.  However, it is most useful only when you already know the names of what you need ahead of time.  For people new to Linux, using a 'Software Center' application is much easier because it displays software with descriptions and screenshots under various common categories.  That is not included in the default LL installation.  You need to install that first before you can use it.

To install a software manager, open Synaptic Package Manager and search for both of these:
 


Click each of those (exact names above, not listings with other things added to the names) to read a description of the programs.  Both are very similar and either will be fine.  (Correction:  software-center will cause problems, lubuntu-software-center might be okay.)Pick one by clicking the box next to it and select "Mark for Installation".  Then hit the apply button and let it install any other dependent packages if it lists them too.

When complete, you can find it listed under Menu -> System.


P.s.
I would suggest you take a little time to read through the Help Manual (Menu -> Favorites -> Help Manual) to get an idea of how some things work in Linux.  Also see some of the links on this post for additional information:  https://www.linuxliteos.com/forums/index.php?topic=273.0 (https://www.linuxliteos.com/forums/index.php?topic=273.0).[/list]
Title: Re: Linux Lite won't let me install *any* software
Post by: N4RPS on June 22, 2014, 03:07:58 AM
Hello!

Regardless of one's skill level, Lubuntu Software Center or Ubuntu Software Center make adding software much easier for folks than Add/Remove Software, a.k.a. Synaptic Package Manager. In both LSC and USC, software is broken down into categories, more detailed explanations are given, and reviews on them can be read and/or submitted.

DANGER!       DANGER!       DANGER!       DANGER!       DANGER!       DANGER!       DANGER!       DANGER!       DANGER!


However, these two programs make changes that can prevent certain kernel updates that LL 'holds back' (for a reason) from being 'held back'. As a result, these programs can 'break' LL to where only reinstalling the OS can fix it...

73 DE N4RPS
Rob
Title: Re: Linux Lite won't let me install *any* software
Post by: ka22bo on June 27, 2014, 05:02:24 AM
I'm having the same problem. I tried to install [3] Chromium and [23] Wine but after typing my password I was just prompted with "Chromium Web Browser(Wine) could not be installed." with a single button [ ok ] - No description of what went wrong what so ever. I try to install a software manager as I am familiar with it in Xubuntu and LinuxMint, in my terminal this is what I get:

user@LT-MX3215-LL2:~$ sudo apt-get install software-center
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package software-center is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'software-center' has no installation candidate
user@LT-MX3215-LL2:~$

Title: Re: Linux Lite won't let me install *any* software
Post by: Jerry on June 27, 2014, 05:38:57 AM
Have you run Install Updates after installing Linux Lite?
Title: Re: Linux Lite won't let me install *any* software
Post by: ka22bo on June 27, 2014, 05:46:03 AM
Yes I did, even for the other user.
Title: Re: Linux Lite won't let me install *any* software
Post by: Jerry on June 27, 2014, 05:54:27 AM
Read this thread here, Linux Lite is not designed to work with software center - https://www.linuxliteos.com/forums/index.php?topic=508 and we recommend against it's installation. Much easier to use Menu, System, Install/Remove Software. Also make sure the user who is installing software is the one you set up when you first installed Linux Lite. If you added any additional users after an install, they will need sudo privileges to install and remove software. More info here - https://www.linuxliteos.com/manual/install.html#adduser
Title: Re: Linux Lite won't let me install *any* software
Post by: ka22bo on June 27, 2014, 07:30:13 AM
I was able to find software center will not work with LL2 for my self - due to dependency version conflict, and yes its the update thing that prevented me from installing programs. I have used the Menu>System>Install Additional Software>[25] Install Updates twice but only after using Menu>Favorites>Install Updates I have finally installed Chromium and Wine. I believe its the same thing, so I must have missed some feedbacks with my earlier updates.

Again, In my case I can say its the install update that causes my problem, I don't know with the OP.

Thanks Valtam for you time.
Title: Re: Linux Lite won't let me install *any* software
Post by: Jerry on June 27, 2014, 01:53:49 PM
With every release we always ask people to do Menu, Install Updates after a fresh install. This will set you up right for everything else :)
Title: Re: Linux Lite won't let me install *any* software
Post by: kansasdougll on March 16, 2016, 05:10:18 PM

For Google Chrome, simply go to Menu -> System -> Install Additional Software, then choose it (#2) from the list shown and it will be installed for you.


  I'm here because I'm having the same problem. I have no solution, just posting to inform the problem the other individual is/was having, isn't unique to them.  I performed performed, the
Menu -> System -> Install Additional Software, then choose it (#2) from the list shown, steps.   That worked as it should on my netbook. Not so well on the desktop I'm trying to get back into use. After entering my password I get the installing Chrome box that shows the progress bar of the installation; then I get an error box that contains the message Chrome could not be installed. This after updating LL and a cold reboot. However Chromium installed when I got similar error message An entry for it appeared in the internet menu. Go figure [sigh]
Title: Re: Linux Lite won't let me install *any* software
Post by: firenice03 on March 16, 2016, 05:16:31 PM

For Google Chrome, simply go to Menu -> System -> Install Additional Software, then choose it (#2) from the list shown and it will be installed for you.


  I'm here because I'm having the same problem. I have no solution, just posting to inform the problem the other individual is/was having, isn't unique to them.  I performed performed, the
Menu -> System -> Install Additional Software, then choose it (#2) from the list shown, steps.   That worked as it should on my netbook. Not so well on the desktop I'm trying to get back into use. After entering my password I get the installing Chrome box that shows the progress bar of the installation; then I get an error box that contains the message Chrome could not be installed. This after updating LL and a cold reboot. However Chromium installed when I got similar error message An entry for it appeared in the internet menu. Go figure [sigh]

Chrome for 32-bit Linux is no longer supported as of March 1st 2016... Is your desktop the 64-bit version of LL?
If it 32-bit, after the OS was updated the Chrome link should be removed from Lite Software..
If chrome is erroring on 64-bit try updating LL, if not use the following commands:

Open a terminal and do each of these commands one at a time:

Code: [Select]
sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list"
sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/opt/google/chrome/cron/google-chrome"
Title: Re: Linux Lite won't let me install *any* software
Post by: kansasdougll on March 16, 2016, 06:09:43 PM
 Because others may continue to run into this, and a web search is going to lead here, Im including what I discovered by chance. I apologize in advance if it was already included in this thread and I over looked it.  Seems that Google ended updates for 32 bit Chrome, and the LL team may have removed availability to it, if they did I don't know why the didn't from the listing of additional software. Chromium is list, and Google still supports it with updates, I take it. Please take a look at the following http://www.webupd8.org/2016/03/fix-failed-to-fetch-google-chrome_3.html (ftp://www.webupd8.org/2016/03/fix-failed-to-fetch-google-chrome_3.html)
Title: Re: Linux Lite won't let me install *any* software
Post by: kansasdougll on March 17, 2016, 12:00:39 AM


Chrome for 32-bit Linux is no longer supported as of March 1st 2016... Is your desktop the 64-bit version of LL?
If it 32-bit, after the OS was updated the Chrome link should be removed from Lite Software..
If chrome is erroring on 64-bit try updating LL, if not use the following commands:

Open a terminal and do each of these commands one at a time:


suggested code was trimmed out of quoted text

Yes the desktop is a 32 bit machine.  After I made that post by chance I discovered that Google no longer supports the 32 bit version of Chrome, and that it'ss possible the LL team most likely no longer makes it available and neglected to edit the additional software listing.
Title: Re: Linux Lite won't let me install *any* software
Post by: nomko on March 23, 2016, 05:15:49 AM
Hello!

Regardless of one's skill level, Lubuntu Software Center or Ubuntu Software Center make adding software much easier for folks than Add/Remove Software, a.k.a. Synaptic Package Manager. In both LSC and USC, software is broken down into categories, more detailed explanations are given, and reviews on them can be read and/or submitted.

However, these two programs make changes that can prevent certain kernel updates that LL 'holds back' (for a reason) from being 'held back'. As a result, these programs can 'break' LL to where only reinstalling the OS can fix it...

If you talk about Software Centers breaking down your system... I agree. But that's not the main reason i use Synaptic/terminal for adding removing software

 I ALWAYS use synaptic and NEVER encountered ANY problems. I agree that Ubuntu's Software Center and sort-a-like makes it easier to install programs for (new/inexperienced) users, BUT!!! any Software Center DOES NOT SHOW YOU what will be installed AND WHAT WILL BE REMOVED!!!

In some cases, when installing an application, it happens that certains packages and/or other applications will be removed from your system. Any Software Center will not show you this nor it will inform you about this.

When using Synaptic, and selecting any kind of application you want to install, you will also get an nice overview of what will be installed and what will be removed and what becomes redundant/unchanged. This gives ANY user a better feeling and understanding of what happens when installing software. Same applies when installing applications using the terminal.

But be carefull with synaptic and the terminal. Both are very powerful tools and if you don't pay well enough attention, these tools can break your system as well. But since they are powertools, it gives you a better learning ex[erience and a better understanding of how Linux works.
Title: Re: Linux Lite won't let me install *any* software
Post by: wat killem on March 23, 2016, 10:54:51 PM
Never Mind That Fix The Fxxxxx Sound icon and unmute VLC !!!!!!!!!
Title: Re: Linux Lite won't let me install *any* software
Post by: nomko on March 24, 2016, 06:04:50 AM
Never Mind That Fix The Fxxxxx Sound icon and unmute VLC !!!!!!!!!
??????????
Title: Re: Linux Lite won't let me install *any* software
Post by: ptyerman on March 24, 2016, 09:33:18 AM
Quote
Never Mind That Fix The Fxxxxx Sound icon and unmute VLC !!!!!!!!!

Instead of shouting and swearing, use or install a suitable sound card. That should fix your issues!