You are Here:
Linux Lite 4.8 Final is now available for download and installation



KODI Update failing

Author (Read 5751 times)

0 Members and 1 Guest are viewing this topic.

KODI Update failing
« on: July 09, 2017, 09:39:30 AM »
 

pompeyrodney

  • New to Forums
  • *
  • 18
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Core Two Duo E7500

  • MEMORY: 2Gb

  • VIDEO CARD: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
This is what I receive when trying to update
Code: [Select]
===========================
Install Updates Error log
===========================
Install Updates could not successfully download and install available updates.
Go to https://www.linuxliteos.com/forums/ and paste the log below into a new or existing thread for assistance.

============ Log ===========

Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
The following packages were automatically installed and are no longer required:
  fonts-roboto fonts-roboto-hinted kodi-data libcec3 libhdhomerun2
  libjs-iscroll libplatform2
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  libao-common libao4 libcec4 libcrossguid1 libp8-platform2 libshairplay0
  python-bluez
The following packages will be upgraded:
  kodi kodi-bin
2 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/33.4 MB of archives.
After this operation, 59.2 MB of additional disk space will be used.
Selecting previously unselected package libao-common.
(Reading database ...  (Reading database ... 5% (Reading database ... 10% (Reading database ... 15% (Reading database ... 20% (Reading database ... 25% (Reading database ... 30% (Reading database ... 35% (Reading database ... 40% (Reading database ... 45% (Reading database ... 50% (Reading database ... 55% (Reading database ... 60% (Reading database ... 65% (Reading database ... 70% (Reading database ... 75% (Reading database ... 80% (Reading database ... 85% (Reading database ... 90% (Reading database ... 95% (Reading database ... 100% (Reading database ... 214660 files and directories currently installed.)
Preparing to unpack .../libao-common_1.1.0-3ubuntu1_all.deb ...
Unpacking libao-common (1.1.0-3ubuntu1) ...
Selecting previously unselected package libao4:amd64.
Preparing to unpack .../libao4_1.1.0-3ubuntu1_amd64.deb ...
Unpacking libao4:amd64 (1.1.0-3ubuntu1) ...
Selecting previously unselected package libcrossguid1:amd64.
Preparing to unpack .../libcrossguid1_0.1~git20150807.8f399e8~xenial_amd64.deb ...
Unpacking libcrossguid1:amd64 (0.1~git20150807.8f399e8~xenial) ...
Preparing to unpack .../kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb ...
Unpacking kodi (2:17.3+git20170525.0741-final-0xenial) over (15.2+dfsg1-3ubuntu1.1) ...
dpkg: error processing archive /var/cache/apt/archives/kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb (--unpack):
 trying to overwrite '/usr/share/kodi/userdata/ModeLines_template.xml', which is also in package kodi-data 15.2+dfsg1-3ubuntu1.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.deb ...
Unpacking kodi-bin (2:17.3+git20170525.0741-final-0xenial) over (15.2+dfsg1-3ubuntu1.1) ...
dpkg: error processing archive /var/cache/apt/archives/kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/kodi', which is also in package kodi 15.2+dfsg1-3ubuntu1.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously unselected package python-bluez.
Preparing to unpack .../python-bluez_0.22-1_amd64.deb ...
Unpacking python-bluez (0.22-1) ...
Selecting previously unselected package libshairplay0:amd64.
Preparing to unpack .../libshairplay0_0.9.0.1-2~xenial_amd64.deb ...
Unpacking libshairplay0:amd64 (0.9.0.1-2~xenial) ...
Selecting previously unselected package libp8-platform2:amd64.
Preparing to unpack .../libp8-platform2_2.1.0.1~xenial_amd64.deb ...
Unpacking libp8-platform2:amd64 (2.1.0.1~xenial) ...
Selecting previously unselected package libcec4:amd64.
Preparing to unpack .../libcec4_4.0.1.1~xenial_amd64.deb ...
Unpacking libcec4:amd64 (4.0.1.1~xenial) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Processing triggers for menu (2.1.47ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb
 /var/cache/apt/archives/kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1) /[Code]

Any ideas please?
 


Re: KODI Update failing
« Reply #1 on: July 09, 2017, 03:26:03 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3185
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Have you tried

Code: [Select]
sudo apt autoremove
If you were previously using the repos affected by Sky in June, you may need to use Lite Software to uninstall Kodi then use -

Code: [Select]
sudo apt-get remove kodi*
Code: [Select]
sudo apt-get purge kodi*
Then use Lite Software to install Kodi.

This is what worked for me.
 

Re: KODI Update failing
« Reply #2 on: July 17, 2017, 09:00:40 AM »
 

pompeyrodney

  • New to Forums
  • *
  • 18
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Core Two Duo E7500

  • MEMORY: 2Gb

  • VIDEO CARD: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
Please tell me what you mean by "the repo affected by Sky in June", thanks

Sent from my MotoG3 using Tapatalk

 

Re: KODI Update failing
« Reply #3 on: July 17, 2017, 10:37:11 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1110
    Posts
  • Country: us
  • Reputation: 186
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 4.8 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: KODI Update failing
« Reply #4 on: July 17, 2017, 03:56:35 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3185
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Please tell me what you mean by "the repo affected by Sky in June", thanks

Sent from my MotoG3 using Tapatalk


Sky (media company) took legal action taking down for example Fusion repo, most of SuperRepo, and some of the most popular addons such as Exodus.
Part of that action, causes Kodi to crash, affects updates, such as where people held off on them to prevent stuff, and the like.

Oddly they did not take action against the repo used on Android boxes and phones, that would be the most used one giving away Sky's premium channels.
Although they have targeted / and successfully hit that repo on Debian Kodi, it is down.
Basically it is those on eBay selling open source materials, and the media frenzy that surrounded the very large number of raids that occurred, and the large seizures of multi million GBP from banks, and other illegal products and cash seizures related to that.
1 example being 2 girls who had 3 Million + GBP seized from banks for preloaded SD cards they sold on eBay, in a couple of months time period alone.
Several box seller had double figure Millions GBP seized from bank accounts, plus other assets.

Others have joined on to the action but it was began and is led by Sky media company, who have tried to get Kodi itself banned.
Last Edit: July 17, 2017, 04:17:59 PM by bitsnpcs
 

Re: KODI Update failing
« Reply #5 on: July 17, 2017, 03:57:21 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3185
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
 

Re: KODI Update failing
« Reply #6 on: July 17, 2017, 04:42:21 PM »
 

pompeyrodney

  • New to Forums
  • *
  • 18
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Core Two Duo E7500

  • MEMORY: 2Gb

  • VIDEO CARD: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
Thanks

Sent from my MotoG3 using Tapatalk

 

Re: KODI Update failing
« Reply #7 on: July 17, 2017, 04:45:57 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3185
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
You are welcome :)
 

Re: KODI Update failing
« Reply #8 on: July 18, 2017, 06:23:42 AM »
 

pompeyrodney

  • New to Forums
  • *
  • 18
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Core Two Duo E7500

  • MEMORY: 2Gb

  • VIDEO CARD: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
HiI was not using any other repo than the standard that came with the install. As a consequence I have not removed and re-installed Kodi. If i run sudo apt-get upgrade, it shows Kodi as being held back? When install updates is run it shows an update to Kodi and produces the following
Code: [Select]
===========================Install Updates Error log===========================Install Updates could not successfully download and install available updates.Go to https://www.linuxliteos.com/forums/ and paste the log below into a new or existing thread for assistance.============ Log ===========Reading package lists...Building dependency tree...Reading state information...Calculating upgrade...The following packages were automatically installed and are no longer required:  fonts-roboto fonts-roboto-hinted kodi-data libcec3 libhdhomerun2  libjs-iscroll libplatform2Use 'apt autoremove' to remove them.The following NEW packages will be installed:  libao-common libao4 libcec4 libcrossguid1 libp8-platform2 libshairplay0  linux-headers-4.4.0-86 linux-headers-4.4.0-86-generic  linux-image-4.4.0-86-generic linux-image-extra-4.4.0-86-generic python-bluezThe following packages will be upgraded:  kodi kodi-bin linux-generic linux-headers-generic linux-image-generic5 upgraded, 11 newly installed, 0 to remove and 0 not upgraded.Need to get 68.6 MB/102 MB of archives.After this operation, 356 MB of additional disk space will be used.Get:1 http://ubuntu.positive-internet.com/ubuntu xenial-proposed/main amd64 linux-image-4.4.0-86-generic amd64 4.4.0-86.109 [21.9 MB]Get:2 http://ubuntu.positive-internet.com/ubuntu xenial-proposed/main amd64 linux-image-extra-4.4.0-86-generic amd64 4.4.0-86.109 [35.9 MB]Get:3 http://ubuntu.positive-internet.com/ubuntu xenial-proposed/main amd64 linux-generic amd64 4.4.0.86.92 [1,788 B]Get:4 http://ubuntu.positive-internet.com/ubuntu xenial-proposed/main amd64 linux-image-generic amd64 4.4.0.86.92 [2,288 B]Get:5 http://ubuntu.positive-internet.com/ubuntu xenial-proposed/main amd64 linux-headers-4.4.0-86 all 4.4.0-86.109 [9,966 kB]Get:6 http://ubuntu.positive-internet.com/ubuntu xenial-proposed/main amd64 linux-headers-4.4.0-86-generic amd64 4.4.0-86.109 [787 kB]Get:7 http://ubuntu.positive-internet.com/ubuntu xenial-proposed/main amd64 linux-headers-generic amd64 4.4.0.86.92 [2,262 B]Fetched 68.6 MB in 53s (1,293 kB/s)Selecting previously unselected package libao-common.(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 214662 files and directories currently installed.)Preparing to unpack .../libao-common_1.1.0-3ubuntu1_all.deb ...Unpacking libao-common (1.1.0-3ubuntu1) ...Selecting previously unselected package libao4:amd64.Preparing to unpack .../libao4_1.1.0-3ubuntu1_amd64.deb ...Unpacking libao4:amd64 (1.1.0-3ubuntu1) ...Selecting previously unselected package libcrossguid1:amd64.Preparing to unpack .../libcrossguid1_0.1~git20150807.8f399e8~xenial_amd64.deb ...Unpacking libcrossguid1:amd64 (0.1~git20150807.8f399e8~xenial) ...Preparing to unpack .../kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb ...Unpacking kodi (2:17.3+git20170525.0741-final-0xenial) over (15.2+dfsg1-3ubuntu1.1) ...dpkg: error processing archive /var/cache/apt/archives/kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb (--unpack): trying to overwrite '/usr/share/kodi/userdata/ModeLines_template.xml', which is also in package kodi-data 15.2+dfsg1-3ubuntu1.1dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)Preparing to unpack .../kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.deb ...Unpacking kodi-bin (2:17.3+git20170525.0741-final-0xenial) over (15.2+dfsg1-3ubuntu1.1) ...dpkg: error processing archive /var/cache/apt/archives/kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.deb (--unpack): trying to overwrite '/usr/bin/kodi', which is also in package kodi 15.2+dfsg1-3ubuntu1.1dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)Selecting previously unselected package python-bluez.Preparing to unpack .../python-bluez_0.22-1_amd64.deb ...Unpacking python-bluez (0.22-1) ...Selecting previously unselected package libshairplay0:amd64.Preparing to unpack .../libshairplay0_0.9.0.1-2~xenial_amd64.deb ...Unpacking libshairplay0:amd64 (0.9.0.1-2~xenial) ...Selecting previously unselected package libp8-platform2:amd64.Preparing to unpack .../libp8-platform2_2.1.0.1~xenial_amd64.deb ...Unpacking libp8-platform2:amd64 (2.1.0.1~xenial) ...Selecting previously unselected package libcec4:amd64.Preparing to unpack .../libcec4_4.0.1.1~xenial_amd64.deb ...Unpacking libcec4:amd64 (4.0.1.1~xenial) ...Selecting previously unselected package linux-image-4.4.0-86-generic.Preparing to unpack .../linux-image-4.4.0-86-generic_4.4.0-86.109_amd64.deb ...Examining /etc/kernel/preinst.d/run-parts: executing /etc/kernel/preinst.d/intel-microcode 4.4.0-86-generic /boot/vmlinuz-4.4.0-86-genericDone.Unpacking linux-image-4.4.0-86-generic (4.4.0-86.109) ...Selecting previously unselected package linux-image-extra-4.4.0-86-generic.Preparing to unpack .../linux-image-extra-4.4.0-86-generic_4.4.0-86.109_amd64.deb ...Unpacking linux-image-extra-4.4.0-86-generic (4.4.0-86.109) ...Preparing to unpack .../linux-generic_4.4.0.86.92_amd64.deb ...Unpacking linux-generic (4.4.0.86.92) over (4.4.0.85.91) ...Preparing to unpack .../linux-image-generic_4.4.0.86.92_amd64.deb ...Unpacking linux-image-generic (4.4.0.86.92) over (4.4.0.85.91) ...Selecting previously unselected package linux-headers-4.4.0-86.Preparing to unpack .../linux-headers-4.4.0-86_4.4.0-86.109_all.deb ...Unpacking linux-headers-4.4.0-86 (4.4.0-86.109) ...Selecting previously unselected package linux-headers-4.4.0-86-generic.Preparing to unpack .../linux-headers-4.4.0-86-generic_4.4.0-86.109_amd64.deb ...Unpacking linux-headers-4.4.0-86-generic (4.4.0-86.109) ...Preparing to unpack .../linux-headers-generic_4.4.0.86.92_amd64.deb ...Unpacking linux-headers-generic (4.4.0.86.92) over (4.4.0.85.91) ...Processing triggers for man-db (2.7.5-1) ...Processing triggers for libc-bin (2.23-0ubuntu9) ...Processing triggers for menu (2.1.47ubuntu1) ...Errors were encountered while processing: /var/cache/apt/archives/kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb /var/cache/apt/archives/kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.debE: Sub-process /usr/bin/dpkg returned an error code (1)
 

Re: KODI Update failing
« Reply #9 on: July 18, 2017, 08:58:07 AM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3185
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Hello,

if you do the

Code: [Select]
sudo apt autoremove
it recommends in your results, this will remove those it specifies and reduce the number of errors remaining, it will make it a shorter list of errors to focus on trying to solve.
 

Re: KODI Update failing
« Reply #10 on: July 18, 2017, 02:50:38 PM »
 

pompeyrodney

  • New to Forums
  • *
  • 18
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Core Two Duo E7500

  • MEMORY: 2Gb

  • VIDEO CARD: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
Hi bitsnpcs
I  have run the APT-GET autoremove prior to trying the install again, this is what i get:
[/code]===========================
Install Updates Error log
===========================
Install Updates could not successfully download and install available updates.
Go to https://www.linuxliteos.com/forums/ and paste the log below into a new or existing thread for assistance.


============ Log ===========


Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
The following packages were automatically installed and are no longer required:
  fonts-roboto fonts-roboto-hinted kodi-data libcec3 libhdhomerun2
  libjs-iscroll libplatform2
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  libao-common libao4 libcec4 libcrossguid1 libp8-platform2 libshairplay0
  python-bluez
The following packages will be upgraded:
  kodi kodi-bin
2 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/33.4 MB of archives.
After this operation, 59.2 MB of additional disk space will be used.
Selecting previously unselected package libao-common.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 182579 files and directories currently installed.)
Preparing to unpack .../libao-common_1.1.0-3ubuntu1_all.deb ...
Unpacking libao-common (1.1.0-3ubuntu1) ...
Selecting previously unselected package libao4:amd64.
Preparing to unpack .../libao4_1.1.0-3ubuntu1_amd64.deb ...
Unpacking libao4:amd64 (1.1.0-3ubuntu1) ...
Selecting previously unselected package libcrossguid1:amd64.
Preparing to unpack .../libcrossguid1_0.1~git20150807.8f399e8~xenial_amd64.deb ...
Unpacking libcrossguid1:amd64 (0.1~git20150807.8f399e8~xenial) ...
Preparing to unpack .../kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb ...
Unpacking kodi (2:17.3+git20170525.0741-final-0xenial) over (15.2+dfsg1-3ubuntu1.1) ...
dpkg: error processing archive /var/cache/apt/archives/kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb (--unpack):
 trying to overwrite '/usr/share/kodi/userdata/ModeLines_template.xml', which is also in package kodi-data 15.2+dfsg1-3ubuntu1.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.deb ...
Unpacking kodi-bin (2:17.3+git20170525.0741-final-0xenial) over (15.2+dfsg1-3ubuntu1.1) ...
dpkg: error processing archive /var/cache/apt/archives/kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/kodi', which is also in package kodi 15.2+dfsg1-3ubuntu1.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously unselected package python-bluez.
Preparing to unpack .../python-bluez_0.22-1_amd64.deb ...
Unpacking python-bluez (0.22-1) ...
Selecting previously unselected package libshairplay0:amd64.
Preparing to unpack .../libshairplay0_0.9.0.1-2~xenial_amd64.deb ...
Unpacking libshairplay0:amd64 (0.9.0.1-2~xenial) ...
Selecting previously unselected package libp8-platform2:amd64.
Preparing to unpack .../libp8-platform2_2.1.0.1~xenial_amd64.deb ...
Unpacking libp8-platform2:amd64 (2.1.0.1~xenial) ...
Selecting previously unselected package libcec4:amd64.
Preparing to unpack .../libcec4_4.0.1.1~xenial_amd64.deb ...
Unpacking libcec4:amd64 (4.0.1.1~xenial) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Processing triggers for menu (2.1.47ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb
 /var/cache/apt/archives/kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Code: [Select]
Thanks for any help
 

Re: KODI Update failing
« Reply #11 on: July 18, 2017, 03:08:09 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3185
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Hello,

can you run Menu>System>Lite Tweaks
and select "package cache"
then click begin.

After this use Menu>Favorites>Install Updates

and post any errors.

 

Re: KODI Update failing
« Reply #12 on: July 18, 2017, 04:56:53 PM »
 

pompeyrodney

  • New to Forums
  • *
  • 18
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Core Two Duo E7500

  • MEMORY: 2Gb

  • VIDEO CARD: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
Code: [Select]
Hi
I have done as you suggested and re-run the update, thanks
===========================
Install Updates Error log
===========================
Install Updates could not successfully download and install available updates.
Go to https://www.linuxliteos.com/forums/ and paste the log below into a new or existing thread for assistance.


============ Log ===========


Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
The following packages were automatically installed and are no longer required:
  fonts-roboto fonts-roboto-hinted kodi-data libcec3 libhdhomerun2
  libjs-iscroll libplatform2
Use 'apt autoremove' to remove them.
The following packages will be upgraded:
  kodi kodi-bin
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 33.1 MB of archives.
After this operation, 57.9 MB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial/main amd64 kodi all 2:17.3+git20170525.0741-final-0xenial [20.6 MB]
Get:2 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial/main amd64 kodi-bin amd64 2:17.3+git20170525.0741-final-0xenial [12.5 MB]
Fetched 33.1 MB in 37s (887 kB/s)
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 182647 files and directories currently installed.)
Preparing to unpack .../kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb ...
Unpacking kodi (2:17.3+git20170525.0741-final-0xenial) over (15.2+dfsg1-3ubuntu1.1) ...
dpkg: error processing archive /var/cache/apt/archives/kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb (--unpack):
 trying to overwrite '/usr/share/kodi/userdata/ModeLines_template.xml', which is also in package kodi-data 15.2+dfsg1-3ubuntu1.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.deb ...
Unpacking kodi-bin (2:17.3+git20170525.0741-final-0xenial) over (15.2+dfsg1-3ubuntu1.1) ...
dpkg: error processing archive /var/cache/apt/archives/kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/kodi', which is also in package kodi 15.2+dfsg1-3ubuntu1.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for menu (2.1.47ubuntu1) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Errors were encountered while processing:
 /var/cache/apt/archives/kodi_2%3a17.3+git20170525.0741-final-0xenial_all.deb
 /var/cache/apt/archives/kodi-bin_2%3a17.3+git20170525.0741-final-0xenial_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Re: KODI Update failing
« Reply #13 on: July 19, 2017, 02:41:29 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7439
    Posts
  • Country: nz
  • Reputation: 699
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 3.8 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 960

  • Kernel: 4.x
How did you originally install Kodi? Looks to me like there was a PPA added at some stage.
 

Re: KODI Update failing
« Reply #14 on: July 19, 2017, 07:19:44 AM »
 

pompeyrodney

  • New to Forums
  • *
  • 18
    Posts
  • Country: gb
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.4 64bit

  • CPU: Core Two Duo E7500

  • MEMORY: 2Gb

  • VIDEO CARD: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
How did you originally install Kodi? Looks to me like there was a PPA added at some stage.
Kodi was installed through the install software tool, no PPA was added at all Jerry, thanks for your help

Sent from my MotoG3 using Tapatalk

 


Tags:
 


Linux Lite 4.8 Final is now available for download and installation