You are Here:
Linux Lite 5.0 Final is now available for download and installation



[ SOLVED ] Installing ThinkOrSwim

Author (Read 3248 times)

0 Members and 1 Guest are viewing this topic.

Installing ThinkOrSwim
« on: November 03, 2019, 05:12:22 PM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1548
    Posts
  • Country: us
  • Reputation: 254
  • * Forum Moderator *

  • Linux Lite: 4.8 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics

  • Kernel: 4.x
Getting this popup.  Have a class starting soon and can't get this working.



When I follow the instructions at this site https://mediaserver.thinkorswim.com/installer/install.html, I get the following:


Quote
torrey@LM-Cinn:~/Downloads$ sudo apt-add-repository ppa:webupd8team/java
You are about to add the following PPA:
 The Oracle JDK License has changed for releases starting April 16, 2019.


The new Oracle Technology Network License Agreement for Oracle Java SE is substantially different from prior Oracle JDK licenses. The new license permits certain uses, such as personal use and development use, at no cost -- but other uses authorized under prior Oracle JDK licenses may no longer be available. Please review the terms carefully before downloading and using this product. An FAQ is available here: https://www.oracle.com/technetwork/java/javase/overview/oracle-jdk-faqs.html


Oracle Java downloads now require logging in to an Oracle account to download Java updates, like the latest Oracle Java 8u211 / Java SE 8u212. Because of this I cannot update the PPA with the latest Java (and the old links were broken by Oracle).


For this reason, THIS PPA IS DISCONTINUED (unless I find some way around this limitation).


Oracle Java (JDK) Installer (automatically downloads and installs Oracle JDK8). There are no actual Java files in this PPA.


Important -> Why Oracle Java 7 And 6 Installers No Longer Work: http://www.webupd8.org/2017/06/why-oracle-java-7-and-6-installers-no.html


Update: Oracle Java 9 has reached end of life: http://www.oracle.com/technetwork/java/javase/downloads/jdk9-downloads-3848520.html


The PPA supports Ubuntu 18.10, 18.04, 16.04, 14.04 and 12.04.


More info (and Ubuntu installation instructions):
- http://www.webupd8.org/2012/09/install-oracle-java-8-in-ubuntu-via-ppa.html


Debian installation instructions:
- Oracle Java 8: http://www.webupd8.org/2014/03/how-to-install-oracle-java-8-in-debian.html


For Oracle Java 11, see a different PPA -> https://www.linuxuprising.com/2019/06/new-oracle-java-11-installer-for-ubuntu.html
 More info: https://launchpad.net/~webupd8team/+archive/ubuntu/java
Press Enter to continue or Ctrl+C to cancel



I am already running Java 11:
Quote
torrey@LM-Cinn:~/Downloads$ java -version
openjdk version "11.0.4" 2019-07-16
OpenJDK Runtime Environment (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3)
OpenJDK 64-Bit Server VM (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3, mixed mode, sharing)
Last Edit: November 03, 2019, 07:14:03 PM by torreydale
Want to thank me?  Click my [Thank] link.
 


Re: Installing ThinkOrSwim
« Reply #1 on: November 03, 2019, 06:25:49 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1411
    Posts
  • Country: us
  • Reputation: 255
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
@torreydale

You're running OpenJDk (Open Java) -- the prompt is for Oracle Java... That would be my guess - it maybe dependent on Oracle...
I would hope OpenJDK would be suffice... BUT.....


If you're wanting to try Oracle - here's a link..
https://www.linuxliteos.com/forums/tutorials/install-java-on-linux-lite/


You can snapshot/timeshift/ make a back up point to try and revert back...
LL 4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 

Re: Installing ThinkOrSwim
« Reply #2 on: November 03, 2019, 07:13:51 PM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1548
    Posts
  • Country: us
  • Reputation: 254
  • * Forum Moderator *

  • Linux Lite: 4.8 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics

  • Kernel: 4.x
That did it.  Thank you.
Want to thank me?  Click my [Thank] link.
 

Re: Installing ThinkOrSwim
« Reply #3 on: November 03, 2019, 08:36:48 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1411
    Posts
  • Country: us
  • Reputation: 255
  • Linux Lite Member

  • Linux Lite: 4.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
LL 4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL 4.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL 4.6 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL 3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express
RETIRED LL 2.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA
Running Linux Lite since LL2.2
 


Tags:
 


Linux Lite 5.0 Final is now available for download and installation