You are Here:
Linux Lite 6.0 RC1 Released - See Release Announcements



Installing Coinexx MT4 metatrader using Wine

Author (Read 19223 times)

0 Members and 1 Guest are viewing this topic.

Installing Coinexx MT4 metatrader using Wine
« on: October 29, 2019, 10:28:49 PM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1580
    Posts
  • Reputation: 261
  • * Forum Moderator *

  • Linux Lite: 4.8 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics

  • Kernel: 4.x
When I attempt to install this app using Wine, I get the following popup:

 

Odd thing is my other laptop runs Linux Mint and the install went fine without this popup.  This app works on Linux; not sure why I'm having this roadblock with Linux Lite.  I was using Cloudflare (1.1.1.1) as my primary DNS for my Linux Lite laptop.  But when I changed it to match what my Linux Mint machine was running for primary and secondary DNS, that didn't make a difference.  Same popup.  I also didn't notice anything unusual with the laptop's local firewall (GUFW). 


Really appreciate any ideas.  We have some time.  I start a class on this stuff early next week.  I'd like to get the problem solved by then.


Cheers
« Last Edit: October 30, 2019, 01:16:23 AM by torreydale »
Want to thank me?  Click my [Thank] link.
 

Re: Installing Coinexx MT4 metatrader using Wine
« Reply #1 on: October 29, 2019, 10:35:23 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8275
    Posts
  • Reputation: 776
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
A quick Google search - https://www.mql5.com/en/forum/60250/page2 Uninstall, clear all trace of it cache etc. Then get wine staging.
 

Re: Installing Coinexx MT4 metatrader using Wine
« Reply #2 on: October 29, 2019, 10:49:46 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8275
    Posts
  • Reputation: 776
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
After adding the wine repo, you'll get a complaint when you try to installing wine-staging, so change the repo details from bionic to xenial, then it will all work, or just do this:

Code: [Select]
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main'
sudo apt install --install-recommends winehq-staging
 

Re: Installing Coinexx MT4 metatrader using Wine
« Reply #3 on: October 29, 2019, 11:03:14 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8275
    Posts
  • Reputation: 776
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
No Menu entries for Wine? LL to the rescue - http://repo.linuxliteos.com/linuxlite/pool/main/w/wine-menu-linuxlite/wine-menu-linuxlite_4.0-0020_all.deb

Make sure to config Wine for Windblows 10.

Bob's your Uncle...



 

Re: Installing Coinexx MT4 metatrader using Wine
« Reply #4 on: October 30, 2019, 01:17:36 AM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1580
    Posts
  • Reputation: 261
  • * Forum Moderator *

  • Linux Lite: 4.8 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics

  • Kernel: 4.x
Done deal.  Thank you.  Bookmarked for future reference.
Want to thank me?  Click my [Thank] link.
 

Re: Installing Coinexx MT4 metatrader using Wine
« Reply #5 on: October 30, 2019, 09:00:09 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1348
    Posts
  • Reputation: 209
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 5.8 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: Installing Coinexx MT4 metatrader using Wine
« Reply #6 on: October 30, 2019, 09:06:17 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 8275
    Posts
  • Reputation: 776
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.6 64bit

  • CPU: Intel Core i9-10850K CPU @ 3.60GHz

  • MEMORY: 32Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
He said in his post he has a class in it. So it's probably less about an advantage and more about having to.

Sent from my Mobile phone using Tapatalk

 

Re: Installing Coinexx MT4 metatrader using Wine
« Reply #7 on: October 30, 2019, 10:35:36 AM »
 

trinidad

  • Platinum Level Poster
  • **********
  • 1348
    Posts
  • Reputation: 209
  • Linux Lite Member
    • dbts-analytics.com

  • Linux Lite: 5.8 64bit

  • CPU: AMD A8 5500 4 cores

  • MEMORY: 8Gb

  • VIDEO CARD: AMD/ATI Radeon HD 7560D

  • Kernel: 5.x
Apologies. Missed that.

TC
All opinions expressed and all advice given by Trinidad Cruz on this forum are his responsibility alone and do not necessarily reflect the views or methods of the developers of Linux Lite. He is a citizen of the United States where it is acceptable to occasionally be uninformed and inept as long as you pay your taxes.
 

Re: Installing Coinexx MT4 metatrader using Wine
« Reply #8 on: March 10, 2022, 12:32:17 PM »
 

K_Collins

  • New to Forums
  • *
  • 9
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.8 64bit
After adding the wine repo, you'll get a complaint when you try to installing wine-staging,
so change the repo details from bionic to xenial, then it will all work, or just do this:

Code: [Select]
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main'
sudo apt install --install-recommends winehq-staging

Is there a reason the xenial main repository was chosen,
or does Linux Lite always follow the previous Ubuntu LTS version?
« Last Edit: March 10, 2022, 02:01:26 PM by K_Collins »
 

Re: Installing Coinexx MT4 metatrader using Wine
« Reply #9 on: March 10, 2022, 03:10:24 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1768
    Posts
  • Reputation: 278
  • Linux Lite Member

  • Linux Lite: 5.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
@K_Collins You're replying to an older thread..
LL is based on Ubuntu LTS - LL5.8 is based on 20.04 - Focal

You can find this info in the Release Announcements..
https://www.linuxliteos.com/forums/release-announcements/linux-lite-5-8-final-released/
LL4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL5.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL4.8 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express  -- Shelved
BACK LL5.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA - Print Server
Running Linux Lite since LL2.2
 

Re: Installing Coinexx MT4 metatrader using Wine
« Reply #10 on: March 10, 2022, 06:05:18 PM »
 

K_Collins

  • New to Forums
  • *
  • 9
    Posts
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 5.8 64bit
Oh ok....

So, when I install or upgrade to the next LL release...I will transition to the "22.04 - jammy" level?
 

Re: Installing Coinexx MT4 metatrader using Wine
« Reply #11 on: March 10, 2022, 08:30:57 PM »
 

firenice03

  • Rockin' the FREE World
  • Global Moderator
  • Platinum Level Poster
  • *****
  • 1768
    Posts
  • Reputation: 278
  • Linux Lite Member

  • Linux Lite: 5.8 64bit

  • CPU: AMD E2//Atom X5//AMD Phenom II X2

  • MEMORY: 4Gb

  • VIDEO CARD: AMD Mullin Radeon R2//Intel//AMD/ATI RS880

  • Kernel: 5.x
So LL5.8 is the last of this series.
You will need to do a fresh install for LL6.0 and any point upgrade 6.2 6.4 etc is a seamless upgrade.

Yes 6.0 will be based on the LTS of Ubuntu at the time - likely 22.04.

LL5.x will still be supported unit 4/2025; I still have systems on the 4.x series.
https://www.linuxliteos.com/download.php#roadmap
LL4.8 UEFI 64 bit ASUS E402W - AMD E2 (Quad) 1.5Ghz  - 4GB - AMD Mullins Radeon R2
LL5.8 UEFI 64 bit Test UEFI Kangaroo (Mobile Desktop) - Atom X5-Z8500 1.44Ghz - 2GB - Intel HD Graphics
LL4.8 64 bit HP 6005- AMD Phenom II X2 - 8GB - AMD/ATI RS880 (HD4200)
LL3.8 32 bit Dell Inspiron Mini - Atom N270 1.6Ghz - 1GB - Intel Mobile 945GSE Express  -- Shelved
BACK LL5.8 64 bit Dell Optiplex 160 (Thin) - Atom 230 1.6Ghz - 4GB-SiS 771/671 PCIE VGA - Print Server
Running Linux Lite since LL2.2
 

 

-->
X Close Ad

Linux Lite 6.0 RC1 Released - See Release Announcements