You are Here:
Linux Lite 5.0 Final is now available for download and installation



[ SOLVED ] Install Updates error Intel Graphics Stack

Author (Read 2859 times)

0 Members and 1 Guest are viewing this topic.

Install Updates error Intel Graphics Stack
« on: February 17, 2017, 06:50:23 PM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3180
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Hello,

I have an error -

Process as follows, I use Menu>Install Updates

It says these 2 updates are available -

1 :    Name: libcairo-gobject2 INSTALLED: 1.14.6-1 AVAILABLE: 1.15.2-0intel1
2 :    Name: python-crypto INSTALLED: 2.6.1-6ubuntu0.16.04.1 AVAILABLE: 2.6.1-6ubuntu0.16.04.2

Installing gives an error gui saying -
Linux Lite Updates have failed. For more information refer to:
 
/var/log/llupdates.log

The log file referred to says -
Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
The following packages will be upgraded:
  libcairo-gobject2 python-crypto
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 379 kB of archives.
After this operation, 0 B of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  libcairo-gobject2
E: There were unauthenticated packages and -y was used without --allow-unauthenticated

Edit -
I have used Lite Tweak and clean the packages, the python-crypto error has now gone.

I think the gobject error is the intel graphics stack as 1.15.2 is the newer version of this.
I have tried updating this using the gui from the menu that it added on install, it has updated version 1.14, but not updated to 1.15.
Rechecking Install updates the error remains for 1.15.2
Last Edit: February 19, 2017, 03:02:29 AM by bitsnpcs
 


Re: Install Updates error Intel Graphics Stack
« Reply #1 on: February 18, 2017, 09:18:46 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7694
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Does having the Intel graphics stack significantly improve your computing experience? If you absolutely need it, consider using the latest for 16.04 base instead - https://01.org/linuxgraphics/downloads/intel-graphics-update-tool-linux-os-v2.0.2
If you don't, just go back to the original ones we ship.
 

Re: Install Updates error Intel Graphics Stack
« Reply #2 on: February 18, 2017, 09:30:50 AM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3180
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Hello Jerry,

this is the one installed currently.

It improves things in that I do not need to use nomodeset edit to get to the desktop, and I don't get errors in updates about i915 driver is missing.
There were never any options to install graphics drivers.

When I tried ubuntu it auto installed updates which included a driver called Gallium which totally messed things up.

Graphics ability wise no, the stack has not improved anything, it is still a maximum of 1024x768 resolution and it still has artifacts on video (little transparent sublines)
 

Re: Install Updates error Intel Graphics Stack
« Reply #3 on: February 18, 2017, 09:45:58 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7694
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
Does Install Updates work without a hitch? If not, try:

Code: [Select]
sudo apt-get update
sudo apt-get install -f
sudo apt-get dist-upgrade
 

Re: Install Updates error Intel Graphics Stack
« Reply #4 on: February 18, 2017, 10:12:08 AM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3180
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Install updates works for everything else, this is a recent error for the two updates, now only for the 1.
I have added this and it produces this result, at the end after update and upgrade -

Code: [Select]
W: GPG error: https://download.01.org/gfx/ubuntu/16.04/main xenial InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 56A3DEF863961D39
W: The repository 'https://download.01.org/gfx/ubuntu/16.04/main xenial InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure( manpage for repository creation and user configuration details.
Last Edit: February 18, 2017, 10:16:20 AM by bitsnpcs
 

Re: Install Updates error Intel Graphics Stack
« Reply #5 on: February 18, 2017, 08:00:39 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7694
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
 

Re: Install Updates error Intel Graphics Stack
« Reply #6 on: February 19, 2017, 03:02:06 AM »
 

bitsnpcs

  • Platinum Level Poster
  • **********
  • 3180
    Posts
  • Country: 00
  • Reputation: 300

  • Linux Lite: 3.2 64bit
Thank you Jerry  :)
On the link I tried the one below, if it helps others.

Code: [Select]
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 56A3DEF863961D39
sudo apt-get update
Last Edit: February 19, 2017, 03:13:47 AM by bitsnpcs
 

Re: Install Updates error Intel Graphics Stack
« Reply #7 on: February 19, 2017, 03:18:21 AM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7694
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
No problemo :)

Sent from my mobile phone using Tapatalk

 


Tags:
 


Linux Lite 5.0 Final is now available for download and installation