You are Here:
Linux Lite 5.0 Final is now available for download and installation



[ SOLVED ] How do I install Opera browser without corrupting Linux Lite?

Author (Read 3487 times)

0 Members and 3 Guests are viewing this topic.

How do I install Opera browser without corrupting Linux Lite?
« on: January 23, 2017, 11:24:37 AM »
 

JES49

  • New to Forums
  • *
  • 3
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Celeron N3050

  • MEMORY: 2Gb
I am new to Linux and recently installed Linux Lite 3.2.

When I installed Opera browser using .deb file from Opera web site, I found that the menu option "Install Updates" no longer worked. I would get the error message "Failed to execute command "/usr/scripts/updates-gui" (no such file on directory)". I know that the Opera install caused the problem because I reinstalled Linux Lite and kept testing "Install Updates" while modifying the system to my liking.

Any idea what I'm doing wrong and how I can install Opera cleanly?

Thank you.

Last Edit: January 24, 2017, 11:02:56 AM by JES49
 


Re: How do I install Opera browser without corrupting Linux Lite?
« Reply #1 on: January 23, 2017, 12:55:41 PM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1548
    Posts
  • Country: us
  • Reputation: 254
  • * Forum Moderator *

  • Linux Lite: 4.8 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics

  • Kernel: 4.x
Have you opened your file manager to see if that file exists?  Open up the Home Folder File Manager (Menu > My Computer > File System) and put /usr/scripts in the address bar.  Then see if updates-gui exists there.
Want to thank me?  Click my [Thank] link.
 

Re: How do I install Opera browser without corrupting Linux Lite?
« Reply #2 on: January 23, 2017, 02:17:21 PM »
 

richtea

  • Occasional Poster
  • **
  • 57
    Posts
  • Country: 00
  • Reputation: 5
  • Linux Lite Member

  • Linux Lite: 2.8 32bit

  • CPU: E3815 @ 1.46 GHz

  • MEMORY: 4Gb

  • VIDEO CARD: Intel Atom Z36xxx/Z37xxx Series
Using Opera as a backup browser on 2.8, no trouble with standard installation.
If you are primarily after speed, try the Slimjet browser - stable, brisk, no issues.
Terry Davis Command Line video cracks me up.
Quod delere vos ego faciam permanens.
 

Re: How do I install Opera browser without corrupting Linux Lite?
« Reply #3 on: January 23, 2017, 02:22:20 PM »
 

JES49

  • New to Forums
  • *
  • 3
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Celeron N3050

  • MEMORY: 2Gb
OK, I retraced my steps:

1. Install Linux Lite - OK
2. Use menu option "Install Updates" - OK
3. Check for "/usr/scripts/updates-gui" - OK
4. Load and double-click Opera ".deb" file to install - OK
5. Check for "/usr/scripts/updates-gui" - "scripts" folder gone

Opera seems to work fine. Any ideas?
 

Re: How do I install Opera browser without corrupting Linux Lite?
« Reply #4 on: January 23, 2017, 04:10:16 PM »
 

torreydale

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1548
    Posts
  • Country: us
  • Reputation: 254
  • * Forum Moderator *

  • Linux Lite: 4.8 64bit

  • CPU: Intel Core i5-5300U (-HT-MCP-)

  • MEMORY: 8Gb

  • VIDEO CARD: Intel Broadwell-U Integrated Graphics

  • Kernel: 4.x
I'm having trouble reconciling your point 3 with your point 5. 

You might consider running the Package System Repair option of Lite Tweaks.
Want to thank me?  Click my [Thank] link.
 

Re: How do I install Opera browser without corrupting Linux Lite?
« Reply #5 on: January 23, 2017, 05:47:24 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7694
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
#3 post, I can't reproduce this error in my test machine.

 

Re: How do I install Opera browser without corrupting Linux Lite?
« Reply #6 on: January 23, 2017, 06:15:50 PM »
 

JES49

  • New to Forums
  • *
  • 3
    Posts
  • Country: us
  • Reputation: 0
  • Linux Lite Member

  • Linux Lite: 3.2 64bit

  • CPU: Intel Celeron N3050

  • MEMORY: 2Gb
I noticed that my Opera ".deb" file was 32-bit, not 64-bit like the version of Linux Lite I installed. I reran the steps that I listed above using a 64-bit version of Opera and everything seems to be working OK now. Thanks everyone.
 

Re: How do I install Opera browser without corrupting Linux Lite?
« Reply #7 on: January 23, 2017, 06:17:40 PM »
 

Jerry

  • Linux Lite Creator
  • Administrator
  • Platinum Level Poster
  • *****
  • 7694
    Posts
  • Country: nz
  • Reputation: 728
  • Linux Lite Member
    • Linux Lite OS

  • Linux Lite: 5.0 64bit

  • CPU: Intel Xeon Dual CPU's E5645 2.4GHz 12 Cores

  • MEMORY: 16Gb

  • VIDEO CARD: nVidia GeForce GTX 1650

  • Kernel: 5.x
 


Tags:
 


Linux Lite 5.0 Final is now available for download and installation