Linux Lite Forums

Software - Support => Installing Software => Topic started by: Nuginity on April 06, 2019, 10:56:58 PM

Title: Help me, i can't install VLC
Post by: Nuginity on April 06, 2019, 10:56:58 PM
Can someone Help me with installing VLC media player for Linux Lite 4.4
when i trying to install, it showing:
Code: [Select]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-plugin-video-output (= 3.0.1-3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


-sorry for my bad english
Title: Re: Help me, i can't install VLC
Post by: bitsnpcs on April 06, 2019, 11:52:24 PM
Hello Nuginity,

these are the software install, and uninstall, guide -

https://www.linuxliteos.com/manual/software.html#instsoftware (https://www.linuxliteos.com/manual/software.html#instsoftware)
Title: Re: Help me, i can't install VLC
Post by: Jerry on April 07, 2019, 12:01:37 AM
VLC is already installed, there is no need to install it again.
Title: Re: Help me, i can't install VLC
Post by: Nuginity on April 07, 2019, 12:35:28 AM
i don't know what happen, the VLC dissapear from my linux, and i tried to install it again, and it say i need to fix the broken packages, and when i tried to fix that
the synaptic says :
Code: [Select]
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
Title: Re: Help me, i can't install VLC
Post by: Jerry on April 07, 2019, 12:43:47 AM
What is the output of:

Code: [Select]
grep -r --include '*.list' '^deb ' /etc/apt/ | sed -re 's/^\/etc\/apt\/sources\.list((\.d\/)?|(:)?)//' -e 's/(.*\.list):/\[\1\] /' -e 's/deb http:\/\/ppa.launchpad.net\/(.*?)\/ubuntu .*/ppa:\1/'
Title: Re: Help me, i can't install VLC
Post by: Nuginity on April 07, 2019, 01:25:11 AM
here is it :
Code: [Select]
[otto-kesselgulasch-ubuntu-gimp-xenial.list] ppa:otto-kesselgulasch/gimp
[vscode.list] deb [arch=amd64] http://packages.microsoft.com/repos/vscode stable main
[nemonein-ubuntu-bomi-bionic.list] ppa:nemonein/bomi
[linuxlite.list] deb http://repo.linuxliteos.com/linuxlite/ diamond main
[leaeasy-ubuntu-dde-bionic.list] ppa:leaeasy/dde
[canonical-chromium-builds-ubuntu-stage-bionic.list] ppa:canonical-chromium-builds/stage
[noobslab-ubuntu-apps-bionic.list] ppa:noobslab/apps
[teejee2008-ubuntu-ppa-bionic.list] ppa:teejee2008/ppa
deb http://repo.unpatti.ac.id/ubuntu/ bionic main restricted universe multiverse
deb http://repo.unpatti.ac.id/ubuntu/ bionic-security main restricted universe multiverse
deb http://repo.unpatti.ac.id/ubuntu/ bionic-updates main restricted universe multiverse
deb http://repo.unpatti.ac.id/ubuntu/ bionic-backports main restricted universe multiverse
deb http://archive.canonical.com/ubuntu bionic partner
deb [arch=amd64] https://packages.microsoft.com/repos/vscode stable main
Title: Re: Help me, i can't install VLC
Post by: Jerry on April 07, 2019, 01:33:14 AM
Now:

Code: [Select]
apt policy vlc
Title: Re: Help me, i can't install VLC
Post by: Nuginity on April 07, 2019, 01:40:18 AM
it showing :
Code: [Select]
vlc:
  Installed: (none)
  Candidate: 3.0.1-3
  Version table:
     3.0.1-3 500
        500 http://repo.unpatti.ac.id/ubuntu bionic/universe amd64 Packages
Title: Re: Help me, i can't install VLC
Post by: ralphy on April 07, 2019, 02:23:16 AM
The following packages have unmet dependencies:
 vlc : Depends: vlc-plugin-video-output (= 3.0.1-3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Try the following from Terminal:

Code: [Select]
sudo dpkg --configure -a
sudo apt-get install -f
sudo apt install vlc

It might help.