You are Here:
Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.



Ham-radio software

Author (Read 1334 times)

0 Members and 1 Guest are viewing this topic.

Ham-radio software
« on: April 14, 2016, 10:56:55 AM »
 

arxontas

  • New to Forums
  • *
  • 49
    Posts
  • Country: ca
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: AMD Athlon (TM) 64 processor 3500+

  • MEMORY: 3Gb

  • VIDEO CARD: OpenGL Renderer Mesa DRI Intel(R) G33 x86/MMX/SSE2
First i do not know if this is the correct place to post abt ham-radio.
I use linux lite for abt 3-4 months.
I like to learn how to  install ax25  ,jnos ,and more.
Is there any step by step how to do it??
I have try some but it is not like windows to install.
Thanks
arxontas

If this is not the correct forume ,please delete this post.


 


Re: Ham-radio software
« Reply #1 on: April 14, 2016, 12:17:47 PM »
 

Wirezfree

  • PayPal Supporter
  • Platinum Level Poster
  • *****
  • 1484
    Posts
  • Country: gb
  • Reputation: 404
  • Linux Lite "Advocate"

  • Linux Lite: 2.8 64bit

  • CPU: i7-4790S

  • MEMORY: 16Gb

  • VIDEO CARD: Intel HD4600 (Integrated)
Hi,

I'm also a Radio Ham... I have been running various apps on LL for a while.
Yes, it is a bit different on Linux in general, especially when using USB to control radios.
I have not used the the AX25 protocol myself or jnos.

I have been using: fldigi, flrig and wspr (digi modes)

Here are a couple of links to get you started:
http://www.hamradioandvision.com/installing-fldigi-for-linux/
https://launchpad.net/~kamalmostafa/+archive/ubuntu/fldigi

Examples, (all done in a terminal, apps end up in Ham Radio in Main Menu)
To install wspr:
Code: [Select]
sudo add-apt-repository ppa:ki7mt/wspr
sudo apt-get update
sudo apt-get install libjack0libjack-jackd2-dev
sudo apt-get install portaudio19-dev

To ensure that CAT/USB control works:
Code: [Select]
sudo usermod -aG dialout username((where username = your current logged in username))

Code: [Select]
sudo apt-get install wspr
To install fldigi:
Code: [Select]
sudo add-apt-repository ppa:kamalmostafa/fldigi
sudo apt-get update
sudo apt-get install fldigi


GL ~ 73 ~ G8LIY


Upgrades WIP 2.6 to 2.8 - (6 X 2.6 to 2.8 completed on: 20/02/16 All O.K )
Linux Lite 3.0 Humming on a ASRock N3070 Mobo ~ btrfs RAID 10 Install on 4 Disks :)

Computers Early days:
ZX Spectrum(1982) , HP-150 MS-DOS(1983) , Amstrad CPC464(1984) ,  BBC Micro B+64(1985) , My First PC HP-Vectra(1987)
 

Re: Ham-radio software
« Reply #2 on: April 14, 2016, 07:35:00 PM »
 

arxontas

  • New to Forums
  • *
  • 49
    Posts
  • Country: ca
  • Reputation: 6
  • Linux Lite Member

  • Linux Lite: 3.8 32bit

  • CPU: AMD Athlon (TM) 64 processor 3500+

  • MEMORY: 3Gb

  • VIDEO CARD: OpenGL Renderer Mesa DRI Intel(R) G33 x86/MMX/SSE2
Thanks for the info OM.
I will try it and see what i be ale to do here.
Yes the commands are deferent in linux and that's where it get's me.
I have two old  pc's and i will play till i get it .
I know there are not to many of us  in the packet mode any more. But there is a uronodes now  rms=winlink and some more .
i do digital  psk31 sstv  ,but be nice to keep in life the old packet-radio.
again thanks for the info
73 de ve3clg
 


Tags:
 


Linux Lite 4.6 Final has been released. See the Release Announcements section for more information.